Working Pi last night. Now power and OK LEDs only

12 posts
by jayleekay » Wed Jun 13, 2012 3:28 pm
I received my pi yesterday and thought I'd load up Raspbmc RC2. Initially had some issues with insufficient power. I finally found a fully working power supply after the 3rd test. Install went smooth, no problems and the software installed. All hardware worked: ethernet pulled dhcp and I was able to ftp into the system and pick up network shares, my usb receiver for my remote worked, and the wireless keyboard and mouse both worked.

I decided to load up my SMB share for some videos inside XBMC and I let it run for a few hours pulling in the videos. At some point I turned the TV off that it was attached to. I come back a few hours later and there are a multitude of illegible errors behind the XBMC gui. So I decide to reboot.

Pi starts to boot. I get a plethora of "error whilst ...SD CARD" error -84 and -110. The Power LED is the only light illuminated. Also get a "Problem bringing up eth0 error" and other times an "eth0 could not start because it doesn't exist" or something similar.

Tried again. No SD CARD error this time but tons of mc0 errors.

So, I thought I'd just reimage the SDCard. In fact, I made 2 images both on brand new sd cards.

One is a Patriot LX 8gb Class 10
The other a Kingston 4gb Class 4

Both are on the known working list by the way.

By reinstalling the image I got rid of the error -84s and -110s.

At this point I have no USB, no Ethernet, and the system goes to a command line login for Raspbmc, which I have never seen before. I know the USB isn't working because it asks me for a login and when I use the keyboard nothing happens.

My main question is: The hardware lights on the board, are they lit up by something loaded from the SD Cards? Or should they be on no matter what if they're working?

I only have a red power light and the ok light flashes while the card is loading. I believe it stays on once the system goes to the login prompt. I have no fox, lnk, or 10m lights.

I've also made sure that the only thing connected is my hdmi cable and I still have the same issues.

I'm also going to repost this in the raspbmc forum just in case it's a software issue and not a hardware issue.
Posts: 6
Joined: Thu Jun 07, 2012 1:22 pm
by texy » Wed Jun 13, 2012 4:00 pm
I,ve never tried the raspbmc images, but can you try the latest Debian image, not from the downloads page, but highlighted in this thread :

It has recent firmware that handles high speed SD cards much better.

Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
Forum Moderator
Forum Moderator
Posts: 4955
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England
by jayleekay » Wed Jun 13, 2012 4:48 pm
Even the Class 4 was having issues.

That is my next step though. Well, I was going to try the Debian6 from the downloads first. I'm just worried that it's a hardware problem.
Posts: 6
Joined: Thu Jun 07, 2012 1:22 pm
by jayleekay » Thu Jun 14, 2012 7:33 pm
Well I've given up. Tried Debian build. Built it on a few different card readers on a few different cards. Same problem. No eth0 and no usb devices work. Even dug around and found a 5v 1000mah power supply with no luck. So I decided that I've been defeated on this one.

Checked into returning this little guy and I have to ship it back at my own expense before they issue a return within 14 days of recieving??? No advanced return or free shipping back for a faulty unit? I had to pay for this thing a month in advance. The least they could do is send me one when it's available and have me ship the faulty unit back in the same packaging with prepaid shipping.

Wow..... kick a man when he's down why don't ya.
Posts: 6
Joined: Thu Jun 07, 2012 1:22 pm
by GeoDave » Tue Jun 19, 2012 7:31 pm
I have the exact same problems. I got my a couple weeks ago. Maybe this is a bad batch?
Posts: 3
Joined: Mon Jun 04, 2012 3:29 am
by markyd » Tue Jun 19, 2012 8:31 pm
I have a similar issue which I have posted else where in the forum :

Initial feedback on Wheezy is excellent with a swanky new "raspi-config" that sets up a lot of the initial gotchas like HDMI screen size etc and the config file is now created and pre-populated with rem statements to un-rem to activate various features like overscan etc and even over-clocking (for the brave) but more than that I cant comment as all of a sudden my Pi has become unreliable, locking up, loosing USB and or network after a few minutes on either the previous reliable Squeeze build or the new Wheezy. Final testing was in headless / keyboard / mouse less just network and power ... not using it I kept a continuous ping going to it and it lasted 3 minutes :-( sob what's up with my Pi?

Forum entry:
Posts: 40
Joined: Fri Jan 13, 2012 11:40 am
by eamon » Tue Jun 19, 2012 9:34 pm
So, I'm in the same situation.... if left off for a while (30minutes or so) it will boot fine and stay on net for about 10 minutes.... then bang.... Off net! Power + OK lights on, but FDX +Lnk +10M flash on/off in sequence with the link up/ link down message on console. This happens with pretty much any OS I've tried. rebooting just gets to the same off-net state, but much sooner. This happened from day 1, but jsut haven't had time to look into it in detail... so, from reading this post, looks like I'm past the 14days return.

However, would be reluctant to buy another.... not confident that there is any reliability behind them now.... Once bitten and all that. :-(

Short of running it while sitting on an ice pack, does anyone have any real suggestions?
User avatar
Posts: 3
Joined: Fri Jun 08, 2012 8:56 pm
by john.c » Tue Jun 26, 2012 10:56 am
I was getting the same error just before.
error whilst ...SD CARD" error -84 and -110

I tried re-installing the OS on the SD card with no success.

However I managed to get it working again.

I wiped the card totally using fdisk, deleted all the partitions.
Then loaded the OS back onto the SD card using the image.

It now boots again with no errors.

I wonder if there are issues with SD cards not being designed for this sort of work?
I am surprised there is no way of booting from USB.
User avatar
Posts: 16
Joined: Tue Jun 26, 2012 10:52 am
Location: Adelaide, South Australia
by jayleekay » Tue Jun 26, 2012 9:19 pm
Mine ended up being a combination of problems. I got over the SD errors. Found out that the x1 has failed on this thing. I put it in the freezer for about an hour and after plugging it back up the eth0 and usb worked for approximately 15 seconds. Install started then boom, it went down again.

I'm not soldering this x1 chip because I lack the skillz. So, I'm selling it. If it doesn't sell then I'm just going to trash it. Emailed Mike@RS the day he went on vacation and never heard back from anyone. I was given the advice to just fill out the paperwork and return it. Just not worth the hassle. Advanced replacement was not an option apparently.
Posts: 6
Joined: Thu Jun 07, 2012 1:22 pm
by IDE » Mon Jul 02, 2012 8:04 am
Same issue with two model B boards here. I've bought supported SD cards listed in the Wiki, 1amp and 2amps usb power supply, two usb hub..

The wiki says there is 1 out of 1000 boards being defective. I may have got real lucky getting two bads boards.

They BOTH worked for the first evening. Next day all the same issues described here are happening to me.

Lol, they say SD cards problems can be fixed with rpi-update, well lol i cant access the console since no usb/network is avail. I have max233 at my office but what's the point if it's a defective unit in the first place.

I say either ask for an exchange, or get a full refund. This is a non functional product. Well, to be more precise, we are part of the few who has defective boards, lets send them for RMA.
Posts: 52
Joined: Fri Jan 13, 2012 12:28 am
by dom » Mon Jul 02, 2012 8:45 am
IDE wrote:Lol, they say SD cards problems can be fixed with rpi-update, well lol i cant access the console since no usb/network is avail. ... g_firmware
describes how to update firmware when sdcard is not booting, by downloading from GitHub.

Or use the newer Wheezy image:
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5070
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by IDE » Sun May 05, 2013 6:22 pm
Hello again everyone!

I am back on the forums. After many months of wait, I've bought back another rPi. This time the clock crystals are properly soldered and I am not experiencing any troubles anymore. Time to get productive!

I'd like to thank everyone in the rPi project especially for those who worked out the manufacturing bugs. I am very hyped to see this piece of hardware finally functional for me. I cannot thank you guys enough. :)
Posts: 52
Joined: Fri Jan 13, 2012 12:28 am