Page 1 of 1

Deauthenticated due to local deauth request

Posted: Mon Jul 28, 2014 12:50 pm
by valmanza83
People of the internet and the raspberry pi community i ask for your help. Im having an issue with raspbian configured as an access point. The error i'm getting is "deauthenticated due to local deauth request." I have seen this error floating around the internet allot while using the pi as an access point. I will try to provide as much detail as possible to clear up any confusion. Anything i miss just ask and i will provide. Also if you can provide the command starting with sudo.... i'm still new at this and will by no means call myself anything more than a newbie.

here is my hardware/software im using (everything was purchased from
raspbian: 3.12.25+ #700
usb wifi dongle: realtek RTL8188CUS (mini and with antenna)
Power supply: usb port - 5v 1a plug or GPIO pins - battery pack lithium ion 3.7v 6600mAh with charger (not both at the same time, DUH!)
sdcard: patriot lx series 8gb class 10
Main tutorial came from adafruit but i found others out there that showed me how to install and configure openvpn and route all the data thru tun0 and not eth0. I have combined a few of tutorials together. My reasons for this are my own why i need this. I seem to have everything setup correctly as everything boots up with no errors except for the one in the title after connecting and using it. Here is my mega tutorial....

Code: Select all
if anyone sees anything that stands out at them as a potential problem and why. ill fix it so can get up and running. Here is how i am getting this issue. I connect my phone to the pi AP and load youtube. Why do i load youtube? Simple, it demands a lot of bandwidth. If i were to open up just an rss feed i can be on that for a while till i get booted of the PI AP however with a youtube video running at 720p i get about 40mb or so till the PI AP stops sending my phone the video. On my phone i can see in the status bar my incoming and out going data, for my phone only, when that stops i know it disconnected from the PI but just wait it gets better. When its about to disconnect my phone hangs waiting for more of the video for about 5 mins till the pi releases my phone and than the phone switches to another wifi or 4g and i then see the error on the PI AP log. It doesn't matter if i have a pc, android, or ios connected to the PI AP all the devices are dropped when trying to just stream a video. All at the same time this is going on the wifi light on the dongle is lighting up like its transmitting but my phone is trying to buffer the video.

what i have tried.....
1. different hostapd files, straight from realtek, the version listed on adafruit tutorial and the latest version on realtek website
2. different drivers (see here yes they do work
3. use haveged (some forums said this helped for the error i'm getting, it did not, obviously)
4. use 2 different wifi dongles (the nano and one with antenna sold at adafruit)
5. different power sources, length of usb cable, gage thickness of usb cable
6. location and signal channel of RPI AP ( prevent/reduce interference)
7. different Sd cards (regular, micro, class 2, 4, 10, size 4, 8, 16gb)
8. different iso (rasbpian iso, NOOBS iso network install)
probably more but i can't think straight because this is racking my brain. i have been on this for about a month now.

what i haven't tried, but want to, is to try a new wifi dongle that has an antenna and DOESN'T need a usb hub. Also preferable works out of the box and inexpensive. If anyone knows a wifi dongle that fits the bill please post the purchase link with the drivers, if needed, link.

so what does all of this tell me it most likely is? its a software level issue and its way out of my depth. So i ask you if you know what it may be to please help because this problem frustrating me but i can't leave it alone just yet.

Thanks for reading

Re: Deauthenticated due to local deauth request

Posted: Fri Sep 05, 2014 4:56 pm
by andies
I am having the same issue. The surprise is: I used to have an older version of raspbian with no problems at all and switched to a new version (using apt-get update and upgrade) and suddenly, without changing the conf-files, I cannot connect to my access point anymore. I suspect a kernel issue here.

See: Took me a day until I found out :(

Re: Deauthenticated due to local deauth request

Posted: Mon Sep 08, 2014 12:05 pm
by andies
No kernel problem at all. I made a simple mistake when installing bridge-utils (I have motion as well as an wifi access point installed in my raspberry). I was not sure which of the interfaces (br0, eth0, wlan0) must have and can have an IP address. Most of the websites that are not written by linux experts do spend exactly one line on this problem - so I gave br0 as well as eth0 an IP number. This is wrong. Only br0 gets one.

After removing the second IP the problem vanished.

Re: Deauthenticated due to local deauth request

Posted: Mon Oct 20, 2014 4:39 am
by johnboiles
Getting the same thing on the same kernel (3.12.25+ #700). This most recent time, it happened after 34 hours of uptime. Everything worked fine, and then all my wifi connections dropped and went into cycles of "deauthenticated due to local deauth request" and "associated". Interestingly, I was also almost completely out of disk space on the partition.

I freed up 100m (using `apt-get clean`) and updated the kernel to 3.12.30+ #717 (using `rpi-update`). I'll start looking at the logs more closely to see what patterns I can find.

Re: Deauthenticated due to local deauth request

Posted: Wed Oct 22, 2014 3:08 am
by johnboiles
Ok hit this issue again after 46.5 hours of uptime. There's still 10% of disk space free so that must have been unrelated. This time before going into the deauth/disassociated/associated loop, I got a bunch of errors that looked like this:

Code: Select all

Oct 21 19:54:53 boat-pi kernel: [167271.390644] ieee80211 phy0: rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
Oct 21 19:54:55 boat-pi kernel: [167273.694029] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 12 in queue 0
I've seen these errors before sporadically in the logs, and the rt2800 is not the hostapd device, so these are likely a red herring, but think it's worth mentioning. BTW I'm using an Edimax EW-7811Un (RTL8188CUS chipset) as my hostapd interface.

Re: Deauthenticated due to local deauth request

Posted: Mon Nov 17, 2014 8:36 pm
by hati23
Hello together,

Is this issue solved now?
I have the same Issue since one year. I changed the sdcard a few month ago - then the problem was gone. But now the issue is back again, and I don´t know why...
I can connect to my Pi, but after a few minutes it drops me out and syslog says "Deauthenticated due to local deauth request". The only way I can reconnect again is to reboot the Pi.
I also installed haveged, but it didn´t help. :cry:


Re: Deauthenticated due to local deauth request

Posted: Sun Nov 23, 2014 4:23 pm
by valmanza83
Hey everybody I found a solution but it's not what I wanted. You have to change the usb network adapter to ralink. The one I got was on Amazon.

Here is my document I made and use to setup the pi for this new adapter. ... cslist_api

Hope this all helps you.

Re: Deauthenticated due to local deauth request

Posted: Sun Jan 18, 2015 5:10 pm
by johnboiles
@valmanza83 I'll pick one of those up and give it a try. I'm amassing a decent collection of wifi dongles here :)

Looking back at some OpenWRT forum posts looks like they had this issue some years ago which suggests to me that it's a hostapd bug. The Adafruit instructions have you compile a version of hostapd from Realtek. I suspect that version still has the bug. @valmanza83, looks like you're using the stock version of hostapd from apt-get, which could explain why it works for you. Just a theory.

Daemon haveged should solve this problem

Posted: Mon Mar 07, 2016 10:20 pm
by etna_oliver
I also had the problem with "Deauthenticated due to local deauth request". Now I read an article in a German Linux magazine about the generation of random numbers and this seems to be an solution to the problem. It' looks like the Raspberry Pi, especially when used as a headless server, does not produce enough random numbers (you can see your current amount of random numbers in '/proc/sys/kernel/random/entropy_avail'). The production of random numbers depends on coincidence events, like keys pressed on the keyboard by the user etc. But there is not enough random in a headless server and the pool of random numbers seems to be to small for the generation of keys for the wireless communication. But there is a solution called HAVEGED. This daemon stimulates the generation of random numbers. Before install I had an average of 900 entropy bytes at my Pi, now after installation it jumped to 2000 bytes. Since the installation I had none "local deauth request" anymore! I installed the daemon under wheezy using "sudo apt-get haveged". After install the daemon should start automatically. You can check by typing "service --status-all" which should list haveged as running. You can watch the entropy pool again. It should have 2000 or more bytes. I hope and pray that this is the final solution to this annoying problem that consumed so much of my time.

Re: Deauthenticated due to local deauth request

Posted: Tue Mar 15, 2016 2:04 pm
by nayrangnu
etna_oliver wrote:... there is a solution called HAVEGED. This daemon stimulates the generation of random numbers...
I had this issue and

Code: Select all

apt-get install haveged
worked like a charm. Thanks @etna_oliver! :lol:

The old problem is back

Posted: Wed Mar 16, 2016 7:21 pm
by etna_oliver
The problem returned yesterday. :x One client using Android caused an authenticate/deauthenticate-loop and the wlan adapter stopped working after a while. After restarting networking-service and hostapd the clients where able to connect again. After a few hours the same problem occurred again. All this time the pool of random numbers was filled enough. Meanwhile I think it is a problem with this old hostapd release from Realtek. Now I decided to buy a different adapter that uses a nl80211 driver. So i do not need this old hostapd-daemon anymore.