Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Model B+ USB Not Working

Sat Jul 26, 2014 1:54 am

Hello,

I just got the model B+ today. I do NOT have any other pi's. Ive tried a image of the seemingly latest berryboot, raspbian installed via NOOBS, and Raspbian installed from image (6/20/2014). I know my keyboard and mouse (USB) work.

Berryboot boots but neither keyboard or mouse works.
Raspian boots but keyboard and mouse doesnt work
NOOBS boots, keyboard and mouse work until i install raspbian, then they dont work once raspbian boots (configuration screen)

I googled, i searched, ive been at it for about 1.5-2 hours. Most posts suggest updating firmware, usually by way of a Model B (which i dont have). Others have mentioned raspbian 6/20/2014 just working, no luck.

Is the pi's firmware a traditional firmware like on a PC (a chip on the motherboard) or is it stored on the SD card?

Also how can i update so the USB works. Do i have to wait for images to include something/be updated?

Any help would be great, brand new raspi and its a paperweight at this point. Thanks

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Model B+ USB Not Working

Sat Jul 26, 2014 7:44 am

When you say not working can you describe what happens exactly.

There is the posibility your Noobs install is corrupted (note not a big posibility but it exists)

CDo you have a PC or a Mac you can load the SD card into just to check it? ;)

How long are you waiting for your install and do you have a Ethernet connection?
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

guzunty
Posts: 276
Joined: Mon Jan 14, 2013 10:13 am

Re: Model B+ USB Not Working

Sat Jul 26, 2014 7:51 am

I definitely had issues with the usb ports not being active on the B+, but that was using older SD card images that worked on older Pi models.

I found that a clean Raspbian 2014-06-20 image definitely booted normally and enabled the ports. I'd recommend trying that again before moving on to other remedies.

The firmware is on the card, in the boot partition, which is formatted as FAT and therefore mountable on Linux, Windows or OSX.

There was a very recent firmware file posted here:

https://dl.dropboxusercontent.com/u/366 ... otcode.bin

Using a desktop PC, you could try dropping that file into the root of the boot partition of your SD card. Since you haven't been able to do anything with your Pi yet, you don't have anything to lose by trying it.

If you're not comfortable with that, then waiting a bit for the images to be updated is the only other option I can suggest. Please remember that these images are created and maintained by volunteers, so they may take a little while to catch up to the latest and greatest.
Guzunty: A fully programmable peripheral you build yourself! https://github.com/Guzunty/Pi/wiki

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12665
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Model B+ USB Not Working

Sat Jul 26, 2014 7:52 am

sounds like you are trying to use non recent versions of the software, it must be the latest version, or indeed the LAN9514 chip won't work, as only the latest version knows how to generate a clock signal for the LAN9514.

fruitoftheloom
Posts: 22047
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Model B+ USB Not Working

Sat Jul 26, 2014 8:29 am

I have used the latest release of Raspbian and Arch from downloads page and both work AOK. Have also downloaded OpenElec from their main site and it works AOK.

USB Keyboard, Mouse, BT and WiFi all plugged in.. ;)
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

drgeoff
Posts: 10333
Joined: Wed Jan 25, 2012 6:39 pm

Re: Model B+ USB Not Working

Sat Jul 26, 2014 9:21 am

fruitoftheloom wrote:I have used the latest release of Raspbian and Arch from downloads page and both work AOK. Have also downloaded OpenElec from their main site and it works AOK.
As does Raspbmc from the Downloads page on this site.

User avatar
pluggy
Posts: 3635
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: Model B+ USB Not Working

Sat Jul 26, 2014 10:47 am

Way too many out of date obscure operating systems.....

Download the and install the latest Raspdian from http://www.raspberrypi.org/downloads/ before whinging about B+ problems.

Then complain to the site that provided the obscure OS.
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25439
Joined: Sat Jul 30, 2011 7:41 pm

Re: Model B+ USB Not Working

Sat Jul 26, 2014 1:32 pm

pluggy wrote:Way too many out of date obscure operating systems.....

Download the and install the latest Raspdian from http://www.raspberrypi.org/downloads/ before whinging about B+ problems.

Then complain to the site that provided the obscure OS.
Very true. RIght at the start of Pi, there were so many requests to recommend this or that distro, complaints when we didn't have a forum specific to each obscure distro etc/

Imagine the pain now with all those poorly supported distros not being updated for the Model B+....it's heavy going with all the support given here for things nothing to do with the official distro's!

What I am surprised about is the number of people moving the SD card from B to B+, but who are not up to date. That's quite interesting.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6195
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Model B+ USB Not Working

Sat Jul 26, 2014 1:57 pm

To be fair, he said he tried the latest raspbian image, so something else might be up.

User avatar
Burngate
Posts: 6225
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: Model B+ USB Not Working

Sat Jul 26, 2014 3:45 pm

ShiftPlusOne wrote:To be fair, he said he tried the latest raspbian image, so something else might be up.
What's more, despite the other comments above, he hasn't moved a card from a B to a B+, he isn't using a strange OS, and he's described his problem remarkably well for someone new to the Pi.

So to answer one of his questions, there isn't a chip on the board, everything's on the SD card.

As far as I know, the most up-to-date image on the downloads page is either NOOBs or Raspbian. Neither should need updating to get the USB to work - and you had the keyboard & mouse working at the NOOBs screen.

My first guess is power.
Coincidentally, my second guess is also power, as is my third.
Watch the PWR LED as NOOBs gives way to Raspbian. If it blinks, you've got a power problem.

What keyboard is it? It's possible that it (or the mouse) is drinking too much current once the rest of the system starts. A cheap-n-nasty keyboard is better than an all-bells-n-whistles one.

Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Re: Model B+ USB Not Working

Sat Jul 26, 2014 5:03 pm

Thank you to those who actually read my post and realized i DID use the latest raspbian and NOOBS.

I can read the microSD card on my PC (Win 8.1) without issue. Ive used Win32DiskImager to write images to the card. Noobs was a drag and drop as per the directions from Noobs directions.

My current keyboard is a Logitech classic keyboard 200 (pretty basic) and some generic optical mouse. I am using a 5.1V/1A psu. I have a 5.3V/2A psu i can try instead.

Ive tried multiple times writing the images/files to the SD card after reformat and clean in diskpart. All images go through install/boot, so im pretty sure that there isn't corruption at play here. The problem again, is once i get to any screen requiring input the mouse/keyboard do not work, with the exception of at the NOOBs screen to select OS to install.

Ill report back how new PSU works

Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Re: Model B+ USB Not Working

Sat Jul 26, 2014 5:07 pm

5.3V/2A PSU, same issue with raspbian. Gets to config upon boot and keyboard does nothing, mouse doesnt work either (as in the optical light doesnt turn on).

With either psu the red light is solid, the green light blinks to indicate activity as expected.

Is it feasible to try and move the firmware from NOOBs to raspbian?

Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Re: Model B+ USB Not Working

Sat Jul 26, 2014 5:17 pm

The answer to my own question was to move the bootcode.bin from the NOOBs to the boot partition of my microSD. raspbian booted up and keyboard and mouse worked instantly.

Again to be clear, this WAS raspbian 6/20/2014 which IS the latest version (as of last night) posted at http://www.raspberrypi.org/downloads/ that had the issue for me

The working bootcode.bin is from NOOBs 1.3.9 (Offline and network install) also listed at the above link. Simply replace the bootcode.bin on your microSD with the bootcode.bin from Noobs and it works. I have the 5.1V/1A PSU but may consider changing to the 5.3V/2A

Thanks to all those offing constructive input

Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Re: Model B+ USB Not Working

Sat Jul 26, 2014 5:34 pm

Looks like i celebrated too soon.

I guess to clarify this is my goal:

Retropie & Rasplex dual boot

I was trying to use Berryboot to accomplish this.

I tried moving the bootcode.bin from Noobs to my microSD with Berryboot on it. Berryboot boots but neither keyboard nor mouse works. Tried with both my PSU's.

Any recommendations/suggestions?

Thanks

StuAngel
Posts: 3
Joined: Sun Jul 27, 2014 6:14 am

Re: Model B+ USB Not Working

Sun Jul 27, 2014 6:32 am

I am in a similar position -

I also received my B+ and am at a loss on what to do next

The problem - No power on either USB or Network

I have tried the following

2 x SanDisk 16GB

in the past 2 days I have installed

SDFormatter V4.0 and Win32 Disk Imager (so you know I have the latest versions within the last 48 hours)

I have downloaded and installed

NOOBS
NOOBS LITE
RASBARIAN
PINDORA
ARCH Linux

(all within the past 48 hours) to both of my Micro SD Cards and nothing has worked, I have found posts suggesting I put the cards into the old B model and use the apt-get update / upgrade, rpi-update and whatnot which I cannot do as I don't have a B model - I do have 2 x A models which both work perectly on both my old PSU/Keyboard and Mouse - so I went out and purchased a new PSU for testing some Belkin 10 watt 2.1amp unit - powers them both us, but still no power to USB/Network (tested with multimeter), I also tried copying the bootcode.bin from one to the other, also downloading the version listed above and still no luck - I am actually starting to think there is an issue with the power rails to the connectors - I even went to the point of installing QEMU - then apt-get updates & rpi-update - got the latest of everything I could on the wheezy build, then wrote that img to the SanDisk

the only thing I haven't tried is - a smaller Disk which I am about to do in the next hour or so - failing that I give up

hoping someone has picked up on something I missed - I am not sure what else to do - and I really didn't want to get flamed but I am at a desperate point now - I am really not that fluent in Linux - I just didn't expect to have to jump through hoops buying a new product.

Stu

drgeoff
Posts: 10333
Joined: Wed Jan 25, 2012 6:39 pm

Re: Model B+ USB Not Working

Sun Jul 27, 2014 9:42 am

Stu

I have a B+ running Raspbian (not via NOOBS) with working USB keyboard, mouse and LAN. Most of the files in /boot have date 19/06/2014. cmdline.txt, config.txt and issue.txt are dated 20/06/2014 and LICENSE.oracle is 25/09/2013.

issue.txt contains

Code: Select all

Raspberry Pi reference 2014-06-20 (armhf)
Generated using spindle, http://asbradbury.org/projects/spindle/, 8fe9fd4, stage4-lxde-edu.qed
If your files are of the same date or newer, then any problem you have is not due to old firmware.

Also, I'm not clear if your B+ is booting or not. Do you get video on an attached display?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25439
Joined: Sat Jul 30, 2011 7:41 pm

Re: Model B+ USB Not Working

Sun Jul 27, 2014 11:06 am

This is most odd. At first glance it looks like out of date software, bu that is clearly no the case. The second option is power. It looks liek the pwoer supp;lies are good neough, but have the people seeing problems tried different USB CABLES just in case they are of bad quality.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Model B+ USB Not Working

Sun Jul 27, 2014 1:14 pm

Plus contact your supplier you may have a flaky pi. ;)
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Model B+ USB Not Working

Sun Jul 27, 2014 2:58 pm

Zer0Cool wrote:The working bootcode.bin is from NOOBs 1.3.9 (Offline and network install) also listed at the above link. Simply replace the bootcode.bin on your microSD with the bootcode.bin from Noobs and it works.
That's really weird :shock: First time I've ever heard of a case like that :?
Just out of curiosity, what make/model/brand/size of SD card are you using?
I was trying to use Berryboot to accomplish this.
I haven't tried Berryboot myself, but maybe it's not been updated to work on the Model B+ yet?

StuAngel
Posts: 3
Joined: Sun Jul 27, 2014 6:14 am

Re: Model B+ USB Not Working

Sun Jul 27, 2014 3:31 pm

@drgeoff
all the dates look good, as mentioned I have only just downloaded the installers over the past couple of days (this weekend) - all of them have had video, goes through the loading process - I can see it ack the USB devices - actually, I thought I would try something else - I hooked up a powered hub to make sure it wasnt a drain on the PSU that was causing it - hasnt made a difference - here are a couple of screen shots of it loading - perhaps you might see something, as mentioned - I really dont know enough about Linux to tell if everything looks good or not.

you can see the 2 x pics at the following - stored dot info / raspi

sorry if the pics are big and a smidge out of focus :/

@jamesh - I also thought this might be it and over the period of testing I tried about 5 diffent power cables, 2 different keyboards - wired and wireless mice (only later, at first I didnt bother with a mouse)

@Jim JKla - I think this might be the case - but the fact that the loader shows up that it found a a USB hub and the mouse - I cant see anything about a keyboard though - see screen caps at - stored dot info / raspi

ps. I appreciate not being attacked for something I don't know - I cant stand looking at these boards when people assume you are an idiot because you missed something or you don't know as much on a subject as they do - everyone starts from somewhere.

Stu

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25439
Joined: Sat Jul 30, 2011 7:41 pm

Re: Model B+ USB Not Working

Sun Jul 27, 2014 3:54 pm

I think this may well be a faulty Pi.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

drgeoff
Posts: 10333
Joined: Wed Jan 25, 2012 6:39 pm

Re: Model B+ USB Not Working

Sun Jul 27, 2014 4:16 pm

After my equivalent of 2.751451 I have many lines which you do not. They involve the discovery of USB device 0424:9514, a 5 port USB hub. That will be the 9514 LAN/USB chip.
And just after that I have lines for USB device 0424:ec00 and mention of smsc95xx and eth0. You don't have those either.

Also notable that all your timestamps disappear after that 2.751451. Mine keep going.

So, as jamesh speculated, this certainly looks like a faulty RPi.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12665
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Model B+ USB Not Working

Sun Jul 27, 2014 4:59 pm

whats new with the newer firmware is that the B had its own 25.000 MHz crystal, but on the B+ one of the SoC's "GPCLK" generators is programmed to generate a precise 25.000 MHz, and the LAN9514 is now clocked by that.
Obviously with (too) old firmware the SoC's GPCLK generator isn't programmed to generate a clock signal, and the chip becomes invisible to the system.

Now its my understanding that firmware for some time had this patch in place (silently), but if your firmware (and maybe the kernel) is too old it might not.

so as drgeoff says:
After my equivalent of 2.751451 I have many lines which you do not. They involve the discovery of USB device 0424:9514, a 5 port USB hub. That will be the 9514 LAN/USB chip.
And just after that I have lines for USB device 0424:ec00 and mention of smsc95xx and eth0. You don't have those either.

Also notable that all your timestamps disappear after that 2.751451. Mine keep going.
It still seems the LN9514 isn't getting its clock signal!

I would start with downloading and installing the very latest version of noobs, formatting the card and placing the files from the zip on the card, and trying to install raspbian, that should almost certainly work. only then I would try berry boot.

If that exactly what you have already done, try if you can borrow or buy a 100% know good card for a B+ and if that doesn't work I would return the PI as defective.

drgeoff
Posts: 10333
Joined: Wed Jan 25, 2012 6:39 pm

Re: Model B+ USB Not Working

Sun Jul 27, 2014 5:05 pm

mahjongg wrote: ... but if your firmware (and maybe the kernel) is too old ...
All the downloads he has tried have been this weekend! StuAngel wrote:

"I have downloaded and installed

NOOBS
NOOBS LITE
RASBARIAN
PINDORA
ARCH Linux

(all within the past 48 hours) "

Zer0Cool
Posts: 7
Joined: Sat Jul 26, 2014 1:45 am

Re: Model B+ USB Not Working

Sun Jul 27, 2014 7:35 pm

AndrewS wrote:
Zer0Cool wrote:The working bootcode.bin is from NOOBs 1.3.9 (Offline and network install) also listed at the above link. Simply replace the bootcode.bin on your microSD with the bootcode.bin from Noobs and it works.
That's really weird :shock: First time I've ever heard of a case like that :?
Just out of curiosity, what make/model/brand/size of SD card are you using?
I was trying to use Berryboot to accomplish this.
I haven't tried Berryboot myself, but maybe it's not been updated to work on the Model B+ yet?
I have a Sandisk 32GB microSD Ultra class 10 card.

I have tried a PSU with a fixed cable and a PSU that allows swapping cables.

While im not a pi expert by any stretch i do work in IT and this seems to at least in my case be a software issue. For the other person having an issue i cannot say, maybe theirs is hardware.

Funny thing is i got and returned a Model B because it was having strange issues with HDMI but only on certain images (and i figured instead of chancing a hardware issue id just get a B+ to replace it), didnt mater what i did to config files and the like certain images would load (like berryboot) on the screen.

Im beginning to consider returning it all. I like to tinker, but its at the point where after 2 weeks of returns and frustration i still dont have a working pi. This could in large part be due to my ignorance, but i have noticed ALOT of outdated information and not a whole lot of current information (granted the B+ is very new, but the same was true for the B). Google "Model B+ USB Issues" and this is one of the only posts that is relevant to the topic and doesnt go on about updating via model B first.

Seeing as how im new to scene, is this what it was like when other revisions came out. Am i just being impatient and need to wait for developers to catch up to the new hardware and update their projects (Berryboot, Retropie, Rasplex, etc)?

Return to “Troubleshooting”