benras
Posts: 55
Joined: Sat Mar 03, 2012 5:52 pm

Choppy audio/sound in LXDE/Debian Sqeeze

Wed Jun 13, 2012 5:37 am

Whether playing mp3 or streaming from the 'net, the sound is awful. Choppy, unlistenable. Connected to HDMI port on TV for vid/audio. Is there an easy fix?

benras
Posts: 55
Joined: Sat Mar 03, 2012 5:52 pm

NO audio/sound in LXDE/Debian Sqeeze

Thu Jun 14, 2012 4:21 am

Remember yesterday, when I said that the sound wasn't working well? Today, I get no sound at all.

When I run the music player in LXDE, it defaults to MUTED. And when I bump up the volume, I get NOTHING. That is, I get nothing on either HDMI or the analog jack.

I tried installing VLC with the same results - in fact, I get an error when attempt to play an MP3.

Someone - please toss me a bone here. I have no idea where to start other than re-flashing the SD card and starting from scratch, hoping just to get to BAD audio again.

benras
Posts: 55
Joined: Sat Mar 03, 2012 5:52 pm

Re: Choppy audio/sound in LXDE/Debian Sqeeze

Thu Jun 14, 2012 4:59 am

I found this, which could explain some of the trouble.

Currently, the audio drivers for the Raspberry Pi are still in beta, and as such come disabled in the standard release (debian6-19-04-2012.zip). Here’s a quick way to get it up and running for both the HDMI as well as the analog output. Open up a terminal and install the alsa (Advanced Linux Sound Architecture) utility package:

Code: Select all

sudo apt-get install alsa-utils
Now load the sound driver using modprobe:

Code: Select all

sudo modprobe snd_bcm2835
By default output will be automatic (HDMI if supported, else analog). You can force it to use a specific interface with:

Code: Select all

sudo amixer cset numid=3 <n>
Substituting <n> for the desired mode: 0=auto, 1=headphones, 2=hdmi. For example, to force the Raspberry Pi to use the analog output:

Code: Select all

sudo amixer cset numid=3 1
Yah but even after setting this up, I get mangled audio.

texy
Forum Moderator
Forum Moderator
Posts: 4996
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: Choppy audio/sound in LXDE/Debian Sqeeze

Thu Jun 14, 2012 9:34 am

Why not try the new wheezy distro :
http://www.raspberrypi.org/phpBB3/viewt ... =50&t=8071

(you shouldn't need to enable the audio as you have above).

Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

benras
Posts: 55
Joined: Sat Mar 03, 2012 5:52 pm

Re: Choppy audio/sound in LXDE/Debian Sqeeze

Thu Jun 14, 2012 4:27 pm

Thanks, Texty. I may do that. I just installed Squeeze because it looked like it was the recommended OS. I wish I had more SD cards laying around.

Return to “Troubleshooting”

Who is online

Users browsing this forum: Exabot [Bot] and 44 guests