shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

ENOSPC rpi camera not working

Thu Jul 24, 2014 1:58 pm

have raspberry pi Type B and i am trying to attach camera into it,

all i have done is upgrading dist and firmware

sudo apt-get update sudo apt-get dist-upgrade sudo rpi-update

all firmware is updated

now according to what i saw commonly in google i have to execute raspistill

Code: Select all

raspistill -v
and this is what i've got

Code: Select all

raspistill Camera App v1.3.8

Width 2592, Height 1944, quality 85, filename (null)
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates
ENOSPC error always showing ,

this is my /etc/modules

Code: Select all

w1-therm
w1-gpio pullup=2
i2c-dev
i2c-bcm2708
spi-bcm2708
snd-bcm2835
#lirc_dev
#lirc_rpi gpio_out_pin=7
my /etc/modprobe.d/raspi-blacklist.conf

Code: Select all

# blacklist spi and i2c by default (many users don't need them)

#blacklist spi-bcm2708
#blacklist i2c-bcm2708
uname -r

3.12.25+

i have tried to solve this with google but nothin works
i cant figure what is wrong with this error, someone know how to solve it? please help me to solve it.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 2:12 pm

Could you paste the output of vcgencmd get_camera

Do you get the same error if you run rpi-update d1f2609 and reboot?

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 2:39 pm

Code: Select all

root@raspberrypi:~# vcgencmd get_camera
supported=1 detected=1

Code: Select all

root@raspberrypi:~# rpi-update d1f2609
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  7037  100  7037    0     0   3147      0  0:00:02  0:00:02 --:--:--  4605
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Your firmware is already up to date

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 2:42 pm

and also ive got error message in stdout /stderr

received unexpected camera control callback event , 0x4f525245

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 2:56 pm

So I2C communication with the camera seems to work.

Your firmware is actually a not the latest then.
https://github.com/Hexxeh/rpi-firmware/commits/master

I've fiddled with the camera code in the latest version (cfd9a20). So to make sure I didn't break anything, I wanted you to try d1f2609, which you already have.

Could you give the output of cat /proc/cpuinfo, ls /boot, cat /boot/config.txt and sudo vcdbg msg log ?

I've tested d1f2609 on my model b and it seems to work fine. About to test in a rev1 model b.

Edit: works fine on both versions here. Hmm...

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:00 pm

There's always the possibility that the camera was zapped with static electricity, which could cause strange behaviour, but after you post the output of the commands I mentions, here's what I'd recommend trying:

Blacklist the I2C modules and also try different firmware versions. If none of that works, I can't imagine it being anything other than a damaged board.

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:03 pm

/cat/procinfo

Code: Select all

cessor       : 0
model name      : ARMv6-compatible processor rev 7 (v6l)
Features        : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2708
Revision        : 000e
Serial          : 00000000df83aad2
ls /boot

Code: Select all

bootcode.bin  config.txt    fixup.dat	 issue.txt   LICENSE.oracle  start.elf
cmdline.txt   fixup_cd.dat  fixup_x.dat  kernel.img  start_cd.elf    start_x.elf
/boot/config.txt

Code: Select all

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#dmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt
#hdmi_mode=16
start_x=1
gpu_mem=128

vcdbg msg

Code: Select all

vcdbg - unrecognized command: 'msg'

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:04 pm

sorry, vcdbg log msg

Everything else looks as it should

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:06 pm

i got repeating message from vcdbg log msg

Code: Select all

981632.300: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981732.397: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981832.494: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981932.592: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982032.690: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982132.788: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982232.884: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982332.983: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982433.080: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982533.176: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982633.273: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982733.370: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982833.466: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982933.563: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983033.660: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983133.757: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983233.853: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983333.951: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983434.048: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983534.144: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983634.241: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983734.338: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983834.433: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983934.531: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
984034.627: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined^C
anything wrong with this condition of error messages?
Last edited by shiningstone on Thu Jul 24, 2014 3:08 pm, edited 1 time in total.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:07 pm

Nope, I get the same output on my B, so it should be mostly harmless.
shiningstone wrote:wow i got repeating message from vcdbg log msg

Code: Select all

981632.300: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981732.397: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981832.494: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981932.592: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982032.690: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982132.788: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982232.884: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982332.983: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982433.080: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982533.176: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982633.273: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982733.370: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982833.466: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982933.563: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983033.660: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983133.757: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983233.853: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983333.951: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983434.048: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983534.144: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983634.241: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983734.338: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983834.433: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983934.531: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
984034.627: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined^C
anything wrong with this condition of error messages?

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:09 pm

ShiftPlusOne wrote:Nope, I get the same output on my B, so it should be mostly harmless.
shiningstone wrote:wow i got repeating message from vcdbg log msg

Code: Select all

981632.300: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981732.397: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981832.494: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
981932.592: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982032.690: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982132.788: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982232.884: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982332.983: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982433.080: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982533.176: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982633.273: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982733.370: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982833.466: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
982933.563: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983033.660: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983133.757: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983233.853: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983333.951: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983434.048: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983534.144: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983634.241: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983734.338: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983834.433: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
983934.531: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined
984034.627: gpioman: gpioman_get_pin_num: pin POWER_LOW not defined^C
anything wrong with this condition of error messages?
so that means the board is not damaged?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:12 pm

Nope, it just means that particular message is safe to ignore for now. The camera board might still be zapped, but I think it's worth giving different firmware versions a go with the i2c modules blacklisted. At that point we should be able to rule out obvious software issues.

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:15 pm

ok i will try

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:30 pm

but i think for camera is been zapped i think thats not possible, i have bought it 1 week ago, i havent used it ,

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:35 pm

shiningstone wrote:but i think for camera is been zapped i think thats not possible, i have bought it 1 week ago, i havent used it ,
If nothing else works, then returning it might be an option here.

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 3:57 pm

http://www.rs-online.com/designspark/el ... era-setup=

yes u r right rpi camera is very very fragile , i forgot to not earthed myself, with very tiny simple mistake like that camera board is broken, damn

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 4:07 pm

That's unfortunate. =/

User avatar
with ice cream
Posts: 187
Joined: Mon Jul 30, 2012 7:25 am

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 8:33 pm

I seem to be running into camera issues as well. I changed from a Raspberry Pi model B revision 2 to a B+, I updated to the latest firmware, I blacklisted all i2c modules, I tested it with two previously working cameras. The cameras are not recognized.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 8:50 pm

with ice cream wrote:I seem to be running into camera issues as well. I changed from a Raspberry Pi model B revision 2 to a B+, I updated to the latest firmware, I blacklisted all i2c modules, I tested it with two previously working cameras. The cameras are not recognized.
Does it work with d1f2609 firmware? (rpi-update d1f2609)

Read through the thread and provide all the information. If it's a software issue, it should be easy to fix.

User avatar
with ice cream
Posts: 187
Joined: Mon Jul 30, 2012 7:25 am

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 9:03 pm

Thank you for the quick response. To test it in a setup similar to what I had when everything was working I downgraded to 494947f. And now it is working again (with both of my camera modules). The issue lies definitely in one of the updates after 494947f.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Thu Jul 24, 2014 9:08 pm

Thanks, I will try to replicate the issue tomorrow.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Fri Jul 25, 2014 8:39 am

Nope, everything works fine here.

User avatar
with ice cream
Posts: 187
Joined: Mon Jul 30, 2012 7:25 am

Re: ENOSPC rpi camera not working

Fri Jul 25, 2014 8:26 pm

ShiftPlusOne wrote:Nope, everything works fine here.
Strange. Also on a B+?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6259
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: ENOSPC rpi camera not working

Fri Jul 25, 2014 8:30 pm

Rev 1 B, Rev 2 B, B+ and compute module were all tested with different firmware versions. All just work.

If you could give the output of the commands I've asked shiningstone to run earlier, I could look over them to make sure there are no mistakes on your end.

shiningstone
Posts: 12
Joined: Thu Jul 24, 2014 1:32 pm

Re: ENOSPC rpi camera not working

Sat Jul 26, 2014 2:16 am

i am pretty sure its all about firmware, i have tried new pi + new camera + same SD card

and this is what ive got.

Code: Select all

Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera preview port to video render.
Connecting camera stills port to encoder input port

Opening output file /home/pi/test123.jpg
Enabling encoder output port
Starting capture 0
mmal: Received unexpected camera control callback event, 0x4f525245

and then it frozen.
is there any solution for this?


or is there any llinux distribution which is better than this?

Return to “Troubleshooting”