Duh
Posts: 6
Joined: Sun Jun 22, 2014 1:14 pm

Pidora 20 (2014) and minecraft

Sun Jun 22, 2014 1:21 pm

Long story short, ive been a redhat-based guy since the mid ninetys. I bought my son a pi to teach him, and of course installed minecraft. Got sdl and libpng up, setup the vchiq permissions, but minecraft does not load the opengl display. The screen does flicker a bit as if it tries, and the background window stays without crashing. So i know that minecraft is trying and thinks it is displaying. I played around with it, gave the gpu most of the memory, but im wondering if it is either a version/package incompatibility or a problem with where opengl display is positioned. Anyone ran into this before?
Note, i did get it running off the bat with raspbian, but i much prefer pidora to use on the pi if i can.
Thank you!

Duh
Posts: 6
Joined: Sun Jun 22, 2014 1:14 pm

Re: Pidora 20 (2014) and minecraft

Sat Jul 19, 2014 10:58 pm

For anyone running into this in the future, i found similar symptoms in raspbian when i used a compositing window manager. Once compositing was turned off, minecraft worked fine. I dont have an extra sd card laying around to see if this was the case with pidoras default desktop/wm yet. I know it starts to xfce, but im unaware of exactly which window manager its using without trying to load it again.

Exile In Paradise
Posts: 3
Joined: Wed May 07, 2014 3:57 pm

Re: Pidora 20 (2014) and minecraft

Wed Jul 30, 2014 4:58 pm

Just a heads up that I am in the same boat.

Pi Model B 2.1 - Pidora 20
Added libpng12 and SDL-1.2 packages, set the /dev/vchiq permission.
Window frame comes up - small window sized flicker elsewhere on screen - then nothing.

I've tried under XFCE and LXDE.
The XFCE compositor is off by default, so I tried turning it on but there was no change.

The /var/log/messages shows nothing interesting so its going to come down to traces or something to resolve.
If I find something, I will post more here.

Return to “Troubleshooting”