Posts: 40
Joined: Tue Feb 14, 2012 9:18 pm

Re: NO usb device works

Fri Jun 22, 2012 9:49 am

jbsteam wrote:GOT IT WORKING!!!!
In my opinion (not that its worth much) it must be a problem relating to the 25mhz crystal and freezing it kick starts it into action.
With my new 0.7A usb charger, the Rpi woks after a fridge trip, but no more 1 day later... I'll try again the fridge today, and perhaps I will attempt to ressolder the crytals (even if I'm not really eager to do it).

Posts: 3
Joined: Wed Jun 20, 2012 9:04 pm

Re: NO usb device works

Sat Jun 23, 2012 9:38 am


Update to my previous post is that it now seems to work fine all of the time.

I've had to "freeze" start it 5 times using the freezer spray but now it works as it should even after being left off all night.

Get yourseleves a can of freezer spray chaps.


User avatar
Forum Moderator
Forum Moderator
Posts: 9566
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: NO usb device works

Sat Jun 23, 2012 11:32 am

Seems to point to the crystal having had a bad mechanical shock.
A quartz crystal consist of a small sliver of quartz clamped between two conductors.
A mechanical shock can dislodge the quartz sliver from between the two conductors, causing the quartz to not being able to vibrate. Often very little is needed to "repair" the problem, touching the input pin of the crystal oscillator causes the crystal to vibrate a bit which might dislodge it. Freezing it can shrink it a bit and give the same result. Adding some heat can also have the same effect. Once the crystal can vibrate freely the problem is "fixed".

Posts: 1
Joined: Sat Jun 23, 2012 4:25 pm

Re: NO usb device works

Sat Jun 23, 2012 4:45 pm

There seem's to be an second problem with the USB devices which could be related to the firmware/OS distribution you use. My R-Pi works well with the Raspbian distribution (taken form here:, but with the current Raspbmc or Openelec images the R-Pi doesn't recognize any keystrokes or mouse movements.

The hardware configuration is always the same: power supply 5 V/1,2 A, Logitech MK 210 keyboard/mouse set (USB transmitter draws 55 mA). The voltage on the boards (TP1 to TP2) varies between (only) 4,65 and 4,7 V most time (with an without USB device or ethernet cable), but Raspbian works smoothly as said above. There's no significant difference between the different distributions.

My experiments with other configurations (cabled keyboard/mouses, powered USB hub) didn't change anything.

Maybe one of you those with the keyboard problem could test the Raspbian image and report here?

Greetings from Stuttgart/Germany

Posts: 1
Joined: Thu Dec 15, 2011 4:07 pm

A pie best served cold

Wed Jul 18, 2012 11:31 am

I can also confirm that putting the Raspberry Pi in the fridge for a while may invoke the USB functionality (I had mine in for slightly less than half an hour and put it to use immediatly afterwards). Whether it works in the long run is yet to be seen.

I have yet to try network connectivity, but seeing as it's the same chip (right?) that handles it, I guess this is alright.

So are we sure it's the crystal, or at least that it's the most probable cause?

Posts: 35
Joined: Wed Aug 01, 2012 12:15 pm

Re: NO usb device works

Wed Sep 12, 2012 6:26 pm

If someone has confirmed a non-oscillating crystal, as by oscilloscope, it could be helpful for others to save copies of the log files in /var/log *before* the fix and copies of the same log files after the fix for comparison. The differences could reveal what logged messages are present (or missing) before the fix, and they may help others better diagnose this problem from their log files without needing an oscilloscope.

Maybe someone could confirm or refute whether other problem causes would produce the same effects in the log files? (The kern.log file seems to be one of the larger files, so maybe it would be one of the main ones to watch and compare?)

For instructions for getting to the log files (from the viewpoint of a 'newbie' such as I am), please skim the post for "Request tool/access to SD post mortem 'out-of-body'" at ... 24&t=13563.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 36 guests