crh23
Posts: 8
Joined: Thu Jan 26, 2012 7:20 pm

SD Card problems?

Tue Jun 05, 2012 9:32 am

When I boot my pi after an initial sequence huge amounts of text come up. It says:

Code: Select all

mmcblk0: error -110 transferring data, sector <7 digit number>, nr <2 Digit number>, cmd response 0x900, card status 0x0
end_request: 1/0 error, dev mmcblk0, <7 digit number>
mmc0: Timeout waiting for hardware interrupt.
This repeats over and over: the two digit numbers shrinking until, after about 30 minuets, the screen goes black.
I have tried writing the SD card using dd and diskimage.
The PWR light is solid, the OK light blinks very occasionally, the FDX is solid, The other two blink.
Help?

snaipperi
Posts: 16
Joined: Fri Dec 02, 2011 10:37 am

Re: SD Card problems?

Tue Jun 05, 2012 9:38 am

Welcome aboard,

http://elinux.org/R-Pi_Troubleshooting#SD_cards
https://www.google.fi/search?q=raspberr ... +interrupt

Can you verify if your SD card is currently supported according to the elinux wiki ( http://elinux.org/RPi_VerifiedPeriphera ... g_SD_Cards ) ?

Fieldy
Posts: 16
Joined: Tue Jun 05, 2012 9:52 am

Re: SD Card problems?

Tue Jun 05, 2012 10:00 am

Hey,

I also have a problem with my SD cards.
I'm using the Transcend 32GB SDHC class 10 card which is listed as working card in the wiki.
But when i try to flash the image using dd I get the following error:

Code: Select all

[root@pc24 debian6-19-04-2012]# dd bs=1M if=debian6-19-04-2012.img of=/dev/sda
dd: writing `/dev/sda': Input/output error
1859+1 records in
1859+0 records out
1949999104 bytes (1.9 GB) copied, 2.60392 s, 749 MB/s
I also tried using other SD cards, but I always get this error. Any ideas?

Best regards

crh23
Posts: 8
Joined: Thu Jan 26, 2012 7:20 pm

Re: SD Card problems?

Tue Jun 05, 2012 10:19 am

I forgot to say: I have previously booted from this card multiple times. (It is listed as working on the wiki: Kingston SD4/16GB)

User avatar
grumpyoldgit
Posts: 1452
Joined: Thu Jan 05, 2012 12:20 pm

Re: SD Card problems?

Tue Jun 05, 2012 10:23 am

If you are suddenly getting card problems after it having worked fine I would suggest you try a different card or just re-image it. I have several on the go and have made all sorts of alterations to the config files to test out suggestions made on here. After a while i just scrub the card and start again.

crh23
Posts: 8
Joined: Thu Jan 26, 2012 7:20 pm

Re: SD Card problems?

Tue Jun 05, 2012 10:31 am

I have re-imaged it many times. So do I need to buy another SD card?

P.S. Thanks for the fast, concise help!

User avatar
grumpyoldgit
Posts: 1452
Joined: Thu Jan 05, 2012 12:20 pm

Re: SD Card problems?

Tue Jun 05, 2012 10:35 am

It is certainly worth having a few. Bearing in mind a Sandisk 8GB Class 4 costs less than £5 on Amazon or Play. Apart from anything else, it can be difficult to tie down a problem if you just have one of everything.

Fieldy
Posts: 16
Joined: Tue Jun 05, 2012 9:52 am

Re: SD Card problems?

Tue Jun 05, 2012 12:56 pm

Fieldy wrote:Hey,

I also have a problem with my SD cards.
I'm using the Transcend 32GB SDHC class 10 card which is listed as working card in the wiki.
But when i try to flash the image using dd I get the following error:

Code: Select all

[root@pc24 debian6-19-04-2012]# dd bs=1M if=debian6-19-04-2012.img of=/dev/sda
dd: writing `/dev/sda': Input/output error
1859+1 records in
1859+0 records out
1949999104 bytes (1.9 GB) copied, 2.60392 s, 749 MB/s
I also tried using other SD cards, but I always get this error. Any ideas?

Best regards
Problem solved! I've used an USB-cardreader. Now I tried it with a MacBook from one of my collegues and it worked...

Return to “Troubleshooting”