MrEngman
Posts: 4051
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: RPI-Update issue

Sun Mar 23, 2014 8:50 pm

Hi Dom,

I appear to have found an additional problem with rpi-update now it has been changed to use curl.

I often use sudo rpi-update Commit-ID to revert to older versions of the kernel to test various wifi drivers, especially the rtl8188eu driver that is currently not included in the kernel and provide modules so others can download.

Since the change to using curl sudo rpi-update works fine but trying to use sudo rpi-update Commit-ID seems to fail. It appears to download the data but does not install it. My knowledge of Linux is very limited so I can't figure out what the problem is. Could you take a look?

As an example of what I'm seeing sudo rpi-update Commit-ID gives the following output

Code: Select all

pi@raspberrypi ~ $ sudo rpi-update 798ae67746d4ac9418bcd8909ea71d25ad752721
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   135  100   135    0     0     86      0  0:00:01  0:00:01 --:--:--    98
100  7177  100  7177    0     0   3624      0  0:00:01  0:00:01 --:--:--  3624
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** ARM/GPU split is now defined in /boot/config.txt using the gpu_mem option!
 *** Downloading specific firmware revision (this will take a few minutes)
 *** Decompressing downloaded firmware archive
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   168  100   168    0     0    224      0 --:--:-- --:--:-- --:--:--   287
  0     0    0 29.9M    0     0  41953      0 --:--:--  0:12:28 --:--:-- 49223
pi@raspberrypi ~ $
as an attempt to revert to 3.10.25+ #622 from 3.10.33+ #658. Running normally sudo rpi-update gives the following and I'd also expect sudo rpi-update Commit-ID to provide a similar output

Code: Select all

pi@raspberrypi ~ $ sudo rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   135  100   135    0     0    173      0 --:--:-- --:--:-- --:--:--   234
100  7177  100  7177    0     0   6306      0  0:00:01  0:00:01 --:--:--  6306
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** ARM/GPU split is now defined in /boot/config.txt using the gpu_mem option!
 *** We're running for the first time
 *** Setting up firmware (this may take a few minutes)
Cloning into '//root/.rpi-firmware'...
^Cpi@raspberrypi ~ $
and was aborted using Cntl-C.

I would really appreciate it if you could take at look at this.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 4051
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: RPI-Update issue

Sun Mar 23, 2014 10:56 pm

Hi Dom,

Well, I've figure a way round the problem. Copied an old version of rpi-update from a different SD card and then run

Code: Select all

sudo UPDATE_SELF=0 rpi-update Commit-ID
Guess I'll have to live with that for now. However, would be nice to be able to run without UPDATE_SELF=0 to allow rpi-update to be updated as and when necessary.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

User avatar
brodtho
Posts: 15
Joined: Sat Jan 04, 2014 7:12 am
Location: Melbourne, Au

Re: RPI-Update issue

Mon Mar 24, 2014 1:50 am

Found a fix kinda maybe sorta.. All I know is it did what I needed it to.

so the standard

Code: Select all

rpi-update
shoots out this error:

Code: Select all

GnuTLS: A TLS warning alert has been received.
Unable to establish SSL connection.
Then went and got rpi-update again with:

Code: Select all

wget http://goo.gl/1BOfJ -O /usr/bin/rpi-update && chmod +x /usr/bin/rpi-update
or

Code: Select all

wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update -O /usr/bin/rpi-update && chmod +x /usr/bin/rpi-update
worked as expected:

Code: Select all

2014-03-24 12:30:13 (2.32 MB/s) - `/usr/bin/rpi-update' saved [7177/7177]
then ran it with:

Code: Select all

/usr/bin/rpi-update
responded well with:

Code: Select all

*** Running ldconfig
 *** Storing current firmware revision
 *** Syncing changes to disk
 *** If no errors appeared, your firmware was successfully updated
 *** A reboot is needed to activate the new firmware
restarted the pi

Code: Select all

shutdown -r now
then tried

Code: Select all

rpi-update
and now:

Code: Select all

 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** ARM/GPU split is now defined in /boot/config.txt using the gpu_mem option!
 *** Your firmware is already up to date
I don't even know why it worked, hopefully one of you guys can explain but the end result for me is I can finally get fbtft which I couldn't before!
Explorer of the seven OSI Layers

MrEngman
Posts: 4051
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: RPI-Update issue

Mon Mar 24, 2014 2:12 am

The version of rpi-update you downloaded, size 7177, is the newer version with the fix for the problem which is why it now works and I expect you see this when it starts

Code: Select all

pi@raspberrypi ~ $ sudo rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   135  100   135    0     0    189      0 --:--:-- --:--:-- --:--:--   253
100  7177  100  7177    0     0   6722      0  0:00:01  0:00:01 --:--:--  143k
 *** Relaunching after update

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

josn
Posts: 4
Joined: Wed Jul 04, 2012 1:56 pm

Re: RPI-Update issue

Tue Mar 25, 2014 1:22 am

Apparently, this problem is caused by a (security-) update to the GnuTLS library that wget (the tool that updates 'rpi-update' cannot handle). This is apparently already solved in the new version of rpi-update by replacing wget with curl. But you cannot get that, because updating rpi-update does not work anymore.

So, the solution is relatively simple: get the new rpi-update in an alternative way. You could do that on your PC or something, but the simplest way is to use curl on the Raspberry Pi itself. do: "curl -L -O https://github.com/Hexxeh/rpi-update/ra ... rpi-update", and the newest version of rpi-update is in the current directory. Now copy that over the old rpi-update: "sudo cp /tmp/x/rpi-update /usr/bin/rpi-update". For the wiseguys: dont use 'cp's '-a' option! Now start rpi-update as normal: "sudo rpi-update", and it will work as normal again.

For a really simple solution: wait until the raspbian repository maintainer updates the rpi-update package. But then you cannot play with the new camera settings for some time ;-)

otherside92
Posts: 1
Joined: Tue Mar 25, 2014 5:05 pm

Re: RPI-Update issue

Tue Mar 25, 2014 5:10 pm

I found following the instructions here worked: http://github.com/Hexxeh/rpi-update

Looks like the rpi-update code was faulty or something as the wget from github which replaces it seemed to work as everything else was up to date.

bluryfusion
Posts: 1
Joined: Wed Mar 26, 2014 6:38 pm

Re: RPI-Update issue

Wed Mar 26, 2014 6:45 pm

Updating manually the rpi-update script before attempt to running with:

Code: Select all

sudo curl -L "https://raw.github.com/Hexxeh/rpi-update/master/rpi-update" -o /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update
Worked for me.

diogoazevedo
Posts: 26
Joined: Thu Jun 20, 2013 1:25 pm
Location: PT

Re: RPI-Update issue

Fri Mar 28, 2014 5:49 pm

Hey everybody,

I have had this problem for some time too, tried several ways of fixing it without success.

Today (28-03-2014) I was checking for updates and when I did:

sudo apt-get dist-upgrade

I noticed that one of the updates was rpi-update.
After dist-upgrade done, rpi-update is now operational.

Hope that helps someone. ;)
Diogo Az

tired
Posts: 1
Joined: Sat Mar 29, 2014 10:05 pm

Re: RPI-Update issue

Sat Mar 29, 2014 10:19 pm

:?:
RichiG wrote:"sudo UPDATE_SELF=0 rpi-update" solved the problem for me. The last rpi-update was 5 months ago.
I tried your method and cannot start my pi anymore. At a first glance I was happy that it was shut down without any restart by the first time - but now, I am more sad that it does no restart anymore.

I am no Linux-Guy or Programmer, I just loved the idea of streaming music to my amplifieried to follow tutorials step by step. And after hours I made it work - except the bad sound qualitiy (analog output) - fine. To get a better sound I tried to install an audio card from adafruit and tried to follow this instruction:
http://learn.adafruit.com/usb-audio-car ... spberry-pi

well... and now there is silence. I would be very very happy for some help. :(
The self update was more a kind of digital suicide I guess.

(Sorry, my English is not perfect)

buckyb
Posts: 16
Joined: Sun Mar 30, 2014 3:05 pm
Location: South Africa

Re: RPI-Update issue

Sun Mar 30, 2014 3:22 pm

I had programs which failed to load properly on sudo apt-get update, then sudo apt-get upgrade. Eventually I applied

sudo apt-get autoclean

after which normal operation returned.

module0x90
Posts: 1
Joined: Mon Mar 31, 2014 2:57 pm

Re: RPI-Update issue

Mon Mar 31, 2014 3:07 pm

All,

I had exactly the same issue as you guys are describing above, I tried the suggested fixes, but none of them helped.

What I did in the end was download on another machine (arch-linux)

https://github.com/Hexxeh/rpi-update/ra ... rpi-update

and copied it across and executed it (after chmod-ing it of course).
Interestingly it did contact the same URL again for the self-update check, but this time it did not fail (because the newer version is using curl instead of wget, haha).


Regards

Thomas

ce4
Posts: 1
Joined: Tue Apr 01, 2014 11:14 am

Re: RPI-Update issue

Tue Apr 01, 2014 11:32 am

I fixed it alternatively by updating the script manually and re-run it:
The first script loads a self-update from this URL:

https://github.com/Hexxeh/rpi-update/ra ... rpi-update which is a redirect. You can copy/paste & run the snippet below:

Code: Select all

# Just to inspect the URL manually:
sudo curl https://github.com/Hexxeh/rpi-update/raw/master/rpi-update
<html><body>You are being <a href="https://raw.githubusercontent.com/Hexxeh/rpi-update/master/rpi-update">redirected</a>.</body></html>
# Use curl and the real URL to update rpi-update manually:
sudo curl -o /usr/bin/rpi-update https://raw.githubusercontent.com/Hexxeh/rpi-update/master/rpi-update
# run rpi-update as usual
sudo rpi-update

crazyquark
Posts: 4
Joined: Wed Sep 11, 2013 8:03 pm

Re: RPI-Update issue

Fri Apr 04, 2014 6:22 am

To skip update you can also do:

Code: Select all

sudo UPDATE_SELF=0 rpi-update
What I did is: updated rpi-update via apt-get:

Code: Select all

sudo apt-get install rpi-update
# gets the latest version
sudo rpi-update
 

simplesi
Posts: 2327
Joined: Fri Feb 24, 2012 6:19 pm
Location: Euxton, Lancashire, UK
Contact: Website

Re: RPI-Update issue

Sun Apr 13, 2014 8:24 pm

JFI A few people are getting this TLS warning message when try to download my ScratchGPIO stuff
Just passing this on in case its got any relevance
http://cymplecy.wordpress.com/scratchgp ... rypi-gpio/
Simon
Seeking help with Scratch and I/O stuff for Primary age children
http://cymplecy.wordpress.com/ @cymplecy on twitter

timtlm
Posts: 7
Joined: Wed Mar 09, 2016 12:58 am

Re: RPI-Update issue

Tue Mar 22, 2016 5:28 pm

Sorry to resurrect an old thread, but it seems that I'm having a similar issue that I can't resolve. I'm trying to run rpi-update on my pi 1 model B in hopes that will fix my wifi usb dongle not being recognized in the list using lsusb. I'm running retropie (raspbian). I've run the following successfully, but when I get to the rpi-update, it gives an error related to the certificates.
SSL certificate problem: unable to get local issuer certificate
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
!!! Failed to download update for rpi-update!
!!! Make sure you have ca-certificates installed and that the time is set correctly

Code: Select all

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install rpi-update
sudo rpi-update
I've also run the recommended steps in the troublshooting section, in addition to the -k insecure option and still get the same error.

Code: Select all

sudo apt-get install ntpdate
sudo ntpdate -u ntp.ubuntu.com

sudo apt-get install ca-certificates

sudo rpi-update -k
Any help would be greatly appreciated. I assume as a last resort I can install one of the supported distros to a different sd card to get rpi-update to work on there.

seyyah
Posts: 1
Joined: Thu Apr 06, 2017 6:08 am

Re: RPI-Update issue

Thu Apr 06, 2017 6:20 am

Using the corresponding environment variable I can work around the issue (thans to @rillian https://github.com/Hexxeh/rpi-update/is ... -230618006)

Code: Select all

$ sudo apt-get update
$ sudo apt-get upgrade

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 8.0 (jessie)
Release:        8.0
Codename:       jessie

$ uname -a
Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

$ sudo rpi-update -k
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: http://curl.haxx.se/docs/sslcerts.html

 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn t adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.
 !!! Failed to download update for rpi-update!
 !!! Make sure you have ca-certificates installed and that the time is set correctly

$ sudo CURL_CA_BUNDLE=/etc/ssl/certs/ca-certificates.crt rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 12762  100 12762    0     0  20237      0 --:--:-- --:--:-- --:--:-- 20225
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** We re running for the first time
 *** Backing up files (this will take a few minutes)
 *** Remove old firmware backup
 *** Backing up firmware
 *** Remove old modules backup
 *** Backing up modules 4.4.50-v7+
#############################################################
WARNING: This update bumps to rpi-4.9.y linux tree
Be aware there could be compatibility issues with some drivers
Discussion here:
https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=167934
##############################################################
Would you like to proceed? (y/N)
 *** Downloading specific firmware revision (this will take a few minutes)
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   168    0   168    0     0    232      0 --:--:-- --:--:-- --:--:--   232
100 53.7M  100 53.7M    0     0   507k      0  0:01:48  0:01:48 --:--:--  866k
 *** Updating firmware
 *** Updating kernel modules
 *** depmod 4.9.20+
 *** depmod 4.9.20-v7+
 *** Updating VideoCore libraries
 *** Using HardFP libraries
 *** Updating SDK
 *** Running ldconfig
 *** Storing current firmware revision
 *** Deleting downloaded files
 *** Syncing changes to disk
 *** If no errors appeared, your firmware was successfully updated to 3ff94f1fc459f88d3e2530542fb609643a7bd1a6
 *** A reboot is needed to activate the new firmware

votkapivo
Posts: 1
Joined: Sat Aug 19, 2017 5:51 pm

Re: RPI-Update issue

Sat Aug 19, 2017 6:02 pm

I stumbled into the same problem.
However, the cause was something pretty different.
I have a virtual network device activated. (Eth0:1), while main internet communication goes through wlan0. Somehow the packets get lost in their search for the sender of the request to update.
After bringing the virtual interface down (sudo ifdown eth0:1) the rpi-update worked as a charm.

Hope this totally different cause and solution helps someone.

Return to “Troubleshooting”