jay123035
Posts: 32
Joined: Wed Nov 21, 2012 5:24 am

SOLVED:bad video resolution on boot but changes after reboot

Mon Mar 10, 2014 6:37 pm

because i power the monior and the PI from the same source i have to have hdmi_force_hotplug=1 otherwise the PI does not see the monitor in time to output a video signal. but when that set and first power up the system i get

Code: Select all

state 0x120016 [DVI DMT (35) RGB full 5:4], 1280x1024 @ 60Hz, progressive
as output for

Code: Select all

tvservice -s
once I reboot I get

Code: Select all

state 0x12001a [HDMI CEA (4) RGB lim 16:9], 1280x720 @ 60Hz, progressive
i think it would be ok if i could force the smaller resolution but 1280x720 is not a "good" resolution "mode" http://elinux.org/RPi_config.txt

one thought is to make the Pi reboot every time it is powered up. but that seams like a lame solution.

thanks for your input
Last edited by jay123035 on Mon Mar 10, 2014 8:02 pm, edited 1 time in total.

User avatar
rpdom
Posts: 16994
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: bad video resolution on boot but changes after reboot

Mon Mar 10, 2014 6:57 pm

You can download the monitor settings using

Code: Select all

sudo tvservice -d /boot/edid.dat
Then edit the /boot/config.txt and add (or uncomment if it exists) the line

Code: Select all

hdmi_edid_file=1
When you next boot your Pi will use the settings from the data file instead of looking for the monitor. Very handy if the monitor isn't connected when you power the Pi on. But you may have to change those settings if you use a different monitor.

I don't have hdmi_force_hotplug=1 set, but I do have hdmi_group=2. Not usre if that is needed in your case.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5588
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: bad video resolution on boot but changes after reboot

Mon Mar 10, 2014 7:10 pm

jay123035 wrote:because i power the monior and the PI from the same source i have to have hdmi_force_hotplug=1 otherwise the PI does not see the monitor in time to output a video signal. but when that set and first power up the system i get

Code: Select all

state 0x120016 [DVI DMT (35) RGB full 5:4], 1280x1024 @ 60Hz, progressive
as output for

Code: Select all

tvservice -s
once I reboot I get

Code: Select all

state 0x12001a [HDMI CEA (4) RGB lim 16:9], 1280x720 @ 60Hz, progressive
i think it would be ok if i could force the smaller resolution but 1280x720 is not a "good" resolution "mode" http://elinux.org/RPi_config.txt
...
Whilst there is/are preferred mode(s) for a (given) HDMI/DVI monitor, I've found that a "native" (T.V.) mode is also O.K. FWIW, some examples of the use of (other) tvservice command options to determine the "optimum" config.txt settings for different display types are shown here:
http://www.cpmspectrepi.webspace.virgin ... tings.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

jay123035
Posts: 32
Joined: Wed Nov 21, 2012 5:24 am

Re: bad video resolution on boot but changes after reboot

Mon Mar 10, 2014 8:01 pm

rpdom wrote:You can download the monitor settings using

Code: Select all

sudo tvservice -d /boot/edid.dat
Then edit the /boot/config.txt and add (or uncomment if it exists) the line

Code: Select all

hdmi_edid_file=1
When you next boot your Pi will use the settings from the data file instead of looking for the monitor. Very handy if the monitor isn't connected when you power the Pi on. But you may have to change those settings if you use a different monitor.

I don't have hdmi_force_hotplug=1 set, but I do have hdmi_group=2. Not usre if that is needed in your case.

This did the trick, thank you very much.

i was able to remove (comment out)

Code: Select all

#hdmi_force_hotplug=1
and

Code: Select all

#hdmi_group=2
once i added the

Code: Select all

hdmi_edid_file=1
thanks again.

Return to “Troubleshooting”