legotron
Posts: 1
Joined: Wed Jan 15, 2014 10:57 pm

Video capturing problem with gstreamer

Thu Jan 16, 2014 7:47 pm

Hi,
I have running green strips during capturing PAL video signal with gstreamer.
I'm using Beholder Wander TV tuner
http://www.beholder.ru/products/Wander/
based on TM6010 chip.
Absolutely same gstreamer pipeline on PC works fine with the same TV tuner.
Can anybody help with the direction of the search?
I can add any other configuration details on request.
Thanks!
gst-launch-1.0 -v --gst-debug-level=1 v4l2src device=/dev/video1 norm=255 io-mode=1 pixel-aspect-ratio=1/1 ! video/x-raw, format=YUY2 ! avimux name=mux ! filesink location=test.avi
[root@camera-raspi ~]# uname -a
Linux camera-raspi 3.12.6-1-ARCH #1 PREEMPT Mon Dec 23 16:36:39 MST 2013 armv6l GNU/Linux
[root@camera-raspi ~]# lsmod
Module Size Used by
tm6000_alsa 5408 0
tuner 16469 0
snd_soc_bcm2708_i2s 5518 0
regmap_mmio 2842 1 snd_soc_bcm2708_i2s
snd_soc_core 155931 1 snd_soc_bcm2708_i2s
leds_gpio 2087 0
led_class 4143 1 leds_gpio
snd_compress 8200 1 snd_soc_core
snd_pcm_dmaengine 5477 1 snd_soc_core
spi_bcm2708 4787 0
regmap_spi 1937 1 snd_soc_core
bcm2708_dmaengine 5080 0
virt_dma 2316 1 bcm2708_dmaengine
regmap_i2c 1681 1 snd_soc_core
i2c_bcm2708 3961 0
tm6000 54710 2 tm6000_alsa
videobuf_vmalloc 5531 1 tm6000
videobuf_core 20587 2 videobuf_vmalloc,tm6000
rc_core 17030 1 tm6000
v4l2_common 7820 2 tuner,tm6000
videodev 121485 4 tuner,v4l2_common,tm6000
media 14470 1 videodev
snd_bcm2835 16286 0
snd_pcm 81426 4 snd_bcm2835,snd_soc_core,tm6000_alsa,snd_pcm_dmaengine
snd_page_alloc 5200 1 snd_pcm
snd_timer 19937 1 snd_pcm
snd 61430 6 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_compress,tm6000_alsa
bcm2708_rng 1044 0
rng_core 4202 1 bcm2708_rng
ipv6 312050 0
[root@camera-raspi ~]# v4l2-dbg -D
Driver info:
Driver name : tm6000
Card type : Trident TVMaster TM5600/6000/60
Bus info : usb-bcm2708_usb-1.3
Driver version: 3.12.6
Capabilities : 0x85050001
Video Capture
Tuner
Radio
Read/Write
Streaming

[root@camera-raspi ~]# v4l2-ctl -I
Video input : 1 (Composite 1: ok)

[root@camera-raspi ~]# v4l2-ctl --list-formats-ext
ioctl: VIDIOC_ENUM_FMT
Index : 0
Type : Video Capture
Pixel Format: 'YUYV'
Name : 4:2:2, packed, YVY2

Index : 1
Type : Video Capture
Pixel Format: 'UYVY'
Name : 4:2:2, packed, UYVY

Index : 2
Type : Video Capture
Pixel Format: 'TM60'
Name : A/V + VBI mux packet

[root@camera-raspi ~]# v4l2-ctl -V
Format Video Capture:
Width/Height : 720/576
Pixel Format : 'YUYV'
Field : Interlaced
Bytes per Line: 1440
Size Image : 829440
Colorspace : Broadcast NTSC/PAL (SMPTE170M/ITU601)
video_green_stripes1.png
video_green_stripes1.png (63.79 KiB) Viewed 1421 times

fadiK
Posts: 1
Joined: Fri Aug 28, 2015 6:49 am

Re: Video capturing problem with gstreamer

Fri Aug 28, 2015 6:54 am

Hi legotron,
How did you run TV Tuner on Pi.
which OS?
and how TM6010 chip driver installed. i plugged it on usb port but didnt see any /dev/video0 device.

Return to “Troubleshooting”