PiTFT: boot to desktop problem


20 posts
by LukeM » Sat Jan 11, 2014 9:02 pm
Hi All,

I picked up the awesome PiTFT Touch Screen and got it working by following the tutorial here. I set it up to display the console on the touch screen and I can launch the desktop by logging in and executing startx. It even works if I execute startx from a remote SSH session. However, if I use raspi-config to configure it to boot to desktop automatically and reboot I just end up with a blank screen with an underscore in the top left corner.

I tried one other thing... I put startx in rc.local and it appears to execute but it just shows the output on the console and never actually displays the desktop.

In either case, if I log in using SSH and execute startx the desktop will display and everything works as expected.

I'm a linux novice so I'm out of ideas and I haven't found many other discussions about this device. Any thoughts on a possible solution?

Thanks,
Luke M
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by AndyD » Sat Jan 11, 2014 10:02 pm
The problem is that the tutorial expects you to use startx, rather than letting lightdm start the X server (as it does when you select boot to desktop). When you select boot to desktop the greeter is started to allow you to log in. The solution is to follow this tutorial (X11 on your Display). Boils down to:-

Install xserver-xorg-video-fbdev
Code: Select all
sudo apt-get install xserver-xorg-video-fbdev


Create a config file with following contents in /usr/share/X11/xorg.conf.d/99-fbdev.conf containing the following:
Code: Select all
Section "Device" 
  Identifier "myfb"
  Driver "fbdev"
  Option "fbdev" "/dev/fb1"
EndSection


The select boot to desktop in raspi-config.
User avatar
Posts: 2318
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
by LukeM » Sat Jan 11, 2014 11:05 pm
That did the trick! Thanks!
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by sirkope » Tue Jan 28, 2014 1:18 pm
Hi all,

I have the same problem, and some other.
How can I see the boot process on the TFT?
When I close the X windows with CTLR+C, the TFT still hold the last image.
When I shutdown the RPI trough SSH, the last image also remain on the TFT
Posts: 17
Joined: Wed Jun 13, 2012 7:39 pm
by mazternhell » Mon Feb 03, 2014 11:51 am
@LukeM Im having the same problems. How did you manage to get out of the blinking cursor into a terminal. Sorry im also new at this stuff. Thanks!
Posts: 14
Joined: Fri Jan 31, 2014 12:18 am
by LukeM » Mon Feb 03, 2014 6:06 pm
mazternhell: I'm no expert either so but I followed AndyD's instructions and it worked fine. Have you tried that? What else have to done to get to where you are now?
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by LukeM » Mon Feb 03, 2014 6:10 pm
sirkope wrote:Hi all,

I have the same problem, and some other.
How can I see the boot process on the TFT?
When I close the X windows with CTLR+C, the TFT still hold the last image.
When I shutdown the RPI trough SSH, the last image also remain on the TFT


I'm not sure exactly what you mean by see the boot process, but if you mean showing the main console to the PiTFT rather than the HDMI or composite out, I followed the instructions in this tutorial under Using the Console.

I'm not sure how to solve your other two problems. Mine does the same thing and I'd be curious if you find anything.
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by mazternhell » Tue Feb 04, 2014 3:29 am
okay so i just did a reinstall of everything and followed the tutorial and now its displaying on the tft on bootup. Now I need to switch back to the monitor as its a little difficult coding from TFT screen. I tried switching using the FRAMEBUFFER=/dev/fb0 line and it won't work. Anyone know what could be the problem?
Posts: 14
Joined: Fri Jan 31, 2014 12:18 am
by LukeM » Tue Feb 04, 2014 11:16 pm
mazternhell wrote:okay so i just did a reinstall of everything and followed the tutorial and now its displaying on the tft on bootup. Now I need to switch back to the monitor as its a little difficult coding from TFT screen. I tried switching using the FRAMEBUFFER=/dev/fb0 line and it won't work. Anyone know what could be the problem?


I typically just use an SSH terminal or a VNC viewer if I need the desktop.
But to answer your question, I was able to go back to normal by removing /usr/share/X11/xorg.conf.d/99-fbdev.conf that I added per AndyD's suggestion, and reverting /boot/cmdline.txt to it's original state (removed the line added per the Adafruit tutorial).

I hope this helps.
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by Digitalkinfolk » Tue Jul 22, 2014 2:04 am
Followed your directions and now I can no longer access the desktop or the PiTFT, the touchscreen just boots up, showing the boot script, and then goes black with a cursor blinking in the left corner? Not sure what to do now because I can't even access the screen to change it back through terminal or access the files when I plug the SD card into my computer, they must be hidden or something A little frustrated took forever to get here and I was almost done and added this code to get the screen to boot directly to the PiTFT instead of the desktop and now I'm stuck, any suggestions on how to force the screen to the PiTFT or a way I can access those files to delete them?
Posts: 1
Joined: Tue Jul 22, 2014 1:52 am
by LukeM » Wed Jul 23, 2014 9:36 pm
It's been a while since I messed with this I'm not an expert but I had a similar problem at one point and I have a couple ideas.

Can you SSH in or use a console cable? If you can manage one of those you should be able to tweak or reverse your settings.

Otherwise, do you have another linux machine you could plug the SD card into? You're right, a windows machine won't be able to easily access anything but the boot partition. If not, you could use an SD card with a fresh install to boot the Pi, then plug your current SD card into the Pi using a USB adapter. Either way, you should then be able to access the files on the SD card that you're looking for.

I hope this helps...
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by technocity » Sun Aug 24, 2014 4:55 am
Hello everyone

I was reading your thread LukeM and still stuck with the blinking cursor. What did you do to solve this?

Thanks in advance

I m also new to linux
Posts: 1
Joined: Sun Aug 24, 2014 4:52 am
by azrith » Tue Aug 26, 2014 2:46 am
I just wanted to say thanks for the post. I was stuck on this for a while. This method worked for me.
Posts: 4
Joined: Sat Apr 06, 2013 9:39 pm
by LukeM » Wed Aug 27, 2014 10:00 pm
technocity wrote:Hello everyone

I was reading your thread LukeM and still stuck with the blinking cursor. What did you do to solve this?

Thanks in advance

I m also new to linux


Not knowing where you are in the process, it is difficult to answer your question in detail. All I can say is, I followed the tutorial and when I encounter the problem I asked about in the original post, the instructions provided by AndyD above solved my problem.
Posts: 7
Joined: Tue Dec 17, 2013 12:14 am
by bd3k » Fri Dec 05, 2014 5:16 am
If you get the black screen on the piTFT and a blinking cursor hit CTRL ALT F1 that will get you back to console
Posts: 6
Joined: Thu Sep 04, 2014 12:31 am
by sch0sch » Wed Jan 14, 2015 10:31 am
Hi
I am also trying to boot directly on the desktop with my piTFT.

Using startx works for me as I followed the tutorial on Adafruit.

If I create the configfile like AndyD, it doesnt work anymore.

But its possible to make these steps retrogressive! Just delete the file you created while connected via ssh with "sudo rm /usr/share/X11/xorg.conf.d/99-fbdev.conf"
Now startx works again.

Still the problem booting to the desktop on piTFT is not solved, does anybody have a new idea?
Posts: 1
Joined: Wed Jan 14, 2015 10:21 am
by yeonghuei » Tue Jul 14, 2015 3:44 pm
AndyD wrote:The problem is that the tutorial expects you to use startx, rather than letting lightdm start the X server (as it does when you select boot to desktop). When you select boot to desktop the greeter is started to allow you to log in. The solution is to follow this tutorial (X11 on your Display). Boils down to:-

Install xserver-xorg-video-fbdev
Code: Select all
sudo apt-get install xserver-xorg-video-fbdev


Create a config file with following contents in /usr/share/X11/xorg.conf.d/99-fbdev.conf containing the following:
Code: Select all
Section "Device" 
  Identifier "myfb"
  Driver "fbdev"
  Option "fbdev" "/dev/fb1"
EndSection


The select boot to desktop in raspi-config.


Hi,

Thank for the fix. I had the same problem and it was resolved by adding the suggested config file.

But I have another issue here. I am currently trying to have the pi to auto boot up and launch chromium into kiosk mode. Previously without this, when using "startx", chromium kiosk mode launched automatically. But after fixing the screen, it just boots into the GUI but chromium does not launch.

I have added the following line in /etc/xsd/lxsession/LXDE-pi/autostart to get chromium kiosk as the startup program:

@chromium --kiosk "http://192.168.1.25"

Any advice would be great!
Posts: 1
Joined: Tue Jul 14, 2015 3:39 pm
by Syndave » Fri Jan 01, 2016 10:29 pm
Create a config file with following contents in /usr/share/X11/xorg.conf.d/99-fbdev.conf containing the following:

Code: Select all
Section "Device"
Identifier "myfb"
Driver "fbdev"
Option "fbdev" "/dev/fb1"
EndSection

How do i do this. This is my first week using linux
Posts: 8
Joined: Fri Jan 01, 2016 2:21 am
by DougieLawson » Sat Jan 02, 2016 12:43 am
Open an LXTerminal window (it's that little TV shaped icon on the taskbar).
Type sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf
Enter all the stuff from the post above.
Press [CTRL]+[O] to save it
Press [ENTER] when prompted
Press [CTRL]+[X] to exit the editor
Press [CTRL]+[D] to exit the LXterminal window

Reboot to get it active.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 27562
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by Fraxal » Mon Jan 25, 2016 9:26 pm
For those who have followed the Adafruit PiTFT guide:
The instructions for booting to desktop are a bit hidden away in the section "Extras!"
https://learn.adafruit.com/adafruit-pitft-28-inch-resistive-touchscreen-display-raspberry-pi/extras#boot-to-x-windows-on-pitft
Posts: 1
Joined: Mon Jan 25, 2016 6:53 pm