MrEngman
Posts: 4016
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax Wi-Fi adapter not functioning correctly

Wed Dec 25, 2013 1:42 am

Well if it's any help I usually use this format for /etc/network/interfaces file

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "network-name"
wpa-psk "network-password"
Works with all the wifi adaptors I have including the EW7811Un.

And adding additional wlan sections (wlan1, wlan2 etc.) with the same format and I can connect more than one wifi adaptor at the same time.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

7ewis
Posts: 130
Joined: Wed Dec 26, 2012 11:30 am

Re: Edimax Wi-Fi adapter not functioning correctly

Wed Dec 25, 2013 2:46 pm

MrEngman wrote:Well if it's any help I usually use this format for /etc/network/interfaces file

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "network-name"
wpa-psk "network-password"
Works with all the wifi adaptors I have including the EW7811Un.

And adding additional wlan sections (wlan1, wlan2 etc.) with the same format and I can connect more than one wifi adaptor at the same time.


MrEngman
Tried this earlier today, and the adapter is actually flashing constantly now, but it still doesn't want to connect to my Wi-Fi. If there are spaces in the SSID, it doesn't need to have \ in-between the words or something does it?

What is the normal flash? I can't remember but mine is flashing constantly then may pause for a second or two, then resume the constant flashing.
Raspberry Pi - Model B (512MB)

MrEngman
Posts: 4016
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax Wi-Fi adapter not functioning correctly

Wed Dec 25, 2013 4:02 pm

Not sure about spaces in the SSID. Looked around using Google and there were conflicting reports, some saying it's OK and others that it doesn't work like you are finding at the moment. Could be worth trying without a space if you can.

My adaptor flashes on approx. once a second or probably just a little faster. It flashes 4 or 5 single flashes and then one double flash, two very short flashes, repeating the sequence continuously.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Return to “Troubleshooting”