ceteras
Posts: 239
Joined: Fri Jan 27, 2012 1:42 pm
Location: Romania

Restart instead of halt

Tue Dec 10, 2013 12:22 pm

Hi,
I wanted to build something for my Pi, based on this behaviour I knew: after executing halt, shutdown -h now, or init 0, raspbian would blink the ACT led ten times then stay put. The plan was to build something to detect those 10 blinks with their timing too and cut the power.
However, my Raspberry doesn't do this anymore, when I execute "sudo halt", "sudo shutdown -h now" or "sudo init 0", it closes everything down as expected, then restarts. It doesn't do the blinking of ACT led neither.

I'd like to know if this is normal, was this intentionally changed in the newer kernels?
I mean, could it be that this has changed for me after an apt-get update & upgrade? (because I've issued these commands at a certain time, and also yesterday evening)

I've prepared a new SD card with the latest Raspbian available, but I'll have to wait until the evening to see if that works as expected.
I couldn't find any thread about this issue, so I've opened my own here.
Thanks!

klricks
Posts: 6852
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Restart instead of halt

Tue Dec 10, 2013 1:55 pm

Not normal.... My RPi still blinks 10 times on shutdown and does not reboot. Raspbian with most recent updates
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.


ceteras
Posts: 239
Joined: Fri Jan 27, 2012 1:42 pm
Location: Romania

Re: Restart instead of halt

Tue Dec 10, 2013 2:29 pm

I saw that thread, but I have nothing attached to my Pi, so I don't think it applies to my case.

ceteras
Posts: 239
Joined: Fri Jan 27, 2012 1:42 pm
Location: Romania

Re: Restart instead of halt

Tue Dec 10, 2013 8:23 pm

I've just tested the fresh raspbian install and it halts as is should, blinking ACT led and all. No restart.
Now if I only could get the other one to do the same... I don't want to re-install and configure everything here.
Any kind of hints would be much appreciated!

obcd
Posts: 917
Joined: Sun Jul 29, 2012 9:06 pm

Re: Restart instead of halt

Wed Dec 11, 2013 5:06 pm

I had such issues as well.
You need the latest firmware for a Pi with 512MB of ram.
You need a recent kernel with that firmware as well or it will reboot instead of halt.

I ended up recompiling my kernel to fix those issues. (It had some config settings changed.)

ceteras
Posts: 239
Joined: Fri Jan 27, 2012 1:42 pm
Location: Romania

Re: Restart instead of halt

Thu Dec 12, 2013 8:47 am

So a mismatch between the firmware and kernel could cause it.
Thank you for the replies. I was curious to know if many others have the same issue or not, and what could cause it.

ceteras
Posts: 239
Joined: Fri Jan 27, 2012 1:42 pm
Location: Romania

Re: Restart instead of halt

Sun Dec 15, 2013 9:07 pm

An rpi-update on the misbehaving sd-card caused it to shut down properly, but also I've lost some changes I've made.
I didn't want to write about what I did to get to this problem, because I was hoping for more general answers.
It's koalo's I2S drivers that got me here, so I think I will post in his thread about my issue.
Thank you again!

Return to “Troubleshooting”