szafran
Posts: 9
Joined: Sat Mar 01, 2014 2:28 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Wed Apr 16, 2014 9:45 am

Thank you. That helped.
Best regards
Szafran

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.25+

Wed Apr 16, 2014 11:03 am

mzs wrote:
szafran wrote:
LaFambe wrote:attached is an updated version of the "automatic download and install script": version information is fetched directly from the initial post in this topic, and firmware is systematically installed if present in tarball. Use install-8188eu.sh to download and install the proper driver for the rpi you run from. Use install-8188eu.sh -k <kernel build> to select the closest available driver version in case no exact match is found for the local kernel. install-8188eu.sh -l shows a list of available driver versions.

[email protected] ~ $ ./install-8188eu.sh -h
usage: install-8188eu.sh [-k|--kernel <kernel build>] [-l|--list]

UPDATE: fixed version of the script attached.
INSTALL: [email protected] ~ $ curl -s http://www.raspberrypi.org/phpBB3/downl ... hp?id=5536 | tar xz
That script doesn't work anymore (great work btw)... is there an updated version ?
Try changing the URL at the top of the script to the new location of the forum posts, change happened when the website changed at a guess.

Code: Select all

#TOPIC_URL="http://www.raspberrypi.org/phpBB3/viewtopic.php?p=462982"
TOPIC_URL="http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371"
That seems to have fixed it, thanks. An update has been loaded onto Dropbox. https://dl.dropboxusercontent.com/u/802 ... 8188eu.tgz. Download it again to get a working version.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Ciph
Posts: 7
Joined: Mon Aug 27, 2012 7:06 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sat Apr 19, 2014 10:24 am

Im confused, it seems every firmware version is compatible with 20140117 all of sudden? Which files do you want me to host?
Last edited by Ciph on Mon Apr 06, 2015 9:21 pm, edited 2 times in total.
http://www.inik.org

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sat Apr 19, 2014 12:52 pm

Ciph wrote:Im confused, it seems every firmware version is compatible with 20140117 all of sudden? Which files do you want me to host? (I host http://dl.ciph.se/raspberrypi
Hi Ciph,

Sorry for the confusion. I have updated ALL the drivers for 3.10.18+ to 3.10.37+ to add new USB device D-Link DWA 123 D1 and I found that the same driver appears to work for 3.10.27+ to 3.10.37+. I was very surprised as it seems very strange that the same driver works for so many different revisions. However the same thing happened with 3.6.11+ #370 to #520. A single driver worked over many revisions although in that case they were all 3.6.11+ which is a rather different situation.

I am now worried though that I may have made an error so I am checking them all again but it will take some time. I will let you know what I find.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sun Apr 20, 2014 3:16 pm

All drivers have been check and are operating OK.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Crademann
Posts: 1
Joined: Sat Apr 26, 2014 3:34 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sat Apr 26, 2014 3:38 pm

Thanks for the great job, MrEngman!

Ciph
Posts: 7
Joined: Mon Aug 27, 2012 7:06 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sat Apr 26, 2014 6:22 pm

Updated my mirror to have the latest and right versions
http://www.inik.org

VipeRsan
Posts: 7
Joined: Fri Jan 11, 2013 1:08 am

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sun Apr 27, 2014 9:21 pm

Any chance for driver for next branch kernel (3.12.18+ #673)?

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Sun Apr 27, 2014 10:52 pm

VipeRsan wrote:Any chance for driver for next branch kernel (3.12.18+ #673)?
Try this https://dl.dropboxusercontent.com/u/802 ... -18.tar.gz

I have compiled it but haven't tested it as I do not have an SD card with 3.12.18+ so I'm not sure if it will work or not. If you try it let me know what happens.

Download and install with

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-3-12-18.tar.gz
tar -zxvf 8188eu-3-12-18.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.12.18+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.12.18+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod 3.12.18+
MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

VipeRsan
Posts: 7
Joined: Fri Jan 11, 2013 1:08 am

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.37+

Mon Apr 28, 2014 8:38 am

This work great. Thank you.

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Mon Apr 28, 2014 10:41 pm

Hi everyone,

So the kernel has been updated to 3.12.18+.

Drivers for rtl8188eu based wifi adaptors for kernel 3.12.18+ are now available. A list of available drivers and installation instructions are here.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

User avatar
Jessie
Posts: 1754
Joined: Fri Nov 04, 2011 7:40 pm
Location: C/S CO USA

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Mon Apr 28, 2014 10:48 pm

I'm pretty sure without your help 25% of all RPi wifi users would be out of luck. Sigh... now I have to run a ethernet cable my arcade cab to fix its drivers.

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Tue Apr 29, 2014 1:24 am

Jessie wrote:I'm pretty sure without your help 25% of all RPi wifi users would be out of luck. Sigh... now I have to run a ethernet cable my arcade cab to fix its drivers.
Hi Jessie,

There is a way round this which makes it is possible to update the driver for the new version without needing to connect the wired network or copy the driver from another machine.

First run sudo rpi-update to get the updated code, but do not reboot yet.

Check the commit id reported by rpi-update as it is finishing running. e.g.

Code: Select all

 *** Syncing changes to disk
 *** If no errors appeared, your firmware was successfully updated to 8643317f122bf5eb786218a23784ceae7ea312eb
 *** A reboot is needed to activate the new firmware
Now take a look at the Hexxeh/rpi-firmware git repo, https://github.com/Hexxeh/rpi-firmware/commits/master, and look for the commit ID reported by rpi-update. Make a note of the commit description, in this case

Code: Select all

kernel: Add fiq fsm rewrite ...
Now look at the raspberrypi/firmware git repo, https://github.com/raspberrypi/firmware/commits/master, and look for the commit with the same commit decription that you found in the Hexxeh/rpi-firmware git repo. This corresponds to rasperrypi/firmware commit 316b922df9159467c2d40f819e74be1dd8685434. Browse the code to firmware/extra and open uname_string. Look at the text and this will show the kernel version and hash value - 3.12.18+ and #677.

You can now use these values to check for an available wifi driver. If you're lucky, and I've updated the kernel before you have, a driver should be available in the list in the first post in this thread. http://www.raspberrypi.org/forums/viewt ... 82#p462982

NOTE: if the driver version used by the new kernel version is the same as the one used by the currently running kernel you must still install (re-install) the driver as it will be loaded from a new directory when the new kernel boots.

Download the driver and install and register it and finally reboot, using the kernel version from uname_string above, in this case 3.12.18+, for the sudo install and sudo depmod commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20140425.tar.gz
tar -xzvf 8188eu-20140425.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.12.18+/kernel/drivers/net/wireless
sudo depmod 3.12.18+
sudo reboot
After rebooting hopefully you will find your wifi will start up as normal, so no need for the network cable.

Sorry it's not going to be too useful this time around but for future updates should be quite useful. Now I really should add this to the installation instructions in my original post.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

gjstevens
Posts: 1
Joined: Tue Apr 29, 2014 10:33 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Wed Apr 30, 2014 12:52 am

hi guys, i just got my RPI today and have been trying to set it up for a few hours but am running into some problems
after loading a raspbian image running rpi-update & apt-get update
the TL-WN752N was installed properly using the helpful script on this page, i configured it in /etc/network/interfaces and it was working.

then i installed debs for PiTFT screen (tried using both beta & normal deb)
https://learn.adafruit.com/adafruit-pit ... stallation

it gets the display working but breaks the wifi for me, the kernel changes to 3.10.32+ #6 (on beta deb, on the other deb it also changes to some other number)

i tried reinstalling TPlink after installing PiTFT debs using the install script but get a "cannot match kernel" error message.
reinstalling with -k for closest kernel build doesnt do anything either...

then i ran a script which should compile TPLink drivers and install them
http://tech.enekochan.com/2014/03/08/ne ... -raspbian/

which failed with ERROR: could not insert ’8188eu’: Exec format error

id like to have both a connection and a display,
and am running out of ideas,
i thought maybe id need to first install TL-WN752N drivers
and then somehow add this: http://adafruit-download.s3.amazonaws.c ... uit-ts.zip
to the kernel, but i am a linux novice i dont know what the proper way would be t
can someone please point me in the right direction
it would be much appreciated

EDIT: i found out in bootlog after installing pitft debs
WPA supplicant fails to start and wlan0 no longer shows up in ifconfig

i really dont know what to try next to get this working, been at it all night
without any results.

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Wed Apr 30, 2014 10:04 am

gjstevens wrote: i cloned the git and ran make it will give the error:

make: *** /lib/modules/3.10.32+/build: No such file or directory stop

i really dont know what to try next to get this working, been at it all night
without any results.
You need to generate a sumbolic link to point /lib/modules/3.10.32+/build to your linux source directory. Like

Code: Select all

sudo ln -s /home/pi/src/linux /lib/modules/3.10.32+/build
Just set /home/pi/src/linux to where you have installed your linux source. You may find you then get an error about armv6l. In that case you need another symlink like

Code: Select all

sudo ln -s /home/pi/src/linux/arch/arm /home/pi/src/linux/arch/armv6l
making sure /home/pi/src/linux points to your source directory.

You should probably also update gcc to gcc-4.7. Use the commands

Code: Select all

sudo apt-get install gcc-4.7
sudo rm /usr/bin/gcc
sudo ln -s /usr/bin/gcc-4.7 /usr/bin/gcc
sudo rm /usr/bin/cpp
sudo ln -s /usr/bin/cpp-4.7 /usr/bin/cpp
This should load gcc-4.7 and cpp-4.7 and update the gcc and cpp links from gcc-4.6 and cpp-4.6 to gcc-4.7 and cpp-4.7.

I think you will now find the driver will compile.

I am not keen on the lwfinger code and use a different version which does not need a separate firmware file installing. I use the driver in this file http://lazyzhu.com/file/RTL8188EUS_RTL8 ... 131104.zip. There is a patch for it at https://dl.dropboxusercontent.com/u/802 ... 88eus.diff. You can download these using the command wget.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

LA40
Posts: 1
Joined: Wed Apr 30, 2014 8:21 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Wed Apr 30, 2014 8:30 pm

Works like charm :)
Thanks for this drivers.

skr3ch
Posts: 7
Joined: Thu May 01, 2014 3:08 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Thu May 01, 2014 3:11 pm

Hi all,
I finished the guide.
But now, if I boot raspbian with the dongle, it seems "freezed" at login time.
So I cannot do anything.

Which could be the problem?

oykawa
Posts: 1
Joined: Sun Jul 21, 2013 12:40 am
Location: Szombathely, Magyarország

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Sun May 04, 2014 7:44 am

I'm updated kernel 3.12.18+ #680!

All drivers have been check and are operating OK.

t.moro
Posts: 2
Joined: Fri May 09, 2014 7:09 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Fri May 09, 2014 7:12 pm

Very Very thanks for your job and for the post.
But I've a problem, the driver works fine but after reboot I've to retype the insmod command, why?
I've the 3.10.24+ kernel

thanks!

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Fri May 09, 2014 9:47 pm

t.moro wrote:Very Very thanks for your job and for the post.
But I've a problem, the driver works fine but after reboot I've to retype the insmod command, why?
I've the 3.10.24+ kernel

thanks!
Possibly the driver has not been installed or registered properly. Did you use these commands to install it

Code: Select all

# for Raspbian download and untar driver for 3.10.24+ #610
wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20131209.tar.gz
tar -zxvf 8188eu-20131209.tar.gz

# Or for 3.10.24+ #614
wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20131219.tar.gz
tar -zxvf 8188eu-20131219.tar.gz

# install module and register it
sudo install -p -m 644 8188eu.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
sudo insmod /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a
Try command sudo depmod 3.10.24+ and then see if it starts up when you reboot.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

mogren
Posts: 2
Joined: Fri May 09, 2014 11:18 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Fri May 09, 2014 11:23 pm

Just did a fresh install tonight, and sadly 3.12.18+ does not work with 3.12.19+. Tried with rasplex yesterday and that worked fine, but raspbian doesn't include the 8188eu driver, any idea why? I'm running:
Linux raspberrypi 3.12.19+ #681 PREEMPT Fri May 9 16:36:10 BST 2014 armv6l GNU/Linux
How hard is it to build a new version? Do I need do set up a full cross-compile toolchain? :?

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.18+

Sat May 10, 2014 1:50 am

mogren wrote:Just did a fresh install tonight, and sadly 3.12.18+ does not work with 3.12.19+. Tried with rasplex yesterday and that worked fine, but raspbian doesn't include the 8188eu driver, any idea why? I'm running:
Linux raspberrypi 3.12.19+ #681 PREEMPT Fri May 9 16:36:10 BST 2014 armv6l GNU/Linux
How hard is it to build a new version? Do I need do set up a full cross-compile toolchain? :?
There's plenty on the forum about compiling modules.

You could try 8188eu-20140509.tar.gz compiled for 3.12.19+. Look here http://www.raspberrypi.org/forums/viewt ... 82#p462982

Download and install with

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20140509.tar.gz
tar -zxvf 8188eu-20140509.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.12.19+/kernel/drivers/net/wireless
sudo depmod 3.12.19+
sudo insmod /lib/modules/3.12.19+/kernel/drivers/net/wireless/8188eu.ko

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

mogren
Posts: 2
Joined: Fri May 09, 2014 11:18 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.19+

Sat May 10, 2014 7:34 am

Thanks, worked perfectly. I really tried to find drivers for 3.12.19+, don't know how I missed them.

MrEngman
Posts: 3946
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.19+

Sat May 10, 2014 7:51 am

mogren wrote:Thanks, worked perfectly. I really tried to find drivers for 3.12.19+, don't know how I missed them.
Probably because you looked for it before I compiled it and updated the list. :)


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

lorigio
Posts: 68
Joined: Tue Aug 20, 2013 8:38 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.19+

Sat May 10, 2014 8:54 am

Hi thanks for your work :D
However how can i update the drivers for every new firmware before reboot?
Now i must plug my pc keyboard on the pi to update the firmware because ssh is no longer accessible after firmware update.

Return to “Troubleshooting”