Page 8 of 58

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.33+

Posted: Wed Mar 19, 2014 7:05 pm
by epg
Hi MrEngman,
I'm experiencing slow speed transfert with Raspbmc stock rtl8188eu driver (below 10 Mb/s), so I'd like to use one of yours precompiled drivers; uname -a says: Linux raspbmc 3.10.24 #2 PREEMPT Mon Dec 23 05:18:12 UTC 2013 armv6l GNU/Linux. What driver I have to download? It seems that there isn't a precompiled drv for this kernel version...

Thank you for work :D

Epg.

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.33+

Posted: Wed Mar 19, 2014 7:34 pm
by MrEngman
I think the driver is the same as I use so will almost certainly not make any difference.

MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.33+

Posted: Sun Mar 23, 2014 6:56 pm
by antman313
Hi everybody !

I need some help :(
Searched google, searched this forum
tried this --> http://dl.dropboxusercontent.com/u/8025 ... 188cus.txt
tried this --> http://forum.stmlabs.com/showthread.php?tid=10805
tried this --> http://tech.enekochan.com/2013/05/29/co ... -raspbian/

no luck at all.

lsusb

Code: Select all

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
Bus 001 Device 005: ID 0c45:7000 Microdia 
Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp. 
Bus 001 Device 007: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
uname -a

Code: Select all

[Linux raspberrypi 3.10.32+ #3 PREEMPT Fri Feb 28 01:41:33 SGT 2014 armv6l GNU/Linux
I use the Adafruit TFT 2.8" Display to monitor some stuff, so I installed the kernal patch from the Adafruit-Site.

I want to use the WiFi USB dongle. But it isn't working at all. Tried a lot - realy. No luck!!

Hope someone can help me. Give me a hint.

If I trie do compile it by myselfe - got this error everytime:

Code: Select all

[email protected]{[19:54]->~/wifi/rpi-rtl8188eu}: CONFIG_RTL8188EU=m make -C ../rpi-linux M=`pwd`make: Entering directory `/home/pi/wifi/rpi-linux'
  CC [M]  /home/pi/wifi/rpi-rtl8188eu/core/rtw_cmd.o
In file included from /home/pi/wifi/rpi-rtl8188eu/core/rtw_cmd.c:23:0:
/home/pi/wifi/rpi-rtl8188eu/include/osdep_service.h: In function ‘thread_enter’:
/home/pi/wifi/rpi-rtl8188eu/include/osdep_service.h:1397:2: error: implicit declaration of function ‘daemonize’ [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
make[1]: *** [/home/pi/wifi/rpi-rtl8188eu/core/rtw_cmd.o] Fehler 1
make: *** [_module_/home/pi/wifi/rpi-rtl8188eu] Fehler 2
make: Leaving directory `/home/pi/wifi/rpi-linux'
Thanks for some help.

Andy

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Mar 29, 2014 12:57 am
by dicoy
I also have the same issue:
[email protected]:~$ lsusb
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.
[email protected]:~$ uname -v
#2 PREEMPT Mon Dec 23 05:18:12 UTC 2013

I'm trying these drivers now:
https://github.com/gleb-chipiga/rtl8188eu

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Fri Apr 04, 2014 11:08 pm
by MrWm
Is there a driver for :

Code: Select all

Linux raspberrypi 3.10.36+ #662 PREEMPT Fri Apr 4 18:31:16 BST 2014 armv6l GNU/Linux
Or am I going to have to compile one myself...? :|

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Apr 05, 2014 9:13 am
by MrEngman
MrWm wrote:Is there a driver for :

Code: Select all

Linux raspberrypi 3.10.36+ #662 PREEMPT Fri Apr 4 18:31:16 BST 2014 armv6l GNU/Linux
Or am I going to have to compile one myself...? :|
You can try this

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-test.tar.gz
tar -zxvf 8188eu-test.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.10.36+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.10.36+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod 3.10.36+
This is a new driver I've compiled for 3.10.36+ but I've found it works with all versions from 3.10.27+ #630 to 3.10.36+ #662.

Let me know how you get on.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Apr 05, 2014 7:18 pm
by MrWm
MrEngman wrote:
MrWm wrote:Is there a driver for :

Code: Select all

Linux raspberrypi 3.10.36+ #662 PREEMPT Fri Apr 4 18:31:16 BST 2014 armv6l GNU/Linux
Or am I going to have to compile one myself...? :|
You can try this

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-test.tar.gz
tar -zxvf 8188eu-test.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.10.36+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.10.36+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod 3.10.36+
This is a new driver I've compiled for 3.10.36+ but I've found it works with all versions from 3.10.27+ #630 to 3.10.36+ #662.

Let me know how you get on.


MrEngman
Well... I followed your instructions and installed the driver,but immediately following the depmod -a it caused a reboot. Now the GUI is not responsive with keyboard and mouse input... Still no wifi. :'(

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Apr 05, 2014 7:44 pm
by MrEngman
Hi MrWm,

If sudo depmod 3.10.36+ caused a reboot then it's likely there may be a problem with the setup. Did you try the setup from a terminal in the GUI or did you run them from the Command Line Terminal?

What do these commands show

Code: Select all

cat /etc/network/interfaces
sudo cat /etc/wpa_supplicant/wpa_wpa_supplicant.conf
ifconfig
Does command

Code: Select all

sudo iwlist wlan0 scan
show any networks or just a message?


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Apr 05, 2014 7:58 pm
by rgc2000
Works fine for me over command line on 3.10.36+. I don't use GUI, only remote ssh access.
Thank you

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sat Apr 05, 2014 9:36 pm
by MrEngman
rgc2000 wrote:Works fine for me over command line on 3.10.36+. I don't use GUI, only remote ssh access.
Thank you
Thanks for the update. I usually only use SSH as well.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sun Apr 06, 2014 12:01 am
by MrWm
MrEngman wrote:Hi MrWm,

If sudo depmod 3.10.36+ caused a reboot then it's likely there may be a problem with the setup. Did you try the setup from a terminal in the GUI or did you run them from the Command Line Terminal?

What do these commands show

Code: Select all

cat /etc/network/interfaces
sudo cat /etc/wpa_supplicant/wpa_wpa_supplicant.conf
ifconfig
Does command

Code: Select all

sudo iwlist wlan0 scan
show any networks or just a message?


MrEngman
Nevermind.. I found my error... I entered depmod -a instead of depmod 3.10.36+
--
I am now reflashing my card with noobs 1.3, hopefully this will help.
EDIT:
I also installed the wrong driver... :o thus giving me a headache...
...now how do I uninstall a 3.10.25+ 8188eu.ko from a 3.10.36+ system?

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sun Apr 06, 2014 1:48 pm
by MrEngman
MrWm wrote:I am now reflashing my card with noobs 1.3, hopefully this will help.
EDIT:
I also installed the wrong driver... :o thus giving me a headache...
...now how do I uninstall a 3.10.25+ 8188eu.ko from a 3.10.36+ system?
Installing the newer driver should just overwrite the older one so there shouldn't be any necessity to uninstall the old one.

You can of course search for all loaded copies of the 8188eu.ko driver file and delete any that are unnecessary.

Code: Select all

sudo find / -name 8188eu.ko
and delete them using command

Code: Select all

sudo rm /directory/to/8188eu.ko
for each one in the list the find command shows.

The only one you need to keep is

Code: Select all

/lib/modules/3.10.36+/kernel/drivers/net/wireless/8188eu.ko
The newer drivers I compile do not need a separate firmware file, rtl8188eufw.bin, so you could delete that as well, if it's installed, but it is not necessary except to gain an extra few KBs of space as it will be ignored by the new driver.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sun Apr 06, 2014 4:36 pm
by MrWm
MrEngman wrote:
MrWm wrote:I am now reflashing my card with noobs 1.3, hopefully this will help.
EDIT:
I also installed the wrong driver... :o thus giving me a headache...
...now how do I uninstall a 3.10.25+ 8188eu.ko from a 3.10.36+ system?
Installing the newer driver should just overwrite the older one so there shouldn't be any necessity to uninstall the old one.

You can of course search for all loaded copies of the 8188eu.ko driver file and delete any that are unnecessary.

Code: Select all

sudo find / -name 8188eu.ko
and delete them using command

Code: Select all

sudo rm /directory/to/8188eu.ko
for each one in the list the find command shows.

The only one you need to keep is

Code: Select all

/lib/modules/3.10.36+/kernel/drivers/net/wireless/8188eu.ko
The newer drivers I compile do not need a separate firmware file, rtl8188eufw.bin, so you could delete that as well, if it's installed, but it is not necessary except to gain an extra few KBs of space as it will be ignored by the new driver.


MrEngman
I can't believe I have to say this... But every time I plug in the Wi-Fi adapter ,the pi rebooted...
I am sorry for making this confusing...

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.34+

Posted: Sun Apr 06, 2014 5:03 pm
by MrEngman
MrWm wrote:I can't believe I have to say this... But every time I plug in the Wi-Fi adapter ,the pi rebooted...
I am sorry for making this confusing...
No trouble, this is normal behaviour with the Pi unfortunately. You need to have your wifi module plugged in before turning on the power. Or use a powered hub and plug the wifi into the hub. I have found, however, that using a hub can sometimes cause odd problems.

I have found a way round this issue and that is to connect the wifi adaptor to the Pi using a USB extension cable. I can then unplug and plug in the wifi to the extension cable without the Pi rebooting.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Sun Apr 06, 2014 6:13 pm
by MrWm
Thank you MrEngman. It finally worked for me. :) :P

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Sun Apr 06, 2014 8:13 pm
by MrEngman
MrWm wrote:Thank you MrEngman. It finally worked for me. :) :P
That's good to hear. Have fun with your Pi.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Wed Apr 09, 2014 11:56 pm
by bhollehday
Im getting

"Error (404)
We can't find the page you're looking for. Check out our Help Center and forums for help, or head back to home."

When I go to the driver website..

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Thu Apr 10, 2014 1:08 am
by MrEngman
bhollehday wrote:Im getting

"Error (404)
We can't find the page you're looking for. Check out our Help Center and forums for help, or head back to home."

When I go to the driver website..
OK, what are you trying to do, what driver website? Would be helpful if you said what you are actually trying to do, or what command was causing the error.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Thu Apr 10, 2014 2:55 am
by bhollehday
sorry I got confused with the instructions. Got it on now and it seems to be working. Its connected to my Wifi network but when i try and go to a website it says it cant be reached. I have an ip address and everything seems to be connected and working..

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Fri Apr 11, 2014 4:19 pm
by sepal
Hi,
has anyone compiled a driver for the following kernel?

Code: Select all

Linux picam 3.6.11+ #26 PREEMPT Tue Nov 26 18:19:51 SGT 2013 armv6l GNU/Linux
The kernel is required in order to use the framebuffer feature for the PiTFT
I've tried several compiled files, but non has worked so far.

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Mon Apr 14, 2014 5:03 am
by mzs
Thanks for the pre-compiled module and all the work you have done.
I found this which may interest you.
http://314256.blogspot.com/2014/04/part ... ghput.html

I was a bit disappointed by the throughput rates, until I found out that it was pretty much the same for all WiFi and not some limitation of the RPi, the driver or a bottleneck caused by the shared internal three port USB hub.

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Mon Apr 14, 2014 9:27 am
by MrEngman
mzs wrote:Thanks for the pre-compiled module and all the work you have done.
I found this which may interest you.
http://314256.blogspot.com/2014/04/part ... ghput.html

I was a bit disappointed by the throughput rates, until I found out that it was pretty much the same for all WiFi and not some limitation of the RPi, the driver or a bottleneck caused by the shared internal three port USB hub.
Ok if you want to see how fast the wifi can transfer at but this is the trouble with speed tests and this one is very artificial. When are you going to download data from another machine on your network and effectively throw the data away by transferring to /dev/null. A real world test where the data is being transferred from the internet into or out of memory (SD card) rather than using /dev/null is far more realistic. My wifi transfer rates vary considerably depending on what is happening on my network and how many others are using it. Max rates I see are about 800KB/s but it sometimes transfers much slower, sometimes as slow as 10KB/s, if the network is busy.


MrEngman

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.36+

Posted: Mon Apr 14, 2014 3:41 pm
by mzs
MrEngman wrote:
mzs wrote:Thanks for the pre-compiled module and all the work you have done.
I found this which may interest you.
http://314256.blogspot.com/2014/04/part ... ghput.html

I was a bit disappointed by the throughput rates, until I found out that it was pretty much the same for all WiFi and not some limitation of the RPi, the driver or a bottleneck caused by the shared internal three port USB hub.
Ok if you want to see how fast the wifi can transfer at but this is the trouble with speed tests and this one is very artificial. When are you going to download data from another machine on your network and effectively throw the data away by transferring to /dev/null. A real world test where the data is being transferred from the internet into or out of memory (SD card) rather than using /dev/null is far more realistic. My wifi transfer rates vary considerably depending on what is happening on my network and how many others are using it. Max rates I see are about 800KB/s but it sometimes transfers much slower, sometimes as slow as 10KB/s, if the network is busy.


MrEngman
I agree that it is an artificial test, but it does set as many things that can be controlled to a known best case, to see the maximum data rate achievable. Like if you were capturing an image with the RPi camera module, storing the jpg on a RAM disk and uploading it to a website. If you were getting only 1KB/sec you would be reasonably sure that unless it was in an airport (high 802.11/bluetooth interference area) that WiFi was not the cause of this bottleneck. It is a test where the smallest link in the data transfer chain should be the WiFi, it is basically trying to stress it and it alone.

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.25+

Posted: Wed Apr 16, 2014 8:20 am
by szafran
LaFambe wrote:attached is an updated version of the "automatic download and install script": version information is fetched directly from the initial post in this topic, and firmware is systematically installed if present in tarball. Use install-8188eu.sh to download and install the proper driver for the rpi you run from. Use install-8188eu.sh -k <kernel build> to select the closest available driver version in case no exact match is found for the local kernel. install-8188eu.sh -l shows a list of available driver versions.

[email protected] ~ $ ./install-8188eu.sh -h
usage: install-8188eu.sh [-k|--kernel <kernel build>] [-l|--list]

UPDATE: fixed version of the script attached.
INSTALL: [email protected] ~ $ curl -s http://www.raspberrypi.org/phpBB3/downl ... hp?id=5536 | tar xz
That script doesn't work anymore (great work btw)... is there an updated version ?

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.10.25+

Posted: Wed Apr 16, 2014 9:28 am
by mzs
szafran wrote:
LaFambe wrote:attached is an updated version of the "automatic download and install script": version information is fetched directly from the initial post in this topic, and firmware is systematically installed if present in tarball. Use install-8188eu.sh to download and install the proper driver for the rpi you run from. Use install-8188eu.sh -k <kernel build> to select the closest available driver version in case no exact match is found for the local kernel. install-8188eu.sh -l shows a list of available driver versions.

[email protected] ~ $ ./install-8188eu.sh -h
usage: install-8188eu.sh [-k|--kernel <kernel build>] [-l|--list]

UPDATE: fixed version of the script attached.
INSTALL: [email protected] ~ $ curl -s http://www.raspberrypi.org/phpBB3/downl ... hp?id=5536 | tar xz
That script doesn't work anymore (great work btw)... is there an updated version ?
Try changing the URL at the top of the script to the new location of the forum posts, change happened when the website changed at a guess.

Code: Select all

#TOPIC_URL="http://www.raspberrypi.org/phpBB3/viewtopic.php?p=462982"
TOPIC_URL="http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371"