TJarsun
Posts: 1
Joined: Tue Aug 22, 2017 11:16 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Wed Aug 23, 2017 12:15 am

After installing raspbian lite if I did an "ifconfig" I see the adapter named as wlx[MAC ADDRESS] and "lsusb" showed it to me as
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
so all I had to do was to run this:

sudo ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules

- And reboot. it is now shown as wlan0 and I can scan and see my networks using:

iwlist wlan0 scan

- Next I added my wifi network data with

sudo nano /etc/network/interfaces
and added:
"
allow-hotplug wlan0
iface wlan0 inet manual
wpa-ssid "NETWORKNAME"
wpa-psk "PASSWORD"
"
Saved with ctrl+x then Y and enter
Did a reboot
After that it auto-connected to my wifi!

ernestosu16
Posts: 1
Joined: Wed Sep 06, 2017 7:17 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Wed Sep 06, 2017 7:23 pm

I have a problem after installing the driver.

Code: Select all

root@raspberrypi:~# brctl addbr br0

root@raspberrypi:~# brctl addif br0 wlan0
can't add wlan0 to bridge br0: Operation not supported


root@raspberrypi:~# iwconfig 
lo        no wireless extensions.

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.437 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

it is possible to install the generic driver that brings by default that if I worked

MrEngman
Posts: 3635
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Thu Sep 07, 2017 7:18 am

You can remove my driver using commands

Code: Select all

sudo rm /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8188eu.ko
sudo rm /etc/modprobe.d/8188eu.conf
sudo depmod $(uname -r)
Rebooting should then use the built in staging driver.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

danielu221
Posts: 2
Joined: Thu Oct 08, 2015 6:15 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Tue Sep 12, 2017 7:40 am

Hello everyone,

currently I have newest version of Raspbian and that TL-WN725N . I had same problems 1 year ago, but finally I resolved it as I remember with maaany problems. I had to clear SD card and now have another raspbian version. What should I do now? Is it possible to run it with newest raspbian version (release 2017-09-07) or I should do downgrade to specified version? I don;t have much time for configurations that's why I am asking. Thanks a lot for any help :)

bicyclerepairman
Posts: 2
Joined: Wed Oct 25, 2017 9:00 am

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Wed Oct 25, 2017 9:15 am

I have a similar problem to the last poster. I have an RPi B2, now running the latest OS image (Stretch, Sept 2017). I have just acquired a Dynamode N RTL Wifi dongle - internally it is a Realtek RTL8188EUS. After plugging it in, clicking on the network icon shows "No wireless interfaces found".

lsusb:
RTL8188EUS 0dba:8179

lsmod:
r8188eu - not used
cfg80211 - r8188eu

iwconfig:
wlan0 unassociated Nickname "<WIFI@REALTEK>"
...(more stuff)

I have a PC running lubuntu, and this dongle works straight away. It also gives the same responses to the above commands (except iwconfig).

If I run "modinfo r8188eu", the Pi and the Lubuntu PC give very similar responses. The "version" is identical. The main differences are different values for "srcversion" and "vermagic" (lubuntu shows "4.10.0-37-generic SMP mod_unload", Pi shows "4.9.41-v7- SMP mod_unload modversions ARMv7 p2v8").

I have tried the previous instructions in this thread to use the 8188eu driver, with no success.

Any help appreciated!!

User avatar
fruitoftheloom
Posts: 15755
Joined: Tue Mar 25, 2014 12:40 pm
Location: Bognor Regis UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Wed Oct 25, 2017 3:36 pm

bicyclerepairman wrote:
Wed Oct 25, 2017 9:15 am
I have a similar problem to the last poster. I have an RPi B2, now running the latest OS image (Stretch, Sept 2017). I have just acquired a Dynamode N RTL Wifi dongle - internally it is a Realtek RTL8188EUS. After plugging it in, clicking on the network icon shows "No wireless interfaces found".

lsusb:
RTL8188EUS 0dba:8179

lsmod:
r8188eu - not used
cfg80211 - r8188eu

iwconfig:
wlan0 unassociated Nickname "<WIFI@REALTEK>"
...(more stuff)

I have a PC running lubuntu, and this dongle works straight away. It also gives the same responses to the above commands (except iwconfig).

If I run "modinfo r8188eu", the Pi and the Lubuntu PC give very similar responses. The "version" is identical. The main differences are different values for "srcversion" and "vermagic" (lubuntu shows "4.10.0-37-generic SMP mod_unload", Pi shows "4.9.41-v7- SMP mod_unload modversions ARMv7 p2v8").

I have tried the previous instructions in this thread to use the 8188eu driver, with no success.

Any help appreciated!!

The drivers are compiled for Raspbian Operating System, Ubuntu Flavours Community Editions suitable for Rpi2/3 and have their own website / forum:

https://ubuntu-pi-flavour-maker.org/

https://ubuntu-pi-flavour-maker.org/faq/
""understanding the theoretical, but not always the end goal""

My other Devices are the ChromeBit CS10, ChromeCast & Huawei Mate 10 Pro SmartPhone

bicyclerepairman
Posts: 2
Joined: Wed Oct 25, 2017 9:00 am

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Thu Oct 26, 2017 4:46 pm

fruitoftheloom wrote:
Wed Oct 25, 2017 3:36 pm

The drivers are compiled for Raspbian Operating System, Ubuntu Flavours Community Editions suitable for Rpi2/3 and have their own website / forum:

https://ubuntu-pi-flavour-maker.org/

https://ubuntu-pi-flavour-maker.org/faq/
Just tried it - the taskbar menu icon shows "Wifi Networks - device not ready".

I have also just tried the Wifi dongle in my Lubuntu PC. It works straight away and connects to wifi.

Mustafa Wahhudi
Posts: 1
Joined: Thu Nov 09, 2017 11:43 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Thu Nov 09, 2017 11:52 pm

Hello MrEngman,

I've tried to download the file 8188eu-20130830.tar.gz for my 3.6.11+ #538 using the command:

Code: Select all

wget http://www.fars-robotics.net/8188eu-20130830.tar.gz
But I get "ERROR 404: Not Found."

What could be wrong? I'm sure my internet is working properly, and I can access www.fars-robotics.net normally.
I'd be very grateful if you can provide me with a working/alternative link for the file
8188eu-20130830.tar.gz
as soon as you can, since my project is now depending on it :)

Many thanks to you for your efforts...

User avatar
DougieLawson
Posts: 31235
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Fri Nov 10, 2017 12:31 am

Why are you trying to do anything with a system that's running a four year old kernel? You really need to upgrade to the supported version of Raspbian.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

MrEngman
Posts: 3635
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Fri Nov 10, 2017 12:51 am

Mustafa Wahhudi wrote:
Thu Nov 09, 2017 11:52 pm
Hello MrEngman,

I've tried to download the file 8188eu-20130830.tar.gz for my 3.6.11+ #538 using the command:

Code: Select all

wget http://www.fars-robotics.net/8188eu-20130830.tar.gz
But I get "ERROR 404: Not Found."

What could be wrong? I'm sure my internet is working properly, and I can access www.fars-robotics.net normally.
I'd be very grateful if you can provide me with a working/alternative link for the file
8188eu-20130830.tar.gz
as soon as you can, since my project is now depending on it :)

Many thanks to you for your efforts...
Try again. Should be available now.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

bhontz
Posts: 1
Joined: Fri Jan 12, 2018 11:03 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Fri Jan 12, 2018 11:05 pm

Hi all - this thread has been incredible valuable, thank you to the contributors and question askers. However, after working on this for several hours I'm still unresolved.

I'm attempting to install a Rosewell RNX-N150NUB wifi dongle purchased from Amazon (claiming to be Raspberry Pi compatible). I'm working with a Raspberry Pi 2 Model B 1GB. I actually have 10 of these, I'm setting these up for a club.

pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.18.11-v7+ #781 SMP PREEMPT Tue Apr 21 18:07:59 BST 2015 armv7l GNU/Linux

pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:ffef Realtek Semiconductor Corp.

I tried the following build:
3.18.11-v7+ #780, #781 - 8188eu-v7-20150406.tar.gz

... as follows:
wget http://www.fars-robotics.net/8188eu-v7-20150406.tar.gz
tar xzf 8188eu-v7-20150406.tar.gz
./install.sh

Which didn't work, here meaning I can't see wlan0 when I "ifconfig".

I erased the 8188eu.ko driver installed by the above from /lib/modules/3.18.11-v7+/kernel/drivers/net/wireless/ and then tried:

sudo wget http://www.fars-robotics.net/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi

... and used the sudo install-wifi 8188eu

I don't receive any error messages in either of the two installation cases above, and further:

sudo insmod /lib/modules/3.18.11-v7+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a

... does not produce an errors.

However, when I ifconfig I can not see wlan0, but if I plug in an old Cisco wifi dongle that I used on an old Windows laptop, the I everything works just fine (i.e. shows wlan0 when I ifconfig and connects to my wifi network).

I note my lsusb ID (ID 0bda:ffef Realtek Semiconductor Corp.) differs from those posted within this thread. The Rosewell RNX-N150NUB dongle did come with drivers, including the 8188eu.ko, but using it as provided produces an "Invalid Module Format" when attempting insmod.

Any thoughts on how I might be able to move this forward?

Thank you in advance.

MrEngman
Posts: 3635
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Sat Jan 13, 2018 1:13 am

Hi bhontz,

The 8188eu driver I've compiled did not include the USB for your wifi module. I have updated the driver for the kernel version you are using, 3.18.11-v7+ #781, and added the USB ID for your wifi. I am updating the remaining drivers but that will take some time.

If you run the script again it should load the driver with your USB ID, provided you use kernel 3.18.11-v7+ #781.

After installing the driver if you run command modinfo 8188eu it should now show the USB ID for your wifi.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

macmpi
Posts: 30
Joined: Tue Dec 15, 2015 9:39 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Sun Feb 11, 2018 2:33 pm

@MrEngman
It seems there are none of your compiled driver somewhere following 4.9.70 (for instance 4.9.75) until latest 4.9.80; or has URL scheme changed since?

I could not find them for newer 4.14.x serie (like latest 4.14.17), which has now become new Hexxeh rpi-firmware master.
Does 4.14 branch include any in-kernel stable replacements now?

Thanks!

MrEngman
Posts: 3635
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Sun Feb 11, 2018 4:16 pm

macmpi wrote:
Sun Feb 11, 2018 2:33 pm
@MrEngman
It seems there are none of your compiled driver somewhere following 4.9.70 (for instance 4.9.75) until latest 4.9.80; or has URL scheme changed since?

I could not find them for newer 4.14.x serie (like latest 4.14.17), which has now become new Hexxeh rpi-firmware master.
Does 4.14 branch include any in-kernel stable replacements now?

Thanks!
I have changed the web address, http://downloads.fars-robotics.net.

Directory structure is

Code: Select all

downloads.fars-robotics.net 
             |
             - wifi-drivers 
                     |
                     - 8188eu-drivers
                     - 8192eu-drivers
                     - 8812au-drivers
                     - mt7610-drivers
                     - mt7612-drivers
To download 8188eu drivers use address http://downloads.fars-robotics.net/wifi ... -file-name where driver-file-name uses my standard filename format that I assume you have previously used.

If you use my script it will automatically determine the driver you need and download and install it. You can install my script using commands

Code: Select all

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi
Run command

Code: Select all

sudo install-wifi -h
for info on how to use it.

To install the driver for you current kernel just use command

Code: Select all

sudo install-wifi
There is a driver, r8188eu, included in the Rasbian images that will run 8188eu wifi modules but I've found it can have some problems. If you want to try it then you will need to delete file /etc/modprobe.d/8188eu.conf as it blacklists the built in driver.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

macmpi
Posts: 30
Joined: Tue Dec 15, 2015 9:39 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Sun Feb 11, 2018 5:38 pm

Ouch, I see...
When did this URL & directories layout change happen?

I have some build scripts pulling all drivers in their original location, so...bad luck: I'll adapt them accordingly, thanks for the note.
Could you update first post accordingly?

Thanks again for all the heavy-lifting.

Return to “Troubleshooting”

Who is online

Users browsing this forum: Baidu [Spider], pcmanbob and 61 guests