czoia
Posts: 1
Joined: Wed Jul 23, 2014 2:27 pm

Re: DS18B20 + Camera module; modprobe breaks camera

Wed Jul 23, 2014 3:08 pm

Hi everybody,

I'm sorry for resume this thread but I've some problem with the raspicam and ds18b20. The temperature sensor always read 85000; this has happened when i try to take a picture from raspicam: I've the problem discuss above in this page; I've try to resolve using the answer found here and now the camera working perfectly but the ds18b20 not! I've try to reset the change do before but nothing to do. I always read 85000.

I'm google for a lot of site but every solution failed.
My situation:

uname -a

Code: Select all

Linux raspberrypi 3.12.24+ #694 PREEMPT Tue Jul 15 17:34:35 BST 2014 armv6l GNU/Linux
/boot/cmdline.tx

Code: Select all

dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait bcm2708.w1_gpiopin=18
(without bcm2708.w1_gpioin=18 the result is the same)

/etc/modprobe.d/raspi-blacklist.conf

Code: Select all

blacklist spi-bcm2708
blacklist i2c-bcm2708
/etc/modules

Code: Select all

w1-gpio
w1-therm
i2c-bcm2078
i2c-dev
#snd-bcm2835
cat /sys/bus/w1/devices/28-0000041af68d/w1_slave

Code: Select all

50 05 4b 46 7f ff 0c 10 1c : crc=1c YES
50 05 4b 46 7f ff 0c 10 1c t=85000
I've try to change the order of modules in /etc/modules (eg w1-therm before w1-gpio pullup=1; w1-gpio instead w1-gpio pullup=1 etc) but never change...every read I do the temperature is always 85000. It's like the sensor don't receive correct signal for translate temperature, but I don't know how do that.

Can anyone help me?
Thank's a lot, I'm sorry for my noobies (and for my poor english)!

Return to “Troubleshooting”