Posts: 2
Joined: Sat Nov 02, 2013 6:44 pm

RaspberryPi stopped booting

Sat Nov 02, 2013 7:40 pm

My RaspberryPi suddenly stopped booting. When I power it on, green LED turns on for a second or two, but then nothing happens (nothing on screen - says "No input signal", nothing on serial port). I tried several SD cards that used to work with it, and I tried two different power supplies (Nokia 1.2A, Logitech 1A, both of which used to work with Pi), and nothing changes.

SD cards are being read, because if I remove start.elf, the green LED starts blinking 3 times every few seconds when I power it on. Any ideas what could be wrong, or what else I should try?

My Raspberry Pi is one of the older Model B's with 256MB RAM.

Posts: 2
Joined: Sat Nov 02, 2013 6:44 pm

Re: RaspberryPi stopped booting

Sat Nov 02, 2013 11:28 pm

OK, since I posted this, I tried a few more times, and now I sometimes get the rainbow square on the screen. On the serial port I see this when booting Linux:

Code: Select all

Uncompressing Linux...

uncompression error

 -- System halted
(regardless of the card; I have verified that the kernel image is fine).

I also tried booting a card with RiscOS, which gave me this on serial console:

Code: Select all

                                     0C100000 007F8000 HalQueryPldone
                                                                     0C100000 HalStartup2
         00008000 00000000 0C000000 ROM start, RAM start, RAM size
                                                                  ROM relocated
                                                                               HalStartup3 .. rst  rend
                       00000000 0BB00000 HalStart from OS
                                                         0C000000 04000000 F5000000  HAL Init completed
Nothing appeared on screen.

Posts: 23
Joined: Sat Jul 07, 2012 6:46 pm
Location: Oviedo, Florida U.S.A.
Contact: Website

Re: RaspberryPi stopped booting

Mon Nov 11, 2013 3:36 am

I suspect the power supply even though you've tried 2 that worked before. Have you added any other hardware peripherals such as wireless dongle, etc that could be drawing more power?

Return to “Troubleshooting”