User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Issue with Ralink RT5370 USB nano WiFi dongle since update

Sat Oct 26, 2013 10:13 pm

I've been using a Ralink RT5370 USB nano WiFi dongle (the one sold by ModMyPi) with my netbook-replacement Raspberry Pi unit (a 512MB Model B attached to a Motorola Atrix Lapdock, as described in my forum signature) for quite some time now. It's been rock-solid stable, for its time in use several hours every day, since I got the dongle a few months back - no problems whatsoever. Nothing has changed in my setup except for updating Raspbian twice over the last couple of weeks.

I typically run the sudo aptitude update and sudo aptitude upgrade commands every week or two, and until now have never had any problems. However, after an update last week the dongle would die at random (but infrequently), and an update a few days ago has caused it to work for a short while but then die completely after the Raspberry Pi has been up for a few minutes (at a guess, I'd say about three to five, but I haven't counted exactly :P). This has rendered it more-or-less unusable for its daily purpose.

Restoring to my most recent known-good backup of my SD Card is no problem at all, and I'm most likely going to do just that. However, I don't like running out-of-date software.

So, I'd like to know whether;

1: There's a fix or workaround for this issue? (For example, has something perhaps changed with the recent updates, and I need to manually change some files to sort out the problem? Or is there some package that I should prevent from being updated which is causing the problem?)

Or...

2: I can provide any information (i.e., run some commands and post their output, provide information from particular configuration files, or whatever) from my setup in its current state, before I restore it to its previous working state, so that the issue can be investigated and fixed by those in-the-know?

Thanks very much in advance for any advice offered - I really appreciate the time and effort of those who voluntarily offer assistance here on the forums. :) (And please accept my apologies if I've missed a pre-existing thread on this matter!)
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

1pi2much
Posts: 99
Joined: Sun Feb 24, 2013 6:58 pm

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Sun Oct 27, 2013 2:50 am

Might be worth trying a dist-upgrade instead of upgrade. Dont know why, but a dist-upgrade seems
to have fixed my recent wifi problems (with another wifi dongle).
YMMV

--


User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Tue Oct 29, 2013 10:39 pm

Thanks for the replies, guys.

Assuming that nobody wants me to provide any information from my currently-somewhat-broken installation, I'll be getting stuck into the above-linked thread, and/or following the dist-upgrade advice soon.

I'll hold off for another couple of days just in case.
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

SirLagz
Posts: 1705
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
Contact: Website

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Wed Oct 30, 2013 12:53 am

How long have you had the RT5370 ?
Mine died after a few months of continuous use, presenting the same symptoms you have there.
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044

User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Wed Oct 30, 2013 7:24 pm

SirLagz wrote:How long have you had the RT5370 ?
Mine died after a few months of continuous use, presenting the same symptoms you have there.
A couple of months, off of the top of my head.

That's concerning... I guess I'll restore my card to the pre-updated state and see if it still keeps happening, first...

Thanks very much for the heads-up.
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

SirLagz
Posts: 1705
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
Contact: Website

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Thu Oct 31, 2013 1:02 am

Not sure if mine failed just because they were cheapy cheapy ones though. YMMV
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044

User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Thu Oct 31, 2013 7:47 pm

I'm somewhat not suspecting failure here, purely because it comes back up fine after an immediate reboot, only to die again a few minutes later. I'm not sure it would be so consistent if the dongle was experiencing a hardware failure. :lol:
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

SirLagz
Posts: 1705
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
Contact: Website

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Fri Nov 01, 2013 7:03 am

LemmeFatale wrote:I'm somewhat not suspecting failure here, purely because it comes back up fine after an immediate reboot, only to die again a few minutes later. I'm not sure it would be so consistent if the dongle was experiencing a hardware failure. :lol:
Exactly what mine was doing lol...
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044

User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Fri Nov 01, 2013 6:14 pm

Oh, yay. :lol:

Well, I'll have a proper look at it shortly. I think I've waited long enough to give anyone who might want information retrieved from the current installation a chance to respond, now, assuming it is a software issue.
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

User avatar
LemmeFatale
Posts: 253
Joined: Fri Feb 01, 2013 8:47 pm
Location: UK

Re: Issue with Ralink RT5370 USB nano WiFi dongle since upda

Sun Nov 03, 2013 7:42 pm

Very, very sorry to double-post, but;

Good news! Restoring to my backup completely fixed the problem.

Of course...

Bad news! This means that I'm currently stuck with out-of-date software.

I'll try the dist-upgrade approach suggested by 1pi2much, tomorrow, and see if that will allow me to get up-to-date without breaking my WiFi setup.

I wonder what it is in the recent updates that has completely broken things?
Classic - Raspberry Pi Model B (512MB) with Motorola Atrix Lapdock
Lemcon-One - Raspberry Pi Model B (256MB) PiMAME TV-Box

Return to “Troubleshooting”