AlexTheStampede
Posts: 4
Joined: Thu Sep 12, 2013 7:12 pm

Wrong keyboard settings in LXDE

Thu Sep 12, 2013 7:30 pm

So, today I got my model B (YAY!) with a card containing NOOBS. Installed fairly quickly (Raspian), raspi-config is full of easy and interesting settings, including locale and keyboard. I did set those properly, and as a result I can use all of my italian keyboard. So where is the problem? "startx" open a browser, type @ and nothing happens. Uh-oh. Wrong settings, indeed. And nothing can configure it properly, the mouse and keyboard thing allows to set speed of the mouse and key repetition for the keyboard, but nothing else. DuckDuckGo fails me, the forum search too, as I apparently did all I had to.

Keep in mind my experience with Linux is basic (some Linuxing at home, a server setup only via ssh, OSX as my OS of choice), so I can do some stuff but nothing too unusual. And clearly I'm good at copy-pasting commands :D

Thanks in advance.

Sleep Mode zZ
Posts: 319
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland

Re: Wrong keyboard settings in LXDE

Fri Sep 13, 2013 8:37 am

There are many threads where the problem discussed is the wrong keyboard layout in X. It's a bug, maybe because of the keyboards driver (wireless Logitech?). Anyway, the workaround is in the following post:
http://www.raspberrypi.org/phpBB3/viewt ... 06#p192606

Replace "pt" with the code for your language.

You can test it beforehand in the terminal. Just give the command (if "it" is the right code)

Code: Select all

setxkbmap it
if it works, use the workaround.

AlexTheStampede
Posts: 4
Joined: Thu Sep 12, 2013 7:12 pm

Re: Wrong keyboard settings in LXDE

Fri Sep 13, 2013 9:48 pm

... Logitech K400r: wireless keyboard+trackpad combo HID.
Lovely. But anyway, it works! Thank you! The temp solution is fine, and I already did the workaround for both the users I got, so next reboot should be "normal".

I guess I should've searched for keyboard layout instead of keyboard setting. Oh well.

Again, thank you.

Return to “Troubleshooting”