On Boot the Pi gets stuck at the Rainbow Splash Screen

3 posts
by JTolhurst » Mon Sep 09, 2013 7:27 pm
Just in case anyone else suffers from the same problem that I have been having:
After installing the latest official wheezy raspbian image onto an SD card my latest Raspberry Pi would only allow me to run the raspi-config for the first time. After configuring this and rebooting the Pi would hang on the rainbow splash screen. If I unplugged the Raspberry Pi for 10 minutes it was possible to boot up. I tried three different SD cards and all suffered from the same issue. I didn't have this issue with my first Raspberry Pi.....
I kind of got lost in the discussions about SD cards and power supplies but the fix I found was to add the following line to the config.txt:
The raspberry Pi now boots first time every time on the three different SD cards that I tried using.
Posts: 1
Joined: Mon Sep 09, 2013 7:11 pm
by kirat » Wed Jan 01, 2014 4:07 pm
Thanks :-), that works perfectly.
What is this command for?
Posts: 3
Joined: Wed Nov 20, 2013 1:12 am
by DougieLawson » Thu Jan 02, 2014 1:23 am
kirat wrote:Thanks :-), that works perfectly.
What is this command for?

It's to allow the micro-controller in the SDCard to initialise and be ready for commands & requests from the RPi.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 27903
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK