foobarecho
Posts: 18
Joined: Tue Aug 06, 2013 4:56 am

The corruption thread

Sun Aug 18, 2013 2:02 pm

I think it might be a Raspbian and few other distros problem. the corruption issue is out of control. I understand when it happens if there is a power failure that results in a reset. but I don't understand why it happens when there is a normal shutdown/reboot. just before a while, I had corruption and this one not in my sd card, but in the hdd. (I moved root and most of the filesystem to hdd thinking it might be sd card thing) I did fsck from linux on pc and there were lots of errors.

causes I've read including voltage, which makes sense, but should this happen with normal booting cycle?

things to know , I do have issue with power adapters, please see this thread for more info: http://www.raspberrypi.org/phpBB3/viewtopic.php?t=53093

but I thought things started to work normal, when the dreaded kbd of death suddenly happened after a normal reboot.

Might be helpful info, in case someone with similar experience:
my overclock config:
arm_freq=900
core_freq=350
sdram_freq=500
no overvolt

Just before this last corruption, I installed omxplayer, yt (youtube) and xmbc (without boot and mount options)

I have emulationstation set to start instead of x.

other corruption cases, mostly related to sudden reset. except one time right after trying to play a youtube video in browser, started giving segmentation fault and sd card corrupted (before I resort to hdd solution) . this time I also tried to do the same thing (coincidence?)

User avatar
ddxfish
Posts: 75
Joined: Wed Aug 07, 2013 5:17 pm
Location: Florida
Contact: Website AOL

Re: The corruption thread

Sun Aug 18, 2013 2:14 pm

There is a high correlation between SD card corruption and overclocking.

There is also a correlation between SD card speed and corruption. Class 10 SD cards seem more prone to corruption than my class 6.
My Pi Guides: http://www.etcwiki.org/wiki/Category:Raspberry_Pi
My AIM screen name: ddxfish
Always happy to chat about the Pi!

klricks
Posts: 7123
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: The corruption thread

Sun Aug 18, 2013 2:29 pm

In my experience:
Overclocking = corruption
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

foobarecho
Posts: 18
Joined: Tue Aug 06, 2013 4:56 am

Re: The corruption thread

Sun Aug 18, 2013 4:12 pm

It seems not related with sd cards, because this is hdd and got corrupted.

it might be overclocking.

I wonder if anyone here tried to run raspberry pi for a week without overclocking? and if so if there was corruption or not.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 26406
Joined: Sat Jul 30, 2011 7:41 pm

Re: The corruption thread

Sun Aug 18, 2013 7:11 pm

Many people have been running Pi's for a year with no corruption.....even overclocked.

There is a fairly recent bug fix available in rpi-update that did fix a possible issue tht could sometimes cause corruption in very particular circumstances - have you got that?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: The corruption thread

Sun Aug 18, 2013 8:05 pm

I am running a USB HDD on a Motorola Lapdock with a Seagate GoFlex 640GB drive. The Raspi is a 512MB running at 950MHz.

No corruption problems at all.

Never have had corruption on the HDD, updates have taken out the class 2 SD card (boot) a couple of times. The battery in the Lapdock keeps power problems from being an issue.

My experience is corruption issues are due to two things. Power and updates.

Brown outs used to cause corruption until earlier this year when updates appeared to have cured them. My website is on a 256MB RasPi at 900MHz with a class 10 SanDisk Ultra 16GB card. I just had a power outage (not from the power company this time, but from a loose connector to the pin header) no corruption. Blew the breakers last week with a blow dryer. No corruption. Of course this is a web server and does not write to the drive much. Mt swap file has been moved to a 512MB USB stick.

My suggestions;
1. Bring your RasPi up to date.
2. Make sure your HDD is receiving adequate power.
3. Go to a more moderate OC setting.

Your HDD might be running fine until a real demand is being placed on it. Then the PSU might not be keeping up.

RasPii OC to 800MHz with no problem. Even 900MHz is not to bad. All of my RasPii (5) do not run 100% stable at anything over 950MHz. So try around the 900MHz (medium) overclock (which OP is already at).

Try a higher voltage PSU like the Adafruit at 5.25V make sure you have more than 4.75V at TP1/TP2. Try separate PSU's for your RasPi and your HDD, especially if you are powering both from the same USB hub and/or PSU.
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

foobarecho
Posts: 18
Joined: Tue Aug 06, 2013 4:56 am

Re: The corruption thread

Mon Aug 19, 2013 1:37 am

That's really helpful, thanks a lot for the details.

I thought I already updated the firmware, but now not sure. I just ran rpi-update and it updated my firmware, so hopefully this will solve my problems.

Return to “Troubleshooting”