Page 1 of 1

Re: Success with KB, Mouse & WiFi?

Posted: Wed Apr 25, 2012 1:44 am
by pdp7
Hi – I have a IOGear GWU625 adapter which uses r8712u driver (compiled from rpi's github).  On Debian 2012-04-19, I had been using successfully from console via wicd-curses and tested ok with all 3 wired keyboards I have.  Tested ok either connected directly or to powered hub.  TP1/TP2 steady at 5.15V.

Moving beyond the console, I finally & launched LXDE today and attached a mouse to discover my adapter stopped working and smsc95xx register read/write errors started occurring.  I've tried two different wired USB mice and different permutations of connections, via powered hub and also direct.  Regardless, wifi adapter fails when all 3 (kb, mouse, wifi) are connected.

I can provide more detail for my individual problem, but I'm curious to know of other people's experience using wifi along with keyboard and mouse at the same time.

Thanks!

Drew Fustini

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 4:48 am
by felixfurtak
Yes, many people are experiencing similar behavior. I have seen similar issue to you with combinations of wi-fi dongles, hubs and keyboards. Often manifesting as a failure to bring up eth0.

While a lot of people are putting this down to a power issue, I suspect it is a problem with USB signalling collision.

There is a patch in the kernel tree which is reported to improve this.

I guess the only thing to do is to wait until it gets rolled out into the Debian/Arch repositories, or compile a new kernel image yourself.

Felix.

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 5:13 am
by pdp7
Thanks for the feedback.  Glad to know there is possible cause other than power (my TP1/TP2 was always at least 5V).  I'm hoping to get access to a Pi again to test further next week (being shared with multiple people my office).  I think my first step will be trying out the latest github kernel.

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 7:41 am
by ait
Got the same issue on Debian 2012-04-19 with r8712u driver (compiled from rpi"s github).

Keyboard, mouse and wifi on a powered hub.

Before startx wifi pings with 2 ms to my router,

after startx (launched LXDE or jwm) ping is over 1000 ms or more.

Sometimes the wifi-adapter fails total.

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 9:17 am
by Boreatton Scouts
Same issues at first - I seem to be able to avoid problems with two powered hubs and the wifi adapter in one and keybd+mouse in the other. Errors on first attempt to boot but rebooting generlly brings up wifi after two or three attempts, and then it is fine and works in lxde or from console.

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 5:19 pm
by fulburncams
Hi

I now have working TP722n adapter by hacking a small usb stub cable which allows me to break into the +5v lead and feed direct from another source, instead of usinf the Raspi 5 v feed.  Hence no USB hub interaction.  As i am creating standalone 'headless' and hopefully wireless server with no keyboard/nouse/screen this works for me ( at least until a permanent solution appears).

Cheers

Steve

Re: Success with KB, Mouse & WiFi?

Posted: Thu May 03, 2012 5:33 pm
by jbeale
ait said:


Got the same issue on Debian 2012-04-19 with r8712u driver (compiled from rpi"s github).

Keyboard, mouse and wifi on a powered hub.


Yes, the kernel patch on April 30 from Dom Cobley marked "added support for TT in the USB driver" is relevant to a system with a USB running at USB High-Speed (WiFi) but also having low- or full-speed USB devices connected. In that situation, the Transaction Translator mechanism enables low and high-speed devices to coexist. https://github.com/raspberrypi/linux/co ... 1fa0678556

Re: Success with KB, Mouse & WiFi?

Posted: Sun May 06, 2012 9:59 pm
by spennig
I'm running the current git kernel (with that patch). The wifi performance still deteriorates to unusable when I have a USB mouse connected:

$ ping alarm
PING alarm.daria.co.uk (172.31.0.187) 56(84) bytes of data.
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=1 ttl=64 time=1001 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=2 ttl=64 time=52.5 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=3 ttl=64 time=959 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=4 ttl=64 time=47.7 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=5 ttl=64 time=999 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=6 ttl=64 time=1000 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=7 ttl=64 time=1000 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=8 ttl=64 time=942 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=9 ttl=64 time=16.6 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=10 ttl=64 time=999 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=11 ttl=64 time=1000 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=12 ttl=64 time=1000 ms
64 bytes from alarm.daria.co.uk (172.31.0.187): icmp_req=13 ttl=64 time=1000 ms (r8172u wifi device, yes staging but works OK in ia32 / x64). Using a powered hub (with plenty of power; USB HDDs work fine on the RPi). 

Re: Success with KB, Mouse & WiFi?

Posted: Mon May 07, 2012 2:29 am
by jbeale
Interesting.  Sounds a lot like the problem that the patch was supposed to fix, did not get fixed. Without a Pi or USB subsystem experience myself I can't help much, but if you have any useful logfiles with relevant error messages, etc. maybe posting them where "dom" (Dom Cobley) could see them, would assist.

Re: Success with KB, Mouse & WiFi?

Posted: Mon May 07, 2012 12:13 pm
by spennig
There's a couple of kernel logs up at:

http://seyrsnys.myzen.co.uk/rp.....wifi-0.log

http://seyrsnys.myzen.co.uk/rp.....wifi-1.log

with lots of

DEBUG:handle_hc_chhltd_intr_dma:: XactErr without NYET/NAK/ACK

amongst other problems (like the failure to load firmware for the zd1211rw device).

Re: Success with KB, Mouse & WiFi?

Posted: Sat May 26, 2012 10:23 am
by teomac
Any fresh news about this issue?

Re: Success with KB, Mouse & WiFi?

Posted: Sat May 26, 2012 10:31 am
by spennig
With the latest kernel (built from git), wifi, mouse and keyboard work just fine, with a powered USB hub. Both the Pi and the hub are powered from a 2.1A Cliptec USB charger. Using a cheap "no-name" WiFi adapter with r8172u kernel driver.

Re: Success with KB, Mouse & WiFi?

Posted: Sat May 26, 2012 11:43 am
by teomac
spennig wrote:With the latest kernel (built from git), wifi, mouse and keyboard work just fine, with a powered USB hub. Both the Pi and the hub are powered from a 2.1A Cliptec USB charger. Using a cheap "no-name" WiFi adapter with r8172u kernel driver.
Thank You so much... so I have to buy a good charger like cliptec quad, which hub I have to buy? I was looking for a D-Link DUB-H7.

Re: Success with KB, Mouse & WiFi?

Posted: Sat May 26, 2012 12:01 pm
by spennig
teomac wrote:
spennig wrote:With the latest kernel (built from git), wifi, mouse and keyboard work just fine, with a powered USB hub. Both the Pi and the hub are powered from a 2.1A Cliptec USB charger. Using a cheap "no-name" WiFi adapter with r8172u kernel driver.
Thank You so much... so I have to buy a good charger like cliptec quad, which hub I have to buy? I was looking for a D-Link DUB-H7.
I found things worked much better with a quality 2.1A charger (like the Cliptec quad). As for the hub, I have no recommendation, I'm using a very cheap, very small 'no name' hub I bought in SE Asia during a business trip to Brunei.

Re: Success with KB, Mouse & WiFi?

Posted: Sat Jun 02, 2012 8:16 am
by teomac
spennig wrote:With the latest kernel (built from git)...
Just another question :) which kernel version do you mean? can you provide git link?

Thank you so much :)