alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Fri Aug 08, 2014 6:22 pm

Here is mt7601u driver for the kernel 3.12.26+ #702
How to install:

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.26_702.tar.gz
sudo tar xf mt7601_3.12.26_702.tar.gz -C /
sudo depmod -a
sudo reboot
Note: the binary itself is the same as of version 3.12.25+ #701, the only difference is the module path.
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

radiono
Posts: 2
Joined: Thu Aug 07, 2014 11:47 am

Re: Dynamode USB Wifi Dongle issues

Sat Aug 09, 2014 7:09 pm

Thanks for the updated modules. Seems raspbmc has a patched kernel (extra modules) compared to raspbian and my TVHeadend has trouble with the latest kernel.

zasf
Posts: 1
Joined: Sun Aug 10, 2014 8:22 am

Re: Dynamode USB Wifi Dongle issues

Sun Aug 10, 2014 8:45 am

Here is 3.0.0.4 mt7601u module compiled for 3.12.22+. It is working fine on my raspberry pi (256mb ram) but only with external usb power. The chip comes with TP-LINK TL-WN727N

https://dl.dropboxusercontent.com/u/964 ... .22%2B.zip

Code: Select all

$ uname -a
Linux octopi 3.12.22+ #691 PREEMPT Wed Jun 18 18:29:58 BST 2014 armv6l GNU/Linux
I followed the steps by llad in this post of the thread except for the Module.symvers file

You have to be very careful at downloading exactly the version you need, otherwise the module will compile but not work. In order to get the one you need go on github

https://github.com/raspberrypi/firmware ... le.symvers

click "history" and download the one that matches your kernel version (in my case 3.12.22)

Enjoy

alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Wed Sep 10, 2014 9:52 pm

Here comes the driver for kernel 3.12.28+ #710
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.28_710.tar.gz
sudo tar xf mt7601_3.12.28_710.tar.gz -C /
sudo depmod 3.12.28+
sudo reboot
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

albag57
Posts: 10
Joined: Wed Jan 22, 2014 9:01 pm

Re: Dynamode USB Wifi Dongle issues

Wed Sep 24, 2014 5:27 am

Hi to all.
I installed the MT7601Usta driver on 3.12.22+ and it works fine but when I use OPENELEC no chances to have my wifi dongle running: I can't configure my network. May it depend because MT7601 uses ra0 instead of wlan0?
Any idea for solving that issue? thanks in advance.
Alberto

fruitoftheloom
Posts: 23395
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Dynamode USB Wifi Dongle issues

Wed Sep 24, 2014 6:02 am

albag57 wrote:Hi to all.
I installed the MT7601Usta driver on 3.12.22+ and it works fine but when I use OPENELEC no chances to have my wifi dongle running: I can't configure my network. May it depend because MT7601 uses ra0 instead of wlan0?
Any idea for solving that issue? thanks in advance.
Alberto
How did you install the driver in OpenElec ? The driver in this thread is aimed at Raspbian Wheezy ;)

http://openelec.tv/forum/124-raspberry- ... -raspberry
Rather than negativity think outside the box !
RPi 4B 4GB (SSD Boot)..
Asus ChromeBox 3 Celeron is my other computer...

albag57
Posts: 10
Joined: Wed Jan 22, 2014 9:01 pm

Re: Dynamode USB Wifi Dongle issues

Sat Sep 27, 2014 3:12 pm

Thanks Fruitoftheloom,
no I installed the driver on Debian and I thought it should have been fine for OPENELEC too. Honestly I have not idea about the way for installing it in OPENELEC: it seems the system is closed, no chance in using terminal for giving commands.
Do you know some solution?
Ciao.
Alberto

fruitoftheloom
Posts: 23395
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Dynamode USB Wifi Dongle issues

Sat Sep 27, 2014 3:22 pm

albag57 wrote:Thanks Fruitoftheloom,
no I installed the driver on Debian and I thought it should have been fine for OPENELEC too. Honestly I have not idea about the way for installing it in OPENELEC: it seems the system is closed, no chance in using terminal for giving commands.
Do you know some solution?
Ciao.
Alberto
The Linux Kernel has support for the Ralink RT5370 and Realtek RTL8188CU / CUS chipset and the later I use as it works in all Linux Distro's including OpenElec without additional drivers:

http://www.ebay.co.uk/itm/WIFI-USB-RTL8 ... 1251934135
Rather than negativity think outside the box !
RPi 4B 4GB (SSD Boot)..
Asus ChromeBox 3 Celeron is my other computer...

albag57
Posts: 10
Joined: Wed Jan 22, 2014 9:01 pm

Re: Dynamode USB Wifi Dongle issues

Sun Sep 28, 2014 1:53 pm

I follow your suggestion. Thanks
Alberto

qwertyAT
Posts: 5
Joined: Mon Sep 29, 2014 8:02 am

Re: Dynamode USB Wifi Dongle issues

Wed Oct 01, 2014 2:39 pm

I retried do compile my WLAN driver for about 7 times.
Different instructions - same result.

Kernel Panic after restart...

And now I figured out what the problem was.
I guess all these instructions are fine and will work.

I needed a powered USB hub...
And now everything is working fine.

Wckoek
Posts: 10
Joined: Fri Aug 15, 2014 4:30 am

Re: Dynamode USB Wifi Dongle issues

Sun Oct 05, 2014 4:36 pm

alfonder wrote:Here comes the driver for kernel 3.12.28+ #710
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.28_710.tar.gz
sudo tar xf mt7601_3.12.28_710.tar.gz -C /
sudo depmod 3.12.28+
sudo reboot
Hi, I have followed this instruction for the September update of raspbian, but I still can't get wifi config to detect the dongle after reboot.

Fermars
Posts: 21
Joined: Wed Sep 17, 2014 2:35 pm
Location: Madrid, Spain

Re: Dynamode USB Wifi Dongle issues

Tue Oct 07, 2014 1:05 pm

Wckoek wrote: Hi, I have followed this instruction for the September update of raspbian, but I still can't get wifi config to detect the dongle after reboot.
You should modify /etc/network/interfaces and /etc/wpa-supplicant/wpa-supplicant.conf to get it work.

First, type ifconfig. You should see a new entry "ra0", if so, then modify that files as following (these are my config files configured as static IP address. You can change by your own):

/etc/network/interfaces:

auto lo

iface lo inet loopback
iface eth0 inet static
address 192.168.1.33
netmask 255.255.255.0
gateway 192.168.1.1

allow-hotplug wlan0

iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet static
address 192.168.1.31
netmask 255.255.255.0
gateway 192.168.1.1

allow-hotplug ra0

iface ra0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface ra0 inet static
address 192.168.1.31
netmask 255.255.255.0
gateway 192.168.1.1

/etc/wpa-supplicant/wpa-supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid=”SSID_WIFI_NETWORK”
psk=”PASSWORD”
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
}

You have to use your own SSID and Password.

Hope it helps.

charlesanjos
Posts: 11
Joined: Tue Jul 03, 2012 4:14 am

Re: Dynamode USB Wifi Dongle issues

Wed Oct 15, 2014 6:25 pm

hello guys! firstly, i want to thank alfonder for the awesome contribution on the compiled driver. i wasn't being able to compile it for my raspi (probably i was being dumb in some crucial point along the process), thanks for compiling it.

now, for my problem: i'm trying to use a mt7601 dongle in AP mode. is it possible? i tried the iw list command to assert AP capabilities, but it just gives me a "nl80211 not found" error. i went to research about it and discovered that it might be a driver issue. can anyone help me with this?

brabl2
Posts: 2
Joined: Wed Oct 15, 2014 6:47 pm

Re: Dynamode USB Wifi Dongle issues

Wed Oct 15, 2014 7:04 pm

alfonder wrote:Here comes the driver for kernel 3.12.28+ #710
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.28_710.tar.gz
sudo tar xf mt7601_3.12.28_710.tar.gz -C /
sudo depmod 3.12.28+
sudo reboot
This works also with kernel 3.12.28+ #709
together with adding ra0 configuration to /etc/network/interfaces
Thanks !

alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Wed Oct 15, 2014 7:57 pm

charlesanjos wrote:i'm trying to use a mt7601 dongle in AP mode. is it possible?
With this driver it is impossible. Ralink's STA-mode software package is freely distributed under the GPL license. But AP-mode package is closed-source commercial product under a certain license. So you don't get AP-enabled driver source unless you're Ralink's partner.
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

wenxuan
Posts: 3
Joined: Thu Sep 11, 2014 4:32 pm

Re: Dynamode USB Wifi Dongle issues

Thu Nov 13, 2014 5:03 am

Do you have a driver for 3.12.31+ by any chance?

5Forward
Posts: 2
Joined: Thu Nov 13, 2014 5:24 pm

Re: Dynamode USB Wifi Dongle issues

Thu Nov 13, 2014 5:29 pm

do we have any chance to find driver for kernel 3.12.32+ ?

alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Thu Nov 13, 2014 9:32 pm

Here is the driver for kernel 3.12.32+ #721
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.32_721.tar.gz
sudo tar xf mt7601_3.12.32_721.tar.gz -C /
sudo depmod 3.12.32+
sudo reboot
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

5Forward
Posts: 2
Joined: Thu Nov 13, 2014 5:24 pm

Re: Dynamode USB Wifi Dongle issues

Thu Nov 13, 2014 11:54 pm

alfonder wrote:Here is the driver for kernel 3.12.32+ #721
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.32_721.tar.gz
sudo tar xf mt7601_3.12.32_721.tar.gz -C /
sudo depmod 3.12.32+
sudo reboot
i've been looking for this since i updated my pi to 3.12.32+, thanks.
do you have any source of updated drivers ?

alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Fri Nov 14, 2014 11:57 am

5Forward wrote: do you have any source of updated drivers ?
The source is the same as for previous kernels. I just built it against the current kernel version.
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

Vitold
Posts: 4
Joined: Fri Oct 10, 2014 3:52 pm
Location: Russia

Re: Dynamode USB Wifi Dongle issues

Sun Nov 16, 2014 9:34 am

Hi all!
I have trouble with driver instalation for 148f:7601 after installing Adafruit 2.8" tft touchscreen display.

uname -a
Linux RPi 3.12.26+ #7 PREEMPT Wed Sep 17 14:25:24 EDT 2014 armv6l GNU/Linux
I`ve tried 3.12.26+ #702 drivers, but it dont work.

Has anyone else encountered this problem? Please tell me what to do.

MrEngman
Posts: 4032
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Dynamode USB Wifi Dongle issues

Sun Nov 16, 2014 5:01 pm

Vitold wrote:Hi all!
I have trouble with driver instalation for 148f:7601 after installing Adafruit 2.8" tft touchscreen display.

uname -a
Linux RPi 3.12.26+ #7 PREEMPT Wed Sep 17 14:25:24 EDT 2014 armv6l GNU/Linux
I`ve tried 3.12.26+ #702 drivers, but it dont work.

Has anyone else encountered this problem? Please tell me what to do.
I have a driver for 148f:7601 that is working on my PI with "3.12.26+ #7 PREEMPT Wed Sep 17 14:25:24 EDT 2014 "

You should be able to download and install it with the following commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/MT7601U-Adafruit-3.12.26-7.tar.gz
tar -xzvf MT7601U-Adafruit-3.12.26-7.tar.gz
sudo install -p -m 644 mtutil7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo mkdir -p /etc/Wireless/RT2870STA
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/.
sudo install -p -m 644 mt7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo install -p -m 644 mtnet7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo depmod 3.12.26+


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Vitold
Posts: 4
Joined: Fri Oct 10, 2014 3:52 pm
Location: Russia

Re: Dynamode USB Wifi Dongle issues

Sun Nov 16, 2014 6:11 pm

MrEngman wrote:You should be able to download and install it with the following commands...
Thank you, it works :)

alfonder
Posts: 35
Joined: Sun Jul 06, 2014 9:19 pm

Re: Dynamode USB Wifi Dongle issues

Mon Nov 24, 2014 12:35 pm

Here is the driver for kernel 3.12.33+ #722
How to install (better copy-paste to avoid typos):

Code: Select all

cd /tmp
wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.33_722.tar.gz
sudo tar xf mt7601_3.12.33_722.tar.gz -C /
sudo depmod 3.12.33+
sudo reboot
To support me, register Dropbox account via invitation https://db.tt/xrV5BqTf

User avatar
ilovemipi
Posts: 152
Joined: Mon Dec 02, 2013 11:52 am
Location: UK + Cyprus
Contact: Website

Re: Dynamode USB Wifi Dongle issues

Wed Dec 03, 2014 11:48 am

MrEngman wrote:
Vitold wrote:Hi all!
I have trouble with driver instalation for 148f:7601 after installing Adafruit 2.8" tft touchscreen display.

uname -a
Linux RPi 3.12.26+ #7 PREEMPT Wed Sep 17 14:25:24 EDT 2014 armv6l GNU/Linux
I`ve tried 3.12.26+ #702 drivers, but it dont work.

Has anyone else encountered this problem? Please tell me what to do.
I have a driver for 148f:7601 that is working on my PI with "3.12.26+ #7 PREEMPT Wed Sep 17 14:25:24 EDT 2014 "

You should be able to download and install it with the following commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/MT7601U-Adafruit-3.12.26-7.tar.gz
tar -xzvf MT7601U-Adafruit-3.12.26-7.tar.gz
sudo install -p -m 644 mtutil7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo mkdir -p /etc/Wireless/RT2870STA
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/.
sudo install -p -m 644 mt7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo install -p -m 644 mtnet7601Usta.ko /lib/modules/3.12.26+/kernel/drivers/net/wireless/
sudo depmod 3.12.26+


MrEngman
Mr Engman

Do you happen to have a driver for 148f:7601 on Raspbmc 3.12.31 #2 or is there another thread covering this?

Return to “Troubleshooting”