rhinos93
Posts: 3
Joined: Wed Jul 03, 2013 2:19 pm

Postfix send mail error

Wed Jul 03, 2013 2:32 pm

Hello World,
i've a pi running at home. I want to send mails via postfix. I've installed postfix, edited the main.cf (i've changed myhostname to meinetld.info) and sudo reboot.
I tried to send a mail:

Code: Select all

[email protected] ~ $ mail -s "Testmail" [email protected]
Random Numbers: 7463985248952EOT
[email protected] ~ $ send-mail: warning: inet_protocols: disabling IPv6 name/addre                                                                                                 ss support: Address family not supported by protocol
postdrop: warning: inet_protocols: disabling IPv6 name/address support: Address                                                                                                  family not supported by protocol

You have new mail in /var/mail/pi
I read that the protocol thing doesn't matter.

/var/mail/pi contains:

Code: Select all

From MAILER-DAEMON  Wed Jul  3 14:11:09 2013
Return-Path: <>
X-Original-To: [email protected]
Delivered-To: [email protected]
Received: by meinetld.info (Postfix)
        id 2943E24E6F; Wed,  3 Jul 2013 14:11:09 +0000 (UTC)
Date: Wed,  3 Jul 2013 14:11:09 +0000 (UTC)
From: [email protected] (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: [email protected]
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
        boundary="D289124E1A.1372860669/meinetld.info"
Message-Id: <[email protected]>

This is a MIME-encapsulated message.

--D289124E1A.1372860669/meinetld.info
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

This is the mail system at host meinetld.info.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<[email protected]>: host mx1.hotmail.com[65.55.37.104] said: 550
    DY-001 (COL0-MC3-F24) Unfortunately, messages from 109.192.183.16 weren't
    sent. Please contact your Internet service provider. You can tell them that
    Hotmail does not relay dynamically-assigned IP ranges. You can also refer
    your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. (in
    reply to MAIL FROM command)

--D289124E1A.1372860669/meinetld.info
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; meinetld.info
X-Postfix-Queue-ID: D289124E1A

X-Postfix-Sender: rfc822; [email protected]
Arrival-Date: Wed,  3 Jul 2013 14:10:47 +0000 (UTC)

Final-Recipient: rfc822; [email protected]
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx1.hotmail.com
Diagnostic-Code: smtp; 550 DY-001 (COL0-MC3-F24) Unfortunately, messages from
    109.192.183.16 weren't sent. Please contact your Internet service provider.
    You can tell them that Hotmail does not relay dynamically-assigned IP
    ranges. You can also refer your provider to
    http://mail.live.com/mail/troubleshooting.aspx#errors.

--D289124E1A.1372860669/meinetld.info
Content-Description: Undelivered Message
Content-Type: message/rfc822

Return-Path: <[email protected]>
Received: by meinetld.info (Postfix, from userid 1000)
        id D289124E1A; Wed,  3 Jul 2013 14:10:47 +0000 (UTC)
Date: Wed, 03 Jul 2013 14:10:47 +0000
To: [email protected]
Subject: Testmail
User-Agent: Heirloom mailx 12.5 6/20/10

MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Message-Id: <[email protected]>
From: [email protected]

Random Numbers: 7463985248952

--D289124E1A.1372860669/meinetld.info--
I use two domains for the pi, but i think that doesn't matter.

Can you please tell me whats wrong with my confi or why doesn't he send emails?
Thanks for your help,
Jonas

SirLagz
Posts: 1705
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
Contact: Website

Re: Postfix send mail error

Wed Jul 03, 2013 3:19 pm

This is wrong

Code: Select all

Unfortunately, messages from 109.192.183.16 weren't
    sent. Please contact your Internet service provider. You can tell them that
    Hotmail does not relay dynamically-assigned IP ranges.
Your out of luck sending to your outlook mail acount
Maybe try creating a gmail and sending there instead.
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044

rhinos93
Posts: 3
Joined: Wed Jul 03, 2013 2:19 pm

Re: Postfix send mail error

Thu Jul 04, 2013 10:35 am

Sendings mails to gmail.com, i don't get an error message but the mail doesn't arrive at my gmail inbox.

geekinthesticks
Posts: 97
Joined: Fri Feb 08, 2013 7:22 pm

Re: Postfix send mail error

Thu Jul 04, 2013 10:50 am

Most isp's won't let you use their smtp server to relay mail, for obvious anti spam reasons. There is a good tutorial on how to set up Postfix to use Google's mail servers http://blog.bigdinosaur.org/postfix-gmail-and-you/ However, I think that this probably only works if you are using Google Apps for Domains.

SirLagz
Posts: 1705
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
Contact: Website

Re: Postfix send mail error

Fri Jul 05, 2013 11:37 am

rhinos93 wrote:Sendings mails to gmail.com, i don't get an error message but the mail doesn't arrive at my gmail inbox.
It can take a while sometimes.
Are you getting any errors in the postfix logs ?
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044

rhinos93
Posts: 3
Joined: Wed Jul 03, 2013 2:19 pm

Re: Postfix send mail error

Wed Jul 10, 2013 10:07 pm

:arrow: I've solved my problems:
- Installed postfix
- i use jangosmtp.com as relayhost(redirect emails) [500 Mails/Month = free]
maybe this will help someone..

dylantje
Posts: 88
Joined: Sun Mar 03, 2013 9:51 pm

Re: Postfix send mail error

Mon Aug 12, 2013 5:13 pm

Hello,

Sorry, for the off topic

Is there anyone who has a web interface for Postfix.
http://www.postfix.org/addon.html

There are several, but I can not get working.

I hope someone can help me. Further

Thank you.

Dylan

Return to “Troubleshooting”