Posts: 2
Joined: Sun Jun 30, 2013 3:12 pm

Pi won't boot after modifying config.txt

Sun Jun 30, 2013 3:29 pm

Hello all,
After modifying my (Raspbian Wheezy) config.txt file to change (uncomment) the overscan settings, my Pi won't boot. If I comment the settings out again, it boots fine. I noticed this behavior also happens if I use hdmi_safe=1.
when I give the Pi power under these conditions, the LEDs flash, indicating some reading for a few seconds, then it stops. It does not send any signal to my monitor during this process. When I re-dd my SD card, or change the config.txt file back to its original state, the Pi boots properly.
My main goal here is to adjust the overscan settings and force an alternate resolution (my 800x600-pixel HDMI monitor thinks it is actually 1184x624 and won't let me select any other setting).
While I'm at it, I tried installing Kali Linux for Raspberry Pi -- I encounter the same issues, but Kali Linux has no config.txt file. And when I add one, it doesn't boot. How would you modify display settings for Kali Linux on the Pi?

User avatar
Posts: 2027
Joined: Tue Jan 01, 2013 9:33 pm
Location: East Midlands, UK

Re: Pi won't boot after modifying config.txt

Sun Jun 30, 2013 4:45 pm

See the instructions for modifying config.txt linked from http://elinux.org/R-Pi_ConfigurationFile

From recollection it is possible to break/corrupt the file by using a Windows editor that uses CRLF instead of NewLine as the line-terminator. That would seem to match the symptoms you describe.
How To Ask Questions The Smart Way: http://www.catb.org/~esr/faqs/smart-questions.html
How to Report Bugs Effectively: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

Posts: 2
Joined: Sun Jun 30, 2013 3:12 pm

Re: Pi won't boot after modifying config.txt

Sun Jun 30, 2013 9:09 pm

Thank you for your feedback. While this seems like the most likely cause, I used Notepad++ to double-check that only Unix newlines were being used. Instead of adding newlines, all I'm doing is deleting the "#" that comments out the line regarding overscan. Sure enough, if I put that "#" back, the Pi boots up without a hitch. Is there something I can try to work around this?

Edit: This also happens when I modify my config.txt file using nano or gedit.
Edit: I tried nano again, this time in superuser mode, and it worked. Not sure why the Notepad++ Unix method didn't, but c'est la vie.

Posts: 2
Joined: Tue Jul 02, 2013 10:24 pm

Re: Pi won't boot after modifying config.txt

Tue Jul 02, 2013 10:52 pm

Hi, I'm having a similar issue after modifying the config.txt file

I only recieved my 512 MB Pi today so please forgive me if I seem a bit clueless...

I installed the latest version of Raspbian Wheezy (25th May 2013) and managed to get that working fine, no problems at all. I then decided that I wanted to flip the screen around so I edited the config.txt file using nano (sudo nano /boot/config.txt) by adding the following line and saving it:

Code: Select all

I then rebooted the Pi using the appropriate command (sudo shutdown -r now). However the Pi does not appear to reboot properly, there is nothing displayed on the screen at allthough the screen will awaken from sleep mode.

I then ejected the SD card and edited the config.txt file in Notepad on my Windows laptop to comment out the line I had added (using #). When I then inserted the SD card to the Pi and started it up it was ok again (though with the screen in the normal position due to the rotation code being commented out).

I have since tried editing the config.txt file in the following ways, always with the same result as above:
- using nano in Super User mode as suggested above (typed su in main Pi terminal, edited the config.txt file in nano as above then typed exit to exit su mode)
- using notepad on my laptop
- using LXTerminal on the Raspbian desktop and using nano from there

Again with all of these commenting out the line always fixes the problem and the Pi then boots as normal.

I have spent quite a long time tryingto rotate the screen with no progress at all, and I need to rotate the screen for the project I have planned.

In summary
- brand new Pi (512 MB)
- Installed latest Raspbian Wheezy (25th May 2013)
- Tried to rotate screen only (nothing else changed or installed, etc...)
- Won't reboot after editing config.txt file by adding one single line (display_rotate=2)

Please let me know if anyone else is having a similar problem. Any advice or guidance greatly appreciated, again apologies if I'm missing something fundamental here but I've only had the Pi for less than a day!

Many thanks,


Edit: I should probably have mentioned that I'm using a HDMI to VGA adapter. This works fine without editing the config file. I have also tried the same method above without the VGA adapter and running the HDMI cabble straight to a HDTV, works fine with the code commented out but then doesn't when I uncomment it.

Posts: 2
Joined: Tue Jul 02, 2013 10:24 pm

Re: Pi won't boot after modifying config.txt

Wed Jul 03, 2013 9:23 pm

Quick update:
Tried adding display_rotate=0 (default rotation), the Pi booted as normal and display was fine. I decided to leave this line in because it worked ok.

Tried adding hdmi_safe=1 to config file, nothing displayed on the screen. Commented it out.

Tried adding hdmi_force_hotplug=1, this worked ok so left it in.

Tried adding hdmi_ignore_edid=0xa5000080, again this worked so left it in.

At this point I tried changing the rotate value to 2, still no joy.

I'm running out of ideas, anyone have any recommendations?

Posts: 6
Joined: Thu Mar 21, 2013 8:56 pm

Re: Pi won't boot after modifying config.txt

Thu Nov 07, 2013 4:30 pm

Per getting config.txt to work in Kali, follow the instructions here: http://rageweb.info/2013/11/07/bootconfig-txt-in-kali/
At least, it worked for me

Return to “Troubleshooting”