ruffinmedia
Posts: 32
Joined: Sat May 11, 2013 11:43 am

Backup and Restore process

Sat Jun 08, 2013 11:30 pm

I'm trying to make a backup of my perfect image using win32 and every time i boot with the restored image, i get the following error.
PANIC: No init found. Try passing init= option to kernel.
Entering kbd (current=0xda82ac80, pid 1) due to keyboard entry.

The original image\card boots the pi with no issues. Is there an easy way to make a complete duplicate image of my SD Card? Even if it costs to make sure that its easy and works 100% of the time, I would be interested. The problem is that the process of backing up and restoring takes forever, only to find out that it was unsuccessful.

Can anyone please help as I'm working on a project that was due awhile ago and i cant seem to figure out what the issue is.
:?: :?: :?: :?:

pichicken
Posts: 20
Joined: Fri Feb 22, 2013 3:38 pm

Re: Backup and Restore process

Sun Jun 09, 2013 7:32 am

If you could grab a Linux machine I'd just suggest you to use "dd" to create a raw backup image. I've used this approach several times as my RPi is subject to frequent SD corruption and has always worked.

But if you really need to stick with Windows could you tell which tool you are using to create and restore the backup?
The knowledge gained from a failure is more valuable than an immediate success.

ruffinmedia
Posts: 32
Joined: Sat May 11, 2013 11:43 am

Re: Backup and Restore process

Sun Jun 09, 2013 8:28 am

I was able to make a perfect copy with USBIT. It works perfect.

Now my only problem is since im trying to setup several Hamachi servers, the image I made has the Hamachi settings already in the image. When i boot both identical Raspi's up, only one is visible at a time on Hamachi. Ive tried changing its nick name, reinstalling Hamachi over itself to no avail. Does anyone know how to uninstall Hamachi so I can add everything all over again?

ghans
Posts: 7883
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Backup and Restore process

Sun Jun 09, 2013 9:28 am

Does

Code: Select all

sudo apt-get purge hamachi
work ?

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

Return to “Troubleshooting”