hybnus
Posts: 1
Joined: Mon Feb 09, 2015 7:48 pm

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 10:47 am

Bosse_B wrote:
manawyrm wrote: Has anyone else had problems with intermittent wifi on the Pi3?
Probably not that many users here have had time to since the Pi3 release announcement was made just 2 days ago.
I also have seen that the foundation is working to bring the support for all hardware up-to-date.
So you might have to wait...
Hi Bosse_B

I have issues with the integrated wifi on the RPI3 aswell.
I can scan the devices with "iwlist wlan0 scan" and it is showing all the wifis in my area. But I cannot connect to any of these networks. It is not connecting to any AP. When I use a WIFI USB dongle it is working instantaneously.
An raspi-config update is not available yet.

Joshimuz
Posts: 2
Joined: Wed Mar 02, 2016 12:27 pm

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 12:31 pm

I've have similar issues with the Pi3 wifi as manawyrm.

But I also have a problem whereby if the wireless connection is not being used for ~1 minute, it drops completely and I can no longer connect/ping the Pi at all, yet it still shows on my router's connection list.

I found that opening a SSH connection and using the top command is a good way to keep it connected, but obviously this isn't an ideal solution. There might be a better way but I'm not very familiar with Linux.

Bosse_B
Posts: 655
Joined: Thu Jan 30, 2014 9:53 am

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 1:20 pm

I don't have a Pi3 myself (yet) but I have seen mention of the WiFi going to sleep inadvertently with similar effects as you describe.
Mabye the solution shown in this thread might help you too?
I have applied it to my system and it does not lose connection (but it is an RPi2 with a WiFi dongle of course).
Bo Berglund
Sweden

N_A_B
Posts: 6
Joined: Sun Oct 21, 2012 7:18 am

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 2:21 pm

Having exactly the same problem with the RPi3 here. 76% packet loss on wlan0. This appears to be a completely different problem to the power-saving issue others have mentioned (and see http://makezine.com/2016/02/28/meet-the ... erry-pi-3/) and occurs with a monitor and also in headless mode.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4247
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 2:25 pm

I haven't managed to get any WiFi connecting yet, because I stubornly refuse to change the channel my router is working on. (Well OK, I did once for a minute or two to prove the issue.)

Has anyone else managed to get the Pi3 operational on channels 12 or 13?

Also do you see an entry in /var/log/syslog "brcmf_add_if: ERROR: netdev:wlan0 already exists" ?

Joshimuz
Posts: 2
Joined: Wed Mar 02, 2016 12:27 pm

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 5:05 pm

Thanks for that link N_A_B, my issue does seem to be the same as Make's (I'm also using headless), if I connect the pi to the network via Ethernet AND WiFi, the WiFi doesn't seem to disconnect and doesn't seem to lag as much (at least from my limited testing using the wireless IP address, for all I know it's just routing me through the Ethernet). Though that does seem a little bit pointless. I'll keep an eye out for the power saving disable patch

alexsh1
Posts: 20
Joined: Fri Mar 06, 2015 11:24 am

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 7:35 pm

Bosse_B wrote:
manawyrm wrote: Has anyone else had problems with intermittent wifi on the Pi3?
Probably not that many users here have had time to since the Pi3 release announcement was made just 2 days ago.
I also have seen that the foundation is working to bring the support for all hardware up-to-date.
So you might have to wait...
That's exactly right.
I am having the same issue with wifi - Foundation have been looking into this issue.

geko
Posts: 1
Joined: Wed Mar 02, 2016 7:26 pm

Re: WiFi Issues ? Start here !

Wed Mar 02, 2016 7:41 pm

rurwin wrote:I haven't managed to get any WiFi connecting yet, because I stubornly refuse to change the channel my router is working on. (Well OK, I did once for a minute or two to prove the issue.)

Has anyone else managed to get the Pi3 operational on channels 12 or 13?

Also do you see an entry in /var/log/syslog "brcmf_add_if: ERROR: netdev:wlan0 already exists" ?
Hi,

I have the same issue with the RPi3 on-board WiFi not appearing to support channels 12 or 13.
I've connected a USB WiFi adapter at the same time and that is still working on channels 12 and 13.

I have two AP's in the house using channels 1 and 13, the on-board WiFi only finds channel 1, the USB WiFi adapter sees both.

I also see those same entries in /var/log/syslog, but they also appear for both the wlan0 and wlan1 devices when I have the USB adapter connected and both WiFi devices work okay over the channels they do connect to.

dankcushions
Posts: 20
Joined: Sat Jun 13, 2015 10:40 am

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 12:16 pm

another intermittent wifi report on the pi3, here:

Code: Select all

PING 192.168.0.11 (192.168.0.11): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10
Request timeout for icmp_seq 11
Request timeout for icmp_seq 12
Request timeout for icmp_seq 13
64 bytes from 192.168.0.11: icmp_seq=14 ttl=64 time=115.782 ms
64 bytes from 192.168.0.11: icmp_seq=15 ttl=64 time=36.375 ms
64 bytes from 192.168.0.11: icmp_seq=16 ttl=64 time=55.641 ms
64 bytes from 192.168.0.11: icmp_seq=17 ttl=64 time=75.728 ms
64 bytes from 192.168.0.11: icmp_seq=18 ttl=64 time=97.629 ms
64 bytes from 192.168.0.11: icmp_seq=19 ttl=64 time=3.590 ms
64 bytes from 192.168.0.11: icmp_seq=20 ttl=64 time=37.376 ms
64 bytes from 192.168.0.11: icmp_seq=21 ttl=64 time=61.206 ms
64 bytes from 192.168.0.11: icmp_seq=22 ttl=64 time=82.287 ms
64 bytes from 192.168.0.11: icmp_seq=23 ttl=64 time=101.490 ms
64 bytes from 192.168.0.11: icmp_seq=24 ttl=64 time=24.663 ms
64 bytes from 192.168.0.11: icmp_seq=25 ttl=64 time=41.908 ms
64 bytes from 192.168.0.11: icmp_seq=26 ttl=64 time=62.585 ms
64 bytes from 192.168.0.11: icmp_seq=27 ttl=64 time=85.789 ms
64 bytes from 192.168.0.11: icmp_seq=28 ttl=64 time=109.554 ms
64 bytes from 192.168.0.11: icmp_seq=29 ttl=64 time=30.032 ms
^C
--- 192.168.0.11 ping statistics ---
30 packets transmitted, 16 packets received, 46.7% packet loss
round-trip min/avg/max/stddev = 3.590/63.852/115.782/32.239 ms
if the foundation are looking into this there an issue logged on git for this i can follow?

N_A_B
Posts: 6
Joined: Sun Oct 21, 2012 7:18 am

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 2:20 pm

geko wrote:I have the same issue with the RPi3 on-board WiFi not appearing to support channels 12 or 13.
Have you changed the regulatory domain to one which supports it? For example, I'm in the UK...

Code: Select all

sudo iw reg set GB
or, to make the change permanent, add

Code: Select all

country=GB
to /etc/wpa_supplicant/wpa_supplicant.conf. This works for me.
Although I would ask, "Why on earth would you want to use 12/13?"

goobering
Posts: 5
Joined: Tue Mar 18, 2014 3:07 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 2:28 pm

Solution for missing channels posted here: http://raspberrypi.stackexchange.com/qu ... 3490#43490

To get channels 12 and 13 to appear using iwlist:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

sudo rpi-update

[reboot]

sudo branch=next rpi-update

[reboot]

curtsoderberg
Posts: 1
Joined: Sat Oct 24, 2015 1:29 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 2:54 pm

sudo BRANCH=next rpi-update

theHetman
Posts: 88
Joined: Tue Jan 10, 2012 5:42 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 3:51 pm

Thanks to everyone that mentioned that connecting to channels 12 and 13 could cause issues. It's been a long term problem for me that certain WiFi dongles wouldn't show my access point in the list. This included the official Foundation dongle. Up until now I've just shrugged and used one that did work, but when my new Pi 3 couldn't detect my router, I needed a fix. I've just moved my AP from channel 12 and now the Pi 3 works as does the official dongle. So thanks again.

It looks like the Pi config tool needs to better handle the valid WiFi channels based on country.

User avatar
InsecureSpike
Posts: 23
Joined: Thu Feb 07, 2013 5:37 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 6:33 pm

i'm having problems trying getting a stable wifi connection with a static address, while running RetroPie.
i've changed my router to channel 6, (it was on auto), done all the updates & upgrades fellow members have posted, but it lasts between 30 seconds to 2 minutes,

should i forget about trying to have a static one for now?

does anyone have any suggestions?

thanks

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4247
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 7:14 pm

N_A_B wrote:Although I would ask, "Why on earth would you want to use 12/13?"
Image

Zagum
Posts: 2
Joined: Wed Aug 20, 2014 3:17 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 8:36 pm

My issues with the RPi3 are now resolved. For me it wasn't channel related as I was already using channel 1, but doing the command

sudo BRANCH=next rpi-update

followed by a reboot made the internal wlan0 actually start working. Pings to it were still very poor but no packet loss,

$ ping -c 10 192.168.1.79
PING 192.168.1.79 (192.168.1.79): 56 data bytes
64 bytes from 192.168.1.79: icmp_seq=0 ttl=64 time=61.088 ms
64 bytes from 192.168.1.79: icmp_seq=1 ttl=64 time=604.186 ms
64 bytes from 192.168.1.79: icmp_seq=2 ttl=64 time=204.834 ms
64 bytes from 192.168.1.79: icmp_seq=3 ttl=64 time=125.742 ms
64 bytes from 192.168.1.79: icmp_seq=4 ttl=64 time=47.396 ms
64 bytes from 192.168.1.79: icmp_seq=5 ttl=64 time=62.581 ms
64 bytes from 192.168.1.79: icmp_seq=6 ttl=64 time=195.311 ms
64 bytes from 192.168.1.79: icmp_seq=7 ttl=64 time=114.414 ms
64 bytes from 192.168.1.79: icmp_seq=8 ttl=64 time=31.542 ms
64 bytes from 192.168.1.79: icmp_seq=9 ttl=64 time=363.219 ms

--- 192.168.1.79 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 31.542/181.031/604.186/170.041 ms


So I then also disabled the power managing on the wlan0 with 'sudo iwconfig wlan0 power off' and the pings normalised to what I'd expect with other devices,

$ ping -c 10 192.168.1.79
PING 192.168.1.79 (192.168.1.79): 56 data bytes
64 bytes from 192.168.1.79: icmp_seq=0 ttl=64 time=7.750 ms
64 bytes from 192.168.1.79: icmp_seq=1 ttl=64 time=8.076 ms
64 bytes from 192.168.1.79: icmp_seq=2 ttl=64 time=8.012 ms
64 bytes from 192.168.1.79: icmp_seq=3 ttl=64 time=7.970 ms
64 bytes from 192.168.1.79: icmp_seq=4 ttl=64 time=8.040 ms
64 bytes from 192.168.1.79: icmp_seq=5 ttl=64 time=4.971 ms
64 bytes from 192.168.1.79: icmp_seq=6 ttl=64 time=7.193 ms
64 bytes from 192.168.1.79: icmp_seq=7 ttl=64 time=4.930 ms
64 bytes from 192.168.1.79: icmp_seq=8 ttl=64 time=8.619 ms
64 bytes from 192.168.1.79: icmp_seq=9 ttl=64 time=8.011 ms

--- 192.168.1.79 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 4.930/7.357/8.619/1.248 ms


So turning off power management certainly looks like a good idea to me !

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4247
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 9:42 pm

The sudo BRANCH=next rpi-update fixed my issue with the channels.

Switching power management off definitely has an effect:

Code: Select all

pi@pluto:~ $ sudo iwconfig wlan0 power off
pi@pluto:~ $ ping -q 192.168.1.61
PING 192.168.1.61 (192.168.1.61) 56(84) bytes of data.
^C
--- 192.168.1.61 ping statistics ---
22 packets transmitted, 22 received, 0% packet loss, time 21031ms
rtt min/avg/max/mdev = 1.518/4.290/4.984/0.628 ms
pi@pluto:~ $ sudo iwconfig wlan0 power on
pi@pluto:~ $ ping -q 192.168.1.61
PING 192.168.1.61 (192.168.1.61) 56(84) bytes of data.
^C
--- 192.168.1.61 ping statistics ---
32 packets transmitted, 32 received, 0% packet loss, time 31050ms
rtt min/avg/max/mdev = 1.536/15.902/192.586/35.229 ms
pi@pluto:~ $ sudo iwconfig wlan0 power off
pi@pluto:~ $ ping -q 192.168.1.61
PING 192.168.1.61 (192.168.1.61) 56(84) bytes of data.
^C
--- 192.168.1.61 ping statistics ---
35 packets transmitted, 35 received, 0% packet loss, time 34050ms
rtt min/avg/max/mdev = 1.389/4.603/10.304/1.181 ms
So with power management off I get a mean round trip time of ~4.5ms with a small mean deviation. But with power management on I get a mean round trip time of ~16ms with a large mean deviation.

Bosse_B
Posts: 655
Joined: Thu Jan 30, 2014 9:53 am

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 9:45 pm

Good to know!
Still waiting delivery of my Pi3....
Bo Berglund
Sweden

User avatar
InsecureSpike
Posts: 23
Joined: Thu Feb 07, 2013 5:37 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 10:25 pm

Zagum wrote: So I then also disabled the power managing on the wlan0 with 'sudo iwconfig wlan0 power off' and the pings normalised to what I'd expect with other devices,

So turning off power management certainly looks like a good idea to me !
this worked for me!

Code: Select all

sudo iwconfig wlan0 power off
thank you!

kbordzan
Posts: 23
Joined: Wed Mar 02, 2016 12:40 pm

Smile or Cry?

Thu Mar 03, 2016 10:47 pm

Me vs TP-Link TL-WN725N @ OSMC - PART III

It's third time when I'm preparing SD card with OSMC. Each time I had issue with WiFi dongle TP-Link-WN725N.
Once I have solved it by manual update of Linux (I didn't know that OSMC is responsible for Linux update), and I have installed driver available for Raspbian. WiFi dongle has changed from blinking to solid light and network was working without problems.
But I have worried that my manual update can broke OSMC and have decided to do it correctly with OSMC Linux.
Current status is that WiFi network is disconecting without reason.

I have found this topic, and also another one: viewtopic.php?f=91&t=29752&start=200 and will proceed with all steps.

1. OSMC installation at SD card (16GB Kingston) - I have decided to choose wireless network (which previously I have done only once, as all tutorials are explaining that after OS installation, still network need to be set manually).
2. Installed version 2016.02-2
3. No network at starup.
4. All settings are done.
5. Network connected automatically during setup. SSH service enabled, but not possible to connect via Putty.
7. Manual updates checks for OSMC - no updates
8. Add-ons added, but SSH not working.

I guess that new OSMC version has solved problem with WiFi dongle, byt why SSH is not working?
Is it possible to restart SSH somehow?

tomputer
Posts: 2
Joined: Thu Mar 03, 2016 10:18 pm

Re: WiFi Issues ? Start here !

Thu Mar 03, 2016 10:49 pm

rurwin wrote: Switching power management off definitely has an effect:
[..]
So with power management off I get a mean round trip time of ~4.5ms with a small mean deviation. But with power management on I get a mean round trip time of ~16ms with a large mean deviation.
I can confirm this, i do experience the same behaviour with power management on the Raspberry Pi 3:

Power management disabled:

Code: Select all

iwconfig wlan0 power off

tom@box:~$ ping -q 192.168.2.4
PING 192.168.2.4 (192.168.2.4): 56 data bytes
^C
--- 192.168.2.4 ping statistics ---
20 packets transmitted, 20 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 5.375/18.011/223.406/47.193 ms
Power management enabled:

Code: Select all

iwconfig wlan0 power on

tom@box:~$ ping -q 192.168.2.4
PING 192.168.2.4 (192.168.2.4): 56 data bytes
^C
--- 192.168.2.4 ping statistics ---
21 packets transmitted, 21 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 7.734/291.685/917.824/264.140 ms
The Pi 3 runs Raspbian/Jessie (2016-02-26) on kernel:

Code: Select all

root@raspberrypi:~# uname -a
Linux raspberrypi 4.1.18-v7+ #846 SMP Thu Feb 25 14:22:53 GMT 2016 armv7l GNU/Linux
Network:

Code: Select all

root@raspberrypi:~# lshw -class network
  *-network:0             
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: b8:27:eb:ea:4d:91
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=brcmfmac driverversion=7.45.41.23 firmware=01-cc4eda9c ip=192.168.2.4 multicast=yes wireless=IEEE 802.11bgn

User avatar
GTR2Fan
Posts: 1601
Joined: Sun Feb 23, 2014 9:20 pm
Location: South East UK

Re: Smile or Cry?

Thu Mar 03, 2016 11:04 pm

kbordzan wrote:Is it possible to restart SSH somehow?

Code: Select all

sudo service ssh restart
... I think.
Pi2B Mini-PC/Media Centre: ARM=1GHz (+3), Core=500MHz, v3d=500MHz, h264=333MHz, RAM=DDR2-1200 (+6/+4/+4+schmoo). Sandisk Ultra HC-I 32GB microSD card on '50=100' OCed slot (42MB/s read) running Raspbian/KODI16, Seagate 3.5" 1.5TB HDD mass storage.

Koth69
Posts: 1
Joined: Fri Mar 04, 2016 3:47 am

Re: WiFi Issues ? Start here !

Fri Mar 04, 2016 3:52 am

Hi... please pardon the noob linux user question...

Do the commands to set the 'BRANCH' and disable the wlan power management:

Code: Select all

sudo BRANCH=next rpi-update
iwconfig wlan0 power off
Need to be run once only (once logged in via ssh) and that will make these changed permanently on the sd card? or will I need to put them in some kind of startup script to run every time the pi3 is turned on?

Appreciate your time in advance.

texy
Forum Moderator
Forum Moderator
Posts: 5094
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: WiFi Issues ? Start here !

Fri Mar 04, 2016 7:12 am

Koth69 wrote:Hi... please pardon the noob linux user question...

Do the commands to set the 'BRANCH' and disable the wlan power management:

Code: Select all

sudo BRANCH=next rpi-update
iwconfig wlan0 power off
Need to be run once only (once logged in via ssh) and that will make these changed permanently on the sd card? or will I need to put them in some kind of startup script to run every time the pi3 is turned on?

Appreciate your time in advance.
Hi
well it's easy to find out - do the ping test, make note of the readings, make the changes, do the ping test, make note of the readings, switch pi off (safely) and back on, do the ping test, make note of the readings - has it worked?

Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

tomputer
Posts: 2
Joined: Thu Mar 03, 2016 10:18 pm

Re: WiFi Issues ? Start here !

Fri Mar 04, 2016 8:02 am

Koth69 wrote:Hi... please pardon the noob linux user question...

Do the commands to set the 'BRANCH' and disable the wlan power management:

Code: Select all

sudo BRANCH=next rpi-update
iwconfig wlan0 power off
Need to be run once only (once logged in via ssh) and that will make these changed permanently on the sd card? or will I need to put them in some kind of startup script to run every time the pi3 is turned on?

Appreciate your time in advance.
The wlan power management setting is not permanent. I created a startup script to make sure it is disabled after a reboot:

Code: Select all

sudo touch /etc/network/if-up.d/wlan0
sudo chmod +x /etc/network/if-up.d/wlan0
sudo echo -e '#!/bin/bash\niwconfig wlan0 power off' > /etc/network/if-up.d/wlan0
The script 'wlan0' will be executed when the network devices are started.

I didn't do anything with the BRANCH=next rpi-update. As far as i understand, this is only required to enable wifi channels 12 and 13. I do not use these channels.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 71 guests