WiFi Issues ? Start here !


 
582 posts   Page 15 of 24   1 ... 12, 13, 14, 15, 16, 17, 18 ... 24
by MrEngman » Mon Jan 11, 2016 8:23 pm
H Bosse_B,

Did you make any changes to file /etc/network/interfaces. If you did that could be why you do not see any networks when selecting the network icon on the GUI and why you cannot get a wifi connection. Put /etc/network/interfaces back to it's original set up.

In your /etc/wpa_supplicant/wpa_supplicant.conf file the line wep_key0="FF23ED193A" needs the quotation marks removing around the hex key. To connect to a WEP AP in theory you can use the password used to generate the hex keys and the password needs quotation marks around it, psk="password", or you can use the hex key with no quotation marks, wep_key0=hex-key. The set up I use is similar to yours using wep_key0=hex-key.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Bosse_B » Mon Jan 11, 2016 8:43 pm
Thanks for replying!
1) /etc/network/interfaces
No, I did not edit the interfaces file. It looks like this right now and that is how Jessie has done it:
Code: Select all
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


2) /etc/wpa_supplicant/wpa_supplicant.conf
Again I did not edit this myself, what is there is put there by Jessie. At an early time during my tests the SSID list came up and I tried to connect both to auriga-ap (WPA2) and bossehemma (WEP). So in the GUI dialog I entered the password/key.
Then Jessie must have written it erroneously into the supplicant file. I really do not want to connect to bossehemma so I removed that part from the supplicant file.
After I had done so I restarted wlan0:
Code: Select all
pi@rpi2-jessie2:~/Projects/fpc/GPIOtest $ sudo ifup wlan0
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

As you see I get a very strange error message, but ifconfig shows the wlan0 like this:
Code: Select all
wlan0     Link encap:Ethernet  HWaddr 74:da:38:3e:d7:3d
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:363 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6200 (6.0 KiB)  TX bytes:6045 (5.9 KiB)

But still when I click the network icon there is no ssid list and instead it says:
wlan0: Not associated

Still no go....
EDIT:
Could it be a difference between Wheezy and Jessie? I seem to remember that in Wheezy there was no problems using this same Edimax dongle....
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by MrEngman » Mon Jan 11, 2016 9:03 pm
Hi Bosse_b,

Ignore those error messages ioctl[SIOCSI... etc.

Wifi can be really annoying sometimes and even if the set up is OK it just won't connect for one reason or another.

Shutting down the Pi and turning off the power for a short time could help. This has worked for me and I think this is because the wifi adapter is confused and is not reset properly on a reboot.
Then there are the two commands
Code: Select all
sudo ifdown wlan0
sudo ifup wlan0
which will take down and bring up the wifi again. One thing you could try is disconnecting the wifi from the Pi, wait 10 seconds, and then plug it back in and see if you get a connection. Probably similar to powering off the Pi as above.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Bosse_B » Mon Jan 11, 2016 11:14 pm
This is beyond me...
I shut down the Pi, then pulled the power cord for 10-15s.
Plugged it back in and waited a while for the networking icon to switch to the WiFi image.
No deal, so I clicked it and the SSID list popped up!
Selected the auriga-ap one and entered its password in the box and hit OK.
Nothing happened again so I tried the ifdown-ifup commands.
Then when I click the network icon there is no longer any SSID list.
ifconfig reports this concerning wlan0:
Code: Select all
wlan0     Link encap:Ethernet  HWaddr 74:da:38:3e:d7:3d
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:28 overruns:0 frame:0
          TX packets:0 errors:0 dropped:11 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1550 (1.5 KiB)  TX bytes:1395 (1.3 KiB)
No IP address but still 1550 bytes received....
Tried to see if it anyhow can detect the networks:
Code: Select all
pi@rpi2-jessie2:~ $ wpa_cli scan && sleep 5 && wpa_cli scan_results
Selected interface 'wlan0'
FAIL-BUSY
Selected interface 'wlan0'
bssid / frequency / signal level / flags / ssid
54:a0:50:79:02:b8       2412    42      [WPA2-PSK-CCMP][WPS][ESS]       Karlbom
08:11:96:6f:63:4d       2462    100     [WPA2-PSK-CCMP][ESS]    auriga-ap
b8:a3:86:5e:44:c5       2412    100     [WPS][WEP][ESS] bossehemma
And it can, but still it won't connect.
But for a short while (like 10 s) I saw it shift the icon to the WiFi one, then back to the "two computer" icon.
So I clicked it again and the list appeared and I entered the password and clicked OK, but no connection.
If I hover the mouse over the network symbol it now says
wlan0: Disassociated from auriga-ap
It just seems soo weird.
Started suspecting the power supply, but when I measure on the pin header 5V pin it shows 5.02V, so it could not be this that causes the problem either.
I have used another Edimax too, it sits on another RPi2B, which runs OSMC and KODI. Here at home that unit is using wired network but out at the vacation home it uses the WiFi to connect to my mobile broadband router. This has worked fine since May 2015 when I built it. I have just checked it and it is still working.
I just noted a difference in the network list for auriga-ap and the mobile network WiFi (I fired up the mobile router in order to check):
Code: Select all
 
[WPA2-PSK-CCMP][ESS]    auriga-ap
[WPA-PSK-CCMP][WPA2-PSK-CCMP][ESS]      bosse4g

Notice that auriga-ap only shows WPA2 whereas bosse4g shows WPA too.
Maybe the Edimax EW-7811Un is not capable of dealing with WPA2????
Or should there be another entry in the supplicant file for WPA2?
As a test I selected the bosse4g SSID in the list and entered its password.
Lo-and-behold! It connected almost immediately!
So could there be a WPA vs WPA2 issue here?

And lastly:
How can I disconnect a WiFi connection? Short of going to the terminal and entering sudo ifdown wlan0 I have found no way!
The GUI dialog does not give any such option....
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by Bosse_B » Mon Jan 11, 2016 11:37 pm
I modified the supplicant file so it reads:
Code: Select all
network={
        ssid="auriga-ap"
        psk="Volente2121"
        proto=RSN
        key_mgmt=WPA-PSK
}
for the auriga-ap network.
Made no difference, it will not connect.
But it happily connects to bosse4g after it fails with auriga-ap.

auriga-ap is a Windows7 access point which was created using the Windows command:
Code: Select all
netsh wlan set hostednetwork mode=allow ssid=auriga-ap key=Volente2121

It is meant to be used from the Pi to share the VPN connection I have on the Win7 laptop.
I have no idea how to enable WPA as opposed to WPA2 on the Win7 access point...
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by MrEngman » Tue Jan 12, 2016 12:06 am
The Edimax has no trouble connecting WP2, WPA or WEP for me.

I don't use the GUI to set up my wifi but edit /etc/wpa_supplicant/wpa_supplicant.conf manually. I only use the ssid and psk lines like
Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="network-name"
        psk="network-password"
}
wpa_supplicant will then work out for itself what it needs to do to connect to the wifi network. Perhaps you could try this.

Instead of using the GUI maybe you could try getting a connection from a terminal window. Change to a terminal window using ctrl-alt-f2. Change back to the GUI using ctrl-alt-f7 I think.

If you want to connect using the GUI it might be best to start with a clean /etc/wpa_supplicant/wpa_supplicant.conf with just
Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

and then see what happens.

Maybe the problem is something to do with the Windows 7 AP and how it works. Something I've never tried and did not know about.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Bosse_B » Tue Jan 12, 2016 9:14 am
MrEngman wrote:The Edimax has no trouble connecting WP2, WPA or WEP for me.
...
Maybe the problem is something to do with the Windows 7 AP and how it works. Something I've never tried and did not know about.

I Googled a bit more and I finally found an old post in a forum that stated:
MSDN forum wrote:only WPA2 keys are allowed.
The reason is that it is a hardware requirement for the Wireless Cards to be certified with the Microsoft Logo for Windows 7 to only allow WPA2 keys for the Virtual Access Point.

Then there also was a reference to a broken Microsoft page...
But I have seen numerous references to people having trouble connecting to the Windows AP using certain devices which are unable to do WPA2. So it seems like this is an issue that is common.

Now I have to get down to the basics concerning the Edimax EW-7811Un device:

1) Is an inability to use WPA2 dependent on the plug hardware or is it a driver issue? It really looks like my plug can connect just fine using WPA but not using WPA2.

2) Are there different hardware versions of the EW-7811Un around, such that some are able to do WPA2 and some are not?
How can one find out which version is currently plugged in?

3) Is there some way to ask the Raspbian driver for its capabilities regarding encryption?

4) Can the driver be updated to a later version via apt-get? If so how?

UPDATE:
I unplugged the Edimax WiFi and fetched the other Edimax dongle from my OSMC media center RPi2B and plugged in that instead. Turns out that it is able to connect to the auriga-ap!
I just selected the entry in the SSID list and did not enter any password but hit OK directly and it connected fine. Seems like if one enters a password it will rewrite the supplicant.conf file but if one leaves the password box empty it uses the password stored in the file.
Anyway, it seems like there is a hardware difference between the two plugs!
So my question #2 is really valid now....
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by MrEngman » Tue Jan 12, 2016 11:10 am
As I have said before the Edimax EW-7811Un can connect using WPA2. I have 4 of them, 2 about 4 years old and two about 2 years old and they all work with WPA2. Information about it, and hundreds more wifi adapters, can be found here https://wikidevi.com/wiki/Edimax_EW-7811Un.

I use the Edimax EW-7811Un and a variety of other wifi adapters and I have two access points both set to use WPA2 security and I can connect to either access point with the 7811Un and with any of my other wifi adapters.

One of my PI 2 B's is currently using the EW-7811Un and is connected with WPA2 security. wpa_cli status shows amongst other things
Code: Select all
mode=station
pairwise_cipher=CCMP
group_cipher=CCMP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED

I have been using these adapters since the Pi was first introduced in 2012 and have generally had no problems connecting to WPA2 APs.

In the past I have had one or two unusual problems where the wifi refused to connect but nothing to do with WPA2. I fixed these problems in a variety of ways including:-

1. Unplugging the wifi and plugging it back into a different USB socket and it worked OK. Then it worked when I plugged it back into the original socket or
2. Deleting the IP lease files, for squeeze and wheezy in /var/lib/dhcp, for Jessie in /var/lib/dhcpcd5 and rebooting.

Similar problems occur with other wifi adapters as well.

Don't forget the EW-7811Un is one of the most popular wifi adapters used with the Pi and if it could not connect to WPA2 there would be a lot of talk on the forum, but there is not.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Bosse_B » Tue Jan 12, 2016 11:58 am
Since I found out that the connectivity issue is really hardware dependent I have created a new thread for the final part of my problem, which is how to get access to the WiFi when the Ethernet cable is still connected. The remote network on the WiFi uses addresses 10.0.0.x and I can reach these if I unplug the Ethernet cable but not if it is plugged in.
It is not possible to reach the Internet via the VPN connection, it is a tunnel specifically only to the internal company LAN.

Anyway, this problem is discussed in this new thread.
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by alemnte » Thu Jan 14, 2016 5:57 am
I am using small usb wifi device that just has 802.11n written on it (cheap one off ebay). Power is www.cadrephotos.com through the micro usb using a genuine iPhone charger but maybe I should buy a usb hub?
Last edited by alemnte on Sun Jan 17, 2016 1:18 pm, edited 1 time in total.
Posts: 3
Joined: Mon Nov 23, 2015 7:11 am
by rahawes » Fri Jan 15, 2016 5:37 am
I have a Raspberry Pi from this summer that is part of a Gopigo. I just received it now. I followed the instructions on your website and set up the wifi over the ethernet cable. The wifi was working and showing up when I clicked on Wifi Setup (in dex.local.)
Then I followed the instructions to update the software, which may have been for the Gopigo2. After updating, I no longer have wifi (adapter and network not showing up in Wifi Setup.
An error message had appeared during the update and a log.txt file appeared in the GUI.
Might the drivers in my Wifi dongle, which were working before the update, have been affected during the update? I teach at a school and hope to start teaching 7th grade students how to work with the Pi and Gopigo.
I ran lsusb and my device is RT5370.
I ran lsmod and nothing shows up.
Posts: 1
Joined: Fri Jan 15, 2016 5:15 am
by ChopperHarris » Fri Jan 15, 2016 7:40 pm
Hi folks,

Sorry to post pretty much the same question as everyone else, but I'm having the apparently familiar issue whereby my RPi initially connects well to my WiFi router (detectable using ping) but a few minutes thereafter it becomes unreachable and pings will timeout. If I connect via SSH when it is reachable, the SSH session will hang if I leave it idle for a minute or two.

I'm running a clean installation of Jessie, freshly updated (using rpi-update and also apt-get update / apt-get upgrade):
Code: Select all
uname -a
Linux raspberrypi 4.1.15+ #830 Tue Dec 15 16:58:28 GMT 2015 armv6l GNU/Linux

My /etc/network/interfaces is more or less Jessie default (I've tried it with and without wireless-power off):
Code: Select all
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

/etc/wpa_supplicant/wpa_supplicant.conf contains:
Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="***********"
        psk="************"
        key_mgmt=WPA-PSK
}

And /etc/modprobe.d/8192cu.conf contains:
Code: Select all
options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1

This is based on the AdaFruit recommendation, but I've tried a variety of settings to see.

dmesg includes (amongst other strings):
Code: Select all
usbcore: registered new interface driver rtl8192cu
IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

lsmod gives:
Code: Select all
8192cu                567860  0

lsusb gives:
Code: Select all
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

I've tried the adapter with the same SD card running in a pi zero and a pi2 and get the same results with both. I've also tried using the adapter connected directly to the Pi and also via a powered Belkin hub.

I think my main issue is that I have exhausted my debugging abilities - I don't see anything obvious in /var/log but I may be looking in the wrong place. Can anyone help shed any light on this please?
Posts: 6
Joined: Fri Jan 15, 2016 7:06 pm
by MrEngman » Fri Jan 15, 2016 11:45 pm
Hi ChopperHarris,

wireless-power off in file /etc/network/interfaces does not seem to work with realtek wifi chip based wifi modules.

The file 8192cu.conf could be the problem and may be why your wifi is disconnecting. You should change rtw_enusbss=1 to rtw_enusbss=0. Don't know why rtw_ips_mode=1 is included or what it does and I don't use it in my 8192cu.conf file.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by ChopperHarris » Sat Jan 16, 2016 10:09 am
MrEngman wrote:Hi ChopperHarris,
You should change rtw_enusbss=1 to rtw_enusbss=0

Thanks MrEngman - I started off with those settings in place (also without the power management option in the interfaces file). However, I've reapplied them but the effect is the same - a few seconds of connectivity immediately after boot and then pings start to time out.

I should say that outbound pings from the box (e.g. to www.google.co.uk) seem to work pretty instantaneously - there's no obvious indication that there's anything wrong with the network. It seems as if everything from the pi outbounds is hunky-dory, but connectivity into the pi is the problem.
Posts: 6
Joined: Fri Jan 15, 2016 7:06 pm
by DougieLawson » Sat Jan 16, 2016 11:11 am
Did you reboot after updating /etc/modprobe.d/8192cu.conf?
When it fails take a look at dmesg | less to see if there are any exciting kernel messages.

Also try running a script from cron every few minutes create the following files

/etc/cron.d/wifi
Code: Select all
*/12 * * * * root /root/WiFiCheck.sh
that runs every twelve minutes

/root/WiFiCheck.sh
Code: Select all
#!/bin/bash

router="192.168.1.1"  ### FIXME change to your router IP
/bin/ping -q -c1 $router > /dev/null

if [ $? -eq  0 ]
then
  : #  echo "Network active"
else
  /bin/kill -9 $(pidof wpa_supplicant)
  /sbin/ifup --force wlan0

## TODO use this if you want a fixed IP address
##  /sbin/ifconfig wlan0 192.168.1.15/24

  /sbin/ip route add default via $router dev wlan0
  cat > /etc/resolv.conf <<resolver
nameserver $router
nameserver 8.8.8.8
resolver

fi
save that then make it executable with chmod 755 /root/WiFiCheck.sh
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 27560
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by npeckman » Sat Jan 16, 2016 9:00 pm
I'm running into some problems connecting an edimax wifi adapter to my house wifi. When I started my pi zero (running raspbian Jessie) with the adapter for the first time, my home network popped up on the interfaces. I entered the password, got a connection signal, loaded a webpage, and figured I was done. I started trying to ssh into my pi after that and wasn't getting a connection, so I looked back at my pi screen and saw that I had no connection signal. I clicked on my home network again and tried to log in, then the wifi interface icon reverted to the "no interface" mode. I then follow this tutorial(http://www.savagehomeautomation.com/projects/raspberry-pi-installing-the-edimax-ew-7811un-usb-wifi-adapte.html) which brought me through a lot of the same steps as the first post of this thread. My adapter is on and working fine. All my files in etc/network/interface and etc/wpa_supplicant/wpa_supplicant.conf seem to be right. When I run the scan line mentioned in this thread, I get
Code: Select all
Selected interface 'wlan0'
OK
Selected interface 'wlan0'
OK

which I assume is good. When I rebooted my pi, the connectivity returned, but as soon as tried to open a webpage, it disappeared. I followed all the steps in this thread and online, I'm not sure where to go from here. Any help appreciated!
Posts: 1
Joined: Sat Jan 16, 2016 8:46 pm
by MrEngman » Sun Jan 17, 2016 9:56 am
npeckman wrote:I'm running into some problems connecting an edimax wifi adapter to my house wifi. When I started my pi zero (running raspbian Jessie) with the adapter for the first time, my home network popped up on the interfaces. I entered the password, got a connection signal, loaded a webpage, and figured I was done. I started trying to ssh into my pi after that and wasn't getting a connection, so I looked back at my pi screen and saw that I had no connection signal. I clicked on my home network again and tried to log in, then the wifi interface icon reverted to the "no interface" mode. I then follow this tutorial(http://www.savagehomeautomation.com/projects/raspberry-pi-installing-the-edimax-ew-7811un-usb-wifi-adapte.html) which brought me through a lot of the same steps as the first post of this thread. My adapter is on and working fine. All my files in etc/network/interface and etc/wpa_supplicant/wpa_supplicant.conf seem to be right. When I run the scan line mentioned in this thread, I get
Code: Select all
Selected interface 'wlan0'
OK
Selected interface 'wlan0'
OK

which I assume is good. When I rebooted my pi, the connectivity returned, but as soon as tried to open a webpage, it disappeared. I followed all the steps in this thread and online, I'm not sure where to go from here. Any help appreciated!

Most tutorials are now out of date with the arrival of raspbian jessie. With Jessie, to configure your wifi, do not edit file /etc/network/interfaces.

You can set the wifi using the network icon in the GUI, or manually edit file /etc/wpa_supplicant/wpa_supplicant.conf. My Pi Zero has /etc/network/interfaces set to the default
Code: Select all
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
and I then set it to connect to my network by manually editing file /etc/wpa_supplicant/wpa_supplicant.conf like
Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="network-name"
        psk="network-password"
}
To set it up using the GUI make sure file /etc/network/interfaces is like as above and look here https://www.raspberrypi.org/documentation/configuration/wireless/README.md.

With the EW-7811Un it is also a good idea to add the file /etc/modprobe.d/8192cu.conf using command
Code: Select all
sudo nano /etc/modprobe.d/8192cu.conf
with the contents set to
Code: Select all
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
Save the file and close the editor with keys cntl-x, y, enter. After generating the file you will need to reboot to activate it. This will disable power management and stop the wifi module disconnecting from the USB if it is idle for any length of time.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3369
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by ChopperHarris » Sun Jan 17, 2016 1:51 pm
DougieLawson wrote:Did you reboot after updating /etc/modprobe.d/8192cu.conf?


Hi Dougie

Thanks for the suggestions - I did reboot (many times!) and have also added your suggested job into cron. I've left it running all morning, and added some additional debug into the script so that I can confirm that a) it's running and b) whether the ping succeeds or not.

Despite the RPi being un-pingable from other machines on the network, the ping from it to the router hasn't failed once. I've also modified the script to ping http://www.google.co.uk instead and that succeeds each time.

It seems like the outgoing connection remains active, but the public-facing side of the adapter isn't responding as one might expect. However, I have no idea whether that makes sense or not.
Posts: 6
Joined: Fri Jan 15, 2016 7:06 pm
by Bosse_B » Sun Jan 17, 2016 3:52 pm
On Windows there is a firewall thing that by default is blocking ICMP packets.
Maybe there is something similar in your case?
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by ChopperHarris » Tue Jan 19, 2016 1:40 pm
Bosse_B wrote:On Windows there is a firewall thing that by default is blocking ICMP packets.
Maybe there is something similar in your case?


I don't think that is going to be the case as the ping-ability of the pi is intermittent. However, I've also raised a support ticket with the manufacturer of my wireless router in case it's responsible for the issue. Thanks for the help here - I will report back once I hear from tp-link.
Posts: 6
Joined: Fri Jan 15, 2016 7:06 pm
by crosslegover » Wed Jan 20, 2016 4:15 am
My raspberry pi catches smatphone hospot, but it doesn't catch home wifi... it displays on the sceen though, but it just can't connect. What's the problem?
Posts: 1
Joined: Wed Jan 20, 2016 4:02 am
by Bosse_B » Wed Jan 20, 2016 7:28 am
What is the protocol (encryption) used by the home wifi?
If it is WEP then in my experience it is very difficult to make it connect.

If it is WPA or WPA2 then it should work fine. But it may also be an adapter issue.
I have two Edimax adapters (same model) and one refuses to connect to one of my WiFi networks but the other works just fine on both.
I struggled a great deal with this (see my posts from a few days ago in this thread) without success until I tried to use the other (newer) Edimax WiFi adapter. That worked immediately!
Very strange.
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by Bosse_B » Wed Jan 20, 2016 5:34 pm
MrEngman wrote: here is the full post
As I have said before the Edimax EW-7811Un can connect using WPA2. I have 4 of them, 2 about 4 years old and two about 2 years old and they all work with WPA2.
...
Don't forget the EW-7811Un is one of the most popular wifi adapters used with the Pi and if it could not connect to WPA2 there would be a lot of talk on the forum, but there is not.


UPDATE: (for the posts a bit earlier on this page)
I don't know if this is a clue to what has happened but today I bought a new Edimax EW-7811UN adapter.
On the package I noted that there was a silver label on the Channel selector for EU.
So I dug out the packages for the earlier two adapters and found that one also had the marker on the EU circle, but the other had its marker on the US circle.
I actually think I bought that adapter while visiting my daughter over in Michigan, USA a couple of years ago.

Now I wonder if this indicates that the adapters are different hardware-wise and that this could explain why WPA2 does not work on that when it does on the other?
Maybe there is a difference in WiFi frequencies or encryption keys in the US compared to EU and that the adapters are different due to this?
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am
by alchemistdagger » Thu Jan 21, 2016 7:17 am
hi, I am completely new to this. I have a raspberri Pi 2 with the new 7 inch touch screen display and a PiHut Wifi. I got the OS installed and running but unable to pull up a webpage in the browser. I have gone thru several instructions on setting up the Wifi and how-to-fix Wifi but nothing has worked so far. checking the files in the LXTerminal my ssid and password are correct, the raspberry Pi sees my network and my network sees the raspberry pi, but I can't pull up anything in the browser. any help is greatly appreciated.

i did just discover an error (i think), i ran this:

sudo service networking reload

and got this
[....] Reloading network interfaces configuration...ifup: interface lo already configured
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
done.


Here is what i have been looking at:

/etc/network/interfaces

Code: Select all
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


/etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
     ssid="network"
     pks="my password"
     key_mgmt=WPA-PSK
Posts: 6
Joined: Sat Jul 28, 2012 8:20 am
by Bosse_B » Thu Jan 21, 2016 7:27 am
I got the OS installed

You did not say WHICH operating system (aka distribution) you have installed....
There are a lot of different distributions for the RPi and WiFi is handled differently between them...
Bo Berglund
Sweden
Posts: 512
Joined: Thu Jan 30, 2014 9:53 am