Page 1 of 1

1 of 3 rpi won't read same SD card

Posted: Thu May 09, 2013 9:36 pm
by rkamicar
I have 3 different rpi's and two of them will boot from several of my SD cards, but one of them won't. Only the power LED comes on, so it's as if there is no card or the card is blank/corrupt/etc.

To be clear:
2 rpi's will boot from the same card with no problem and one will not.
If I put the card back into one of the others, it's fine, so it did not become corrupt somehow.

If I try a different card, I have the same exact result.
Same for a 3rd card.
I haven't gone beyond that.

There are a couple of cards that will work in all 3 rpi's.
--

All are model B. I used the same power adapter for all tests. Same connections (USB, ethernet, HDMI). Everything identical.
The 3rd rpi in question I bought in the past month. One of the other two a couple of months ago and the other about 8 months ago.

rpi-update done, etc. Contacts look clean.

Is there something else I should try?

Is this unusual? - I know some cards don't work, but since this card works for other pi's, I'd expect it should work in all. I believe the card is listed as OK, but I haven't double checked since I bought them.

Any other ideas or thoughts?

Re: 1 of 3 rpi won't read same SD card

Posted: Thu May 09, 2013 10:01 pm
by rickseiden
Are you running the latest and greatest Raspian on all your cards? The new Pis that come out don't run older versions of Raspian. There's a forum link that should go here, but I don't have it. So instead I'll point you to this blog post: http://www.raspberrypi.org/archives/3866

Re: 1 of 3 rpi won't read same SD card

Posted: Thu May 09, 2013 10:02 pm
by gulliverrr
I had a similar problem as I had some cards prepared for older RasPis (Rev 1 or early Rev 2) that didn't work in all 5 new Rev 2 RasPis I got last month. Exactly same diagnosis as yours!
In order to understand the difference, check if the "faulty" Raspi has Hynnix (in some funny writing) written on the main chip and also if it says Made in China close to the power connector. These 2 were my main 2 differences I could easily spot. If that's the case the solution is easy. Download the latest hard float Debian and try again. If you need Debian softfloat get all the files from the boot partition (not the one with your home dir) from a hard float card and copy them over the boot partition of the soft float card.

Re: 1 of 3 rpi won't read same SD card

Posted: Thu May 09, 2013 10:27 pm
by mahjongg
you were looking for this i assume: http://www.raspberrypi.org/archives/3534

Re: 1 of 3 rpi won't read same SD card

Posted: Fri May 10, 2013 2:41 pm
by rickseiden
mahjongg wrote:you were looking for this i assume: http://www.raspberrypi.org/archives/3534
That's the one!

Re: 1 of 3 rpi won't read same SD card

Posted: Fri May 10, 2013 4:46 pm
by rkamicar
Thanks for the tips.

I had, in fact, looked at those links. That's why I stated the same power adapter, etc and it's how I ended up here. I checked the troubleshooting wiki FAQ and it had nothing on this topic.

I checked my hardware and I have 2 rpi Made in the UK with Samsung 304 chip and 1 rpi Made in China with Samsung 246 chip.

However, it's one of the UK boards that has the issue. Same chip, so it doesn't look like that. (I tried again last night).

As for OS release, I meant that it was up-to-date with the line about "rpi-update done, etc" (though I realize I didn't specifically mention OS apt-get update && apt-get dist-upgrade. - I also did an apt-get upgrade and apt-get autoremove, btw).

So, the only thing I can think of, OS-wise, is that I might need to try a new, fresh debian, rather than the dist-upgrade. Though I'd think the upgrade would work.

Re: 1 of 3 rpi won't read same SD card

Posted: Sun May 11, 2014 2:23 am
by devmon
I am having a similar issue. My SD card works on somebody else's RPi but not my own. So I copied the same Arch Linux image to another SD card and that one works (on both). Any ideas what the problem could be? Why would my SD card work on one RPi and not another (since the problem isn't related to my OS)?

Re: 1 of 3 rpi won't read same SD card

Posted: Sun May 11, 2014 8:52 am
by DougieLawson
Have a look at the SDCard socket for bent pins or pins that don't make a good contact with the card.

Re: 1 of 3 rpi won't read same SD card

Posted: Mon May 12, 2014 11:37 am
by simonmcc
I know you've done an RPI update etc, but just to be sure its not a firmware issue I'd download a copy of a current distro and try that.

That caused me problems when I bought a new pi a while back, I tried it with an existing SD card and thought the pi was dead, but it turned out I needed updated software.

HTH