ratbag3366
Posts: 6
Joined: Wed May 01, 2013 12:29 pm

Working well on Ethernet but no on WiFi (RDP/SSH)

Wed May 01, 2013 12:46 pm

I am a happy owner of a 512Mb B Pi. I have it running Raspbian (all updated and upgraded).

It has a 4 port powered USB hub with a wireless keyboard (and built in trackpad) dongle (working perfectly) and an external 1Tb disk (stuffed with movies and the like). This is connected to one of the Pi USB ports and the second onboard port has a mini WiFi adaptor.

Now - the problem...

When I connect the Pi to the network via the Ethernet port, I am able to access the internet and also (from mac's and iPads etc) able to connect to the Pi via RDP and ssh. Great - just what I wanted!

The IP address (due to DHCP / Mac address allocation is 192.168.1.109

However - When I disconnect the ethernet cable and reboot, the Pi's WiFi connects to the router/internet (with DHCP/MAC allocated address of 192.168.1.108). The Pi can access services on the Lan and internet but it is not possible to contact the via SSH/RDP/Ping etc.

Am I doing something wrong?

I have checked the WiFi IP address via the GUI interface and it says its 108 as expected...

Help and (constructive) criticism will be much appreciated.

ratbag3366
Posts: 6
Joined: Wed May 01, 2013 12:29 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Wed May 08, 2013 5:02 pm

I have since bought a second pi (for other uses to the first) and thought that this time i would only set up the WiFi card (to eliminate the possibility that the SSH service was only configured for the eth0 port). The same problems exists - i.e can surf the net, download packages (over WiFi) etc but not connect to the Pi via ssh or ping it from another local machine on the same WiFi LAN. This is really annoying. Can any one please help?
Is there a firewall on the WiFi adaptor or something that might be preventing it responding to outside packets?

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5197
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Wed May 08, 2013 5:21 pm

ratbag3366 wrote:I have since bought a second pi (for other uses to the first) and thought that this time i would only set up the WiFi card (to eliminate the possibility that the SSH service was only configured for the eth0 port). The same problems exists - i.e can surf the net, download packages (over WiFi) etc but not connect to the Pi via ssh or ping it from another local machine on the same WiFi LAN. This is really annoying. Can any one please help?
Is there a firewall on the WiFi adaptor or something that might be preventing it responding to outside packets?
Since both your wired LAN and WiFi both appear to be on the same (192.168.1.x) subnet it looks at if it's firewall or other configuration issues with your router and/or your other local machine. What happens if you try pinging (ssh'ing) between Pi's? (FYI I have several Pi's and can ping or ssh them wired or by WiFi via my router & switches either from another Pi or my Acer netbook running Ubuntu. Although the latter can still be booted into XP I must admit I haven't tried such with that O.S. Generally the IP addresses are "statically" assigned by the router by DHCP) NB: I'm assuming you're pinging the Pi etc. by its IP address directly not by hostname (if the latter it's a DNS issue perhaps).
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

TxBobS
Posts: 18
Joined: Thu Mar 14, 2013 11:46 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Wed May 08, 2013 5:33 pm

It is interesting that it doesn't respond to pings.

Are both Pis up on your network now?
Do they have different IPs?
Is the machine you're connecting from on the same LAN as the Pi? (multiple routers like maybe a wifi router built into your modem plus your personal router connected to the modem?)

ratbag3366
Posts: 6
Joined: Wed May 01, 2013 12:29 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Wed May 08, 2013 5:58 pm

I'll try the Pi2Pi SSH'ing asap. The router is setting IP addresses based on MAC addresses so that I can guarantee a 'static' environment without the hassle of manually configuring all the many IP enabled devices on the LAN. I am using a Draytek 2820n router with a few clever filtering application and content filters but have avoided that on the LAN - which should be clear of restrictions between devices. I have set up IP groups so that I have trusted, static and 'kids' devices with different WAN properties but again that hasn't ever affected LAN side traffic.

I'll report back soon.

ratbag3366
Posts: 6
Joined: Wed May 01, 2013 12:29 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Fri May 10, 2013 11:48 am

I think it may all be a problem with the router...

I can't explain it (as everything else on the LAN works - including SSH and RDP to other devices) but if i connect the Pi to a different access point (on the same LAN) I am able to connect (from devices on the other WiFi access point) to the Pi with both SSH and RDP.

Weird!

Ok - I have a work around but it would be interesting to know what's going on...

Thank you all for your help and suggestions.

KayKallis
Posts: 4
Joined: Sun Jun 16, 2013 4:36 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Thu Jun 20, 2013 2:03 am

I too am having similar issues with WiFi SSH.

When I'm connected via Ethernet (hardline) and WiFi, then SSH works fine via WiFi.

But I'm not able to connect with WiFi by itself (no hardline connected).

Any thoughts?

Here are the details...

http://www.raspberrypi.org/phpBB3/viewt ... 2&start=48

Thanks in advance...

GrantsPi
Posts: 3
Joined: Sun Jun 30, 2013 12:44 am

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Sun Jun 30, 2013 12:53 am

Hi. Sure hope someone has the answer. I have the same problem. Can connect with Putty and RealVNC through WiFi when the RPi is has the Ethernet connection in place. Once I remove the Ethernet connection and reboot the Pi I cannot connect through WiFi using either Putty or RealVNC even though the router shows the Pi to be connected with the expected IP address.
Have tried doing a complete re-install of all software (a number of times); same result.

User avatar
raspberrydt
Posts: 57
Joined: Mon Jan 21, 2013 3:09 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Sun Jun 30, 2013 10:50 am

I had a very similar issue with a webcam. When connected by cable everything was fine, when I put it on Wifi connection impossible frommy wifi netbook.
I was very surprised when I noticed I could access the webcam when my notebook was connected by cable.
So one device on wlan and one on cable works, both on wlan doesn't work. Both devices connected by cable worked too. There is a setting on my wlan internet router "allow communication between wlan devices" hidden somewhat deep inside the system configuration. Set it, clicked "Save", and everything was fine.

Arptastic
Posts: 2
Joined: Thu Nov 21, 2013 8:54 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Thu Nov 21, 2013 9:04 pm

Chiming in a little late: I had a similar issue doing a headless setup.

For me, it seems to be some sort of routing issue - not sure what the specific issue is but it seems that the Pi is un-contactable until it hits something else on the local subnet.

Router using DHCP to assign 'static' address via DHCP to the Pi: 192.168.1.252

Logging into the Pi directly, I can see the IP has been assigned by DHCP successfully.

Code: Select all

ping google.com
is successful.

Code: Select all

ping 192.168.1.1
(router) is also successful - and after doing this my Windows PC (192.168.1.2) is able to ping and SSH to the Pi.

So... In terms of a solution (NB: workaround that worked for me in this case)

Log in to your Pi

Code: Select all

crontab -e
- loads up the crontab editor.

Add a new line at the bottom:

Code: Select all

* * * * * ping 192.168.1.1 -c 1
- replacing 192.168.1.1 with your router's IP if necessary.

The Pi will now ping your router once every minute...

Apologies if this does not work for you but it sorted mine out immediately - after rebooting the Pi I am able to ping/SSH without ethernet attached or having to log in manually first.

If anyone has any ideas on what might cause this any opinions would be much appreciated!

BlueFox
Posts: 1
Joined: Tue Apr 01, 2014 7:56 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Tue Apr 01, 2014 8:00 pm

Hi
I've had the same problem and the following link worked for me

http://www.howtogeek.com/167425/how-to- ... mand-line/

Hope this will help someone in the future

Regards

anorse
Posts: 1
Joined: Mon May 19, 2014 5:26 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Mon May 19, 2014 5:30 pm

I have this exact problem and found it was a router problem. There are a lot of different ways routers phrase this option. I use the Linksys EA6200 and turning off 'wifi protected setup' in the wireless options tab fixed everything. There is probably a more advanced solution rather than just disabling features, but if you're in a pinch...

Marshy37
Posts: 1
Joined: Fri Oct 10, 2014 9:33 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Fri Oct 10, 2014 9:41 pm

Thank anorse - your solution worked for me after spending hours on this. I have a Virgin Media cable router and found the Enable WPA in the advanced wireless settings. I turned it off, rebooted router then rebooted pi. Now I can SSH to the Pi using the wifi connection.
So thankful to find a solution I have registered on the forum just to say thank you and to encourage others with the same problem to try this as well.

miket1024
Posts: 1
Joined: Sun Mar 08, 2015 1:49 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Sun Mar 08, 2015 1:56 pm

I had the same issue and also found it to be a router problem. With Ethernet on my computer and on the Pi, everything worked fine, but the router was not routing RDP to the Pi on wireless. I found instructions for my NetGear router to setup port forwarding for RDP. Essentially I setup a new port forwarding rule to the IP address of the Pi with port 3389 and named it RPI RDP. After that I had no trouble RDPing into the PI. Why the netgear defaults to allowing this on ethernet and not on WiFi I'm not sure; security thing I suppose.

Here is the webpage that gave me the instructions:
http://portforward.com/english/routers/ ... esktop.htm

mst66186
Posts: 2
Joined: Sun Mar 15, 2015 10:39 am
Location: Melbourne, Australia

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Sun Mar 15, 2015 10:46 am

Yes! On a Netgear router the setting can be found under the admin page, advanced tab, WPS Wizard, Wireless Setup, and it's called "Enable Wireless Isolation".
If you want to SSH to your RP on WiFi you will need to make sure that checkbox is not checked.

szaboteur
Posts: 1
Joined: Wed Mar 25, 2015 10:07 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Wed Mar 25, 2015 10:13 pm

hy, i had the same issue. i solved it by changing the encryption on my router from tkip to aes (tkip was default). now its working fine on wifi too! hope it helps....

User avatar
SR-71
Posts: 16
Joined: Fri Nov 23, 2012 7:56 pm

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Sat Mar 19, 2016 3:32 pm

ratbag3366 wrote:I am a happy owner of a 512Mb B Pi. I have it running Raspbian (all updated and upgraded).

It has a 4 port powered USB hub with a wireless keyboard (and built in trackpad) dongle (working perfectly) and an external 1Tb disk (stuffed with movies and the like). This is connected to one of the Pi USB ports and the second onboard port has a mini WiFi adaptor.

Now - the problem...

When I connect the Pi to the network via the Ethernet port, I am able to access the internet and also (from mac's and iPads etc) able to connect to the Pi via RDP and ssh. Great - just what I wanted!

The IP address (due to DHCP / Mac address allocation is 192.168.1.109

However - When I disconnect the ethernet cable and reboot, the Pi's WiFi connects to the router/internet (with DHCP/MAC allocated address of 192.168.1.108). The Pi can access services on the Lan and internet but it is not possible to contact the via SSH/RDP/Ping etc.

Am I doing something wrong?

I have checked the WiFi IP address via the GUI interface and it says its 108 as expected...

Help and (constructive) criticism will be much appreciated.
I get this issue as well, see

viewtopic.php?p=932926#p932926

for a workaround.

ARaspberry
Posts: 3
Joined: Fri Jul 29, 2016 10:01 am

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

Fri Jul 29, 2016 10:07 am

I have a similar problem:
I have ssh(cygwin) on my pc(connected with ethernet cable), and my pi is connected wirelessly.
If I use Termux from my phone, then I connect to the pi successfully.
But if I use my pc(ethernet) to connect to the pi(wireless), with command

Code: Select all

ssh -p port [email protected]_pi_ip
, it says:

Code: Select all

ssh: connect to host wireless_pi_ip port port: Connection timed out
.
How do I solve this?

Return to “Troubleshooting”