Raspberry Pi suddenly quit working

5 posts
by nunchucksuka » Thu Apr 18, 2013 2:01 pm
I just got my raspberry pi and have had it running a few days now. Just yesterday I was working on installing the Arduino IDE so I can program an Arduino from the Pi. I first ran
Code: Select all
sudo apt-get update
to make sure everything was current then
Code: Select all
sudo apt-get install arduino
to install the Arduino IDE. Everything seemed to work fine and I even compiled the Arduino Blink program and uploaded it to my arduino uno just to make sure everything was working as expected. Good so far.

I left my desk for about 15 min and when I came back the screen was blank like it had shut down the display from inactivity, but it was completely unresponsive and wouldn't 'wake-up'. I tried resetting the pi by doing a power cycle, but no luck. All that happens is the ACT led blinks once green during initial power up, and the PWR led is constant red. I have tried booting it with only the SD card and power, no difference.

I have verified the 5 V from TP2 to TP1, and made sure the voltage to ground was the same on each side of the polyfuse. I tried reflashing the SD card with the Raspbian distro I downloaded (and verified with SHA1) but still no luck. I bought the SD card when I purchased the pi to come preloaded with Raspbian and since it was running fine initially it doesn't seem to be a problem of incompatibility. Any suggestions on next troubleshooting steps? Any help is much appreciated.
Posts: 3
Joined: Thu Apr 18, 2013 1:43 pm
by nunchucksuka » Sat Apr 20, 2013 6:43 pm
I also tried swapping out the display just to make sure that wasn't the problem, but that didn't make a difference either. When I plug an ethernet cable into the board, the communication led's light up as expected, but for some reason I can't get the display to show anything. I'm really stuck on this one and I just got the board about a week ago. Is there any warranty on these things? I don't know what went wrong with it, and I was just starting to have fun ;)
Posts: 3
Joined: Thu Apr 18, 2013 1:43 pm
by drgeoff » Sat Apr 20, 2013 7:29 pm
Put the SD card back in the computer that you used when you reflashed it. Can you see some files on it?

Warranty laws often depend on the country and whom you bought it from.
Posts: 6762
Joined: Wed Jan 25, 2012 6:39 pm
by btidey » Sat Apr 20, 2013 11:16 pm
You could also try seeing if you can connect via SSH into the Pi to see if it is basically running and whether it is just the display you are having a problem with.

You'd need to determine what the IP address of the Pi is. Best way to do that is to check on your router admin pages which devices are connected. If it shows up there, and you can ping it then that's a good indicator that it is booting up in some fashion.

You can then go on from there to try a SSH connection (e.g. using Putty on a PC to pi@ipaddr).

If that works then the Pi is booting and running and you then have to sort out why you are not getting a display. You said you swapped out the display. What type was it? HDMI, Composite, HDMI to VGA? Are there any common bits like cables that could be the problem?
Posts: 1263
Joined: Sun Feb 17, 2013 6:51 pm
by nunchucksuka » Tue Apr 23, 2013 1:05 am
Great suggestion using ssh. I just jumped through ssh and rebooted from the command line. As soon as it rebooted the display started working again. Back in business :)
Posts: 3
Joined: Thu Apr 18, 2013 1:43 pm