Rusakko
Posts: 35
Joined: Fri Dec 14, 2012 6:18 pm

Red dots in screen with raspbmc

Mon Apr 08, 2013 8:35 pm

I have a problem with red dots on the screen with raspbmc.
The attached image will illustrate the problem more but I will try to explain it too. Raspberry (512Mb) is connected to amplifier with hdmi, has wired ethernet and one usb hard drive with own power. I use new mobile phone charger as power for raspberry and I don't think that should be the problem. Raspbmc is daily build updated 2013.3.17 or something like that. My first idea was the temperature but it's around 40-45 celcius. Already in menus you can see red dots. Same dots flicker when movie is playing, usually in dark parts of the screen. I tried with another raspberry (256Mb) and i didn't see dots with it, but raspbmc kept crashing, maybe too little memory or something else.
So have anyone seen this kind of problem and what could cause it.
My opinion is that this was not there at the beginning but has appeared lately. Is my raspberry broken or is this something else? Any ideas are welcome.

Rusakko
Posts: 35
Joined: Fri Dec 14, 2012 6:18 pm

Re: Red dots in screen with raspbmc

Mon Apr 08, 2013 8:39 pm

Picture of the screen
Image

M33P
Posts: 199
Joined: Sun Sep 02, 2012 1:14 pm

Re: Red dots in screen with raspbmc

Mon Apr 08, 2013 8:42 pm

Can you try adjusting the HDMI drive strength?

Add a line

config_hdmi_boost = 4

in /boot/config.txt to boost the HDMI output and reboot for the changes to take effect.

User avatar
johnbeetem
Posts: 945
Joined: Mon Oct 17, 2011 11:18 pm
Location: The Mountains
Contact: Website

Re: Red dots in screen with raspbmc

Mon Apr 08, 2013 8:48 pm

I had a similar problem (in my case green dots) when I had an iffy power supply. With TP1-TP2 at 4.65V or higher, everything was fine. Lower than that, when I did something compute-intensive like compiling the green dots would appear and then go away when the compile was complete. Nice "feature", except that sometimes the screen would blank out entirely.

Here's an item about your sort of problem at the RasPi Troubleshooting Wiki: http://elinux.org/R-Pi_Troubleshooting# ... VI_monitor

Rusakko
Posts: 35
Joined: Fri Dec 14, 2012 6:18 pm

Re: Red dots in screen with raspbmc

Tue Apr 09, 2013 6:31 am

I have to try boosting later today
also i could try to use different power source
thanks for the input, i will post results about those changes when i have tried those

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23708
Joined: Sat Jul 30, 2011 7:41 pm

Re: Red dots in screen with raspbmc

Tue Apr 09, 2013 6:53 am

It may also be a dodgy connection on the HDMI (or a bad lead).
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

Rusakko
Posts: 35
Joined: Fri Dec 14, 2012 6:18 pm

Re: Red dots in screen with raspbmc

Thu Apr 11, 2013 6:32 am

Little update
I tried boosting with 4, no result. Different power source, no result. Different hdmi cable, no result.
then I boosted hdmi to 7. It seems to work. At least for couple of hours of video, i haven't seen any red dots.
So hopefully this fixed the problem. And thank you for help for everybody.

Rusakko
Posts: 35
Joined: Fri Dec 14, 2012 6:18 pm

Re: Red dots in screen with raspbmc

Fri May 10, 2013 11:18 am

Now these red dots are back. I tried with another raspberry pi and everything is working fine with the same sd card. So I believe it must be hardware problem. Not even the boost is helping anymore. Same with different sd card and different image.

I there warranty to cover this kind of things. My raspberry is about 6 months old and bought from RS Components in UK.

Or does anyone have any other suggestions how to fix this?

johnrlang58
Posts: 1
Joined: Tue May 19, 2015 3:48 am

Re: Red dots in screen with raspbmc

Tue May 19, 2015 4:02 am

I too have an intermittent problem with the display, :( with random red dots flickering on the screen. My initial assumption is that it is the video card on the Pi. The supplier disagrees, but I am running out of tests to do....

The red and blue dots appear at different places on the display, usually not on startup, but after the board has warmed up.
From the suppliers response my testing confirms:
It is not a Media format decode issue - This happens for all output from photos, to videos and the main menu.
It is not a power issue - the same problem occurs with both the supplied and a 2A USB battery supply
It is not a cable issue as the same thing happens with different HDMI cable
It is not the Tv (Samsung Series 6) as can be duplicated on a monitor or projector...

Last thing to try is the HDMI signal tweak.
John

funomat
Posts: 9
Joined: Tue Mar 29, 2016 8:41 pm

Re: Red dots in screen with raspbmc

Thu Jun 30, 2016 6:12 pm

It's an overheating issue. Usually you will see this with the pi 3 since it overheats very easily. It can also happen with pi 2 though if you wait long enough (I tested it with both).
Do a test: Switch off the pi for 2 days until all the red dots are gone (it takes this long for me).
Place the pi into the bottom half of a pi case. Turn it on. Start some GUI (something that utilizes graphics).
After 8-48 hours depending on environment temperature the red dots will start to appear.
Now take the pi out of the case, so the chip on its bottom receives some fresh, cooler air.
Result for me: The red pixels will start to fade.
Unfortunately they'll appear again over time even without a case AND (if it's a pi 3) with heatsinks applied if you just let the pi heat up long enough.
As far as I know there is no solution except using active cooling.

Other sideeffects of the overheating: More colour corruptions than just the red dots. Degradation of sound output until it stops completely.

Jswalker
Posts: 1
Joined: Wed Aug 23, 2017 6:38 pm

Re: Red dots in screen with raspbmc

Wed Aug 23, 2017 6:41 pm

I know I'm a little late,

But I'm currently experiencing green dots on a 4K tv while running OSMC on a Raspberri Pi 3b connected directly via HDMI.

Has a fix been found for this?

Thanks
Jim

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12242
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Red dots in screen with raspbmc

Thu Aug 24, 2017 12:32 am

yes, this is a symptom caused by lossy HDMI cables that weaken the digital signals to much that reception errors occur, its well known that the solution is to increase the drive strength of the HDMI output using an entry in config.txt, that or replace the HDMI cable with a better quality one.

Return to “Troubleshooting”