Page 1 of 1

VNC Sever won't start [solved]

Posted: Sat Apr 06, 2013 10:04 pm
by pickleshirt
Received my RPi yesterday and got right to work getting it set up. Flashed an 8GB SD with "2013-02-09-wheezy-raspbian" and with only a few issues (mostly power supply related), I was up and running.

I then attempted to remotely access the RPi with my Mac by installing TightVNCServer using the guidance provided by 'http://www.penguintutor.com/linux/tightvnc' I can access the RPi via SSH on the Mac terminal, but no such luck with the VNC client. No matter what I do on the client side, I only get "connection refused." Low and behold, TightVNCServer is not running. See below for the startup info:
_______________
pi@raspberrypi ~ $ tightvncserver
Couldn't start Xtightvnc; trying default font path.
Please set correct fontPath in the tightvncserver script.
Couldn't start Xtightvnc process.

06/04/13 21:55:57 Xvnc version TightVNC-1.3.9
06/04/13 21:55:57 Copyright (C) 2000-2007 TightVNC Group
06/04/13 21:55:57 Copyright (C) 1999 AT&T Laboratories Cambridge
06/04/13 21:55:57 All Rights Reserved.
06/04/13 21:55:57 See http://www.tightvnc.com/ for information on TightVNC
06/04/13 21:55:57 Desktop name 'X' (raspberrypi:1)
06/04/13 21:55:57 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
06/04/13 21:55:57 Listening for VNC connections on TCP port 5901

Fatal server error:
could not open default font 'fixed'
06/04/13 21:55:58 Xvnc version TightVNC-1.3.9
06/04/13 21:55:58 Copyright (C) 2000-2007 TightVNC Group
06/04/13 21:55:58 Copyright (C) 1999 AT&T Laboratories Cambridge
06/04/13 21:55:58 All Rights Reserved.
06/04/13 21:55:58 See http://www.tightvnc.com/ for information on TightVNC
06/04/13 21:55:58 Desktop name 'X' (raspberrypi:1)
06/04/13 21:55:58 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
06/04/13 21:55:58 Listening for VNC connections on TCP port 5901
Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring

Fatal server error:
could not open default font 'fixed'
_______________

I was able to resolve a few of the font issues, created additional font directories with links to the main font directory, but no luck. While I've seen this issue in many posts, I didn't find a solution that solved the problem. Me thinks I must have really goofed up something somewhere!

Thanks in advance for your help!

Re: VNC Sever won't start

Posted: Sat Apr 06, 2013 11:17 pm
by Jim JKla
Have not tried this lately but this worked for me.

http://elinux.org/RPi_Wheezy_VNC

note comment on being root (as in not)

Re: VNC Sever won't start

Posted: Sat Apr 06, 2013 11:49 pm
by pickleshirt
I was so hopeful too...

So upon trying 'sudo apt-get install vnc-server', it responded with "Note, selecting 'tightvncserver' instead of 'vnc-server' tightvncserver is already the newest version." After a snicker, I removed tightvncserver with sudo apt-get remove and tried to install vnc-server again. Thinking I was home free, it now responded "Note, selecting 'tightvncserver' instead of 'vnc-server' Suggested packages: tightvnc-java The following NEW packages will be installed: tightvncserver"

Is it worth forcing the system to work with vnc-server or should tightvncserver work as is (and I'm just doing something wrong?)

Re: VNC Sever won't start

Posted: Sun Apr 07, 2013 12:01 am
by Jim JKla
I don't know I did not do anything special but I was operating from a Windows environmet the first time then I logged in from an Ubuntu install (Dual boot same machine) I had no real issues with either (aside form it being a slow connection) this was a while ago.

To put this in context the only available RPi was the 256 "B" and the image was Wheezy 2012-06-18 beta which won't play with one of the newer 512 "B"'s but I have no reason to suspect that there would be any problems with the latest Wheezy image. I do remember something about having to change the port from the default.

It was tested completly headless as in no monitor but it also ran dual with my TV handling HDMI and my PC (WindowsXP) running VNC and that was both TightVNC and UltraVNC (not however both at the same time :)

Re: VNC Sever won't start

Posted: Sun Apr 07, 2013 2:09 am
by 1pi2much
pickleshirt wrote:I was so hopeful too...

So upon trying 'sudo apt-get install vnc-server', it responded with "Note, selecting 'tightvncserver' instead of 'vnc-server' tightvncserver is already the newest version." After a snicker, I removed tightvncserver with sudo apt-get remove and tried to install vnc-server again. Thinking I was home free, it now responded "Note, selecting 'tightvncserver' instead of 'vnc-server' Suggested packages: tightvnc-java The following NEW packages will be installed: tightvncserver"

Is it worth forcing the system to work with vnc-server or should tightvncserver work as is (and I'm just doing something wrong?)
Try running vncserver (not tightvncserver). I think that is the one you installed. It will run tightvncserver as per my .log file. My specific command is

Code: Select all

vncserver :1 -geometry 1280x800 -depth 16 -pixelformat rgb565
--

Re: VNC Sever won't start

Posted: Sun Apr 07, 2013 2:33 am
by simplesi
I always use X11VNC
http://www.raspberrypi.org/phpBB3/viewt ... 62#p108862

When I says always, I mean every time I've imaged a card since October 2012, I've done this and it works every time :)

It has the advantage/disadvantage (depending on what you want it for) in that it echos the main screen, not a "virtual" one.

I like this because if I ever plug in a monitor then what I see on it is the same as what I see over VNC :)

IF the instructions doesn't work for you - either you've typed them wrong or you have a fault on your RPi/network

Simon

Re: VNC Sever won't start

Posted: Mon Apr 08, 2013 1:18 am
by pickleshirt
Success!

As quickly as I could type the commands, I was up and running with X11VNC. Thanks 'simplesi'! :D

Re: VNC Sever won't start

Posted: Mon Apr 08, 2013 2:32 am
by simplesi
:)
You can always trust me to find the simplest route to success :)
Clue's in the name :)

Simon

Re: VNC Sever won't start

Posted: Tue Dec 02, 2014 12:33 pm
by apenen
Hi.

I have solved it by installing xfonts-base.

Regards.

Re: VNC Sever won't start

Posted: Wed Feb 18, 2015 9:48 am
by meltwater
apenen wrote:Hi.

I have solved it by installing xfonts-base.

Regards.
Excellent. That did the trick for me. Thanks!

Re: VNC Sever won't start

Posted: Sun Aug 04, 2019 8:54 pm
by jason_helms_2019
I was running into the same issue and tried the following:

apt-get remove --purge xfonts-base
apt install xfonts-base

Then vncserver worked without issue. The size of the packages were not the same, the size of the purged xfonts-base was 53KB bigger then when apt installed the same package. Somehow the fixed font is installed where vncserver wants.

I tried to get the full output of the successful vncserver output but whoops. Hope this helps.

Re: VNC Sever won't start

Posted: Mon Aug 05, 2019 1:09 am
by mahjongg
Not only was the thread four years old, but it was also solved!
re-opening such old threads, is BAD!

locking!