LOBrien
Posts: 15
Joined: Sat Apr 14, 2012 9:06 pm

No sound over HDMI (solved)

Mon Mar 18, 2013 9:52 pm

Hi folks, I'm sure this problem comes up a lot. I cannot get my sound to work over HDMI although I can get audio perfectly over the audio jack. I have tried the solutions on this page and still have no audio: http://www.raspberrypi.org/phpBB3/viewtopic.php?t=5062

Here is my config.txt
# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=900

# for more options see http://elinux.org/RPi_config.txt
gpu_mem=128
avoid_safe_mode=1
core_freq=250
sdram_freq=450
over_voltage=2
hdmi_drive=2
Any solutions would be greatly appreciated.
Last edited by LOBrien on Mon Mar 18, 2013 10:25 pm, edited 1 time in total.

Spid
Posts: 525
Joined: Sat Jan 19, 2013 12:47 pm

Re: No sound over HDMI

Mon Mar 18, 2013 10:07 pm

Sound output by default will by either HDMI or Audio Out Jack, and by default it will auto-detect
On the command line type any of the following, pressing the enter key after each entry:

HDMI output:
sudo modprobe snd_bcm2835
sudo amixer cset numid=3 2

Audio Jack output:
sudo modprobe snd_bcm2835
sudo amixer cset numid=3 1

Autodetect output:
sudo modprobe snd_bcm2835
sudo amixer cset numid=3 0
I will always assume you are running Raspbian for desktop and Raspbmc for XMBC !

LOBrien
Posts: 15
Joined: Sat Apr 14, 2012 9:06 pm

Re: No sound over HDMI

Mon Mar 18, 2013 10:25 pm

Exactly what I was looking for, thank you!

Return to “Troubleshooting”