Posts: 1
Joined: Mon Dec 03, 2012 10:56 am

sdcard sudenly won't boot

Wed Mar 13, 2013 11:02 am


I have got the problem that my Raspberry Pi won't boot anymore from my sd-card. I have always used this sd-card for my raspberry with no problems (running OpenElec), but now it won't boot anymore, there is no display output and only the red led is on. The strange this is that the sd-card works just fine when I use it on my PC. I have also tried to put several other images on the sd-card (i.e. OpenElec, Raspbmc and XBain) but it still won't boot (still no green led). I have another sd-card (exactly the same as the broken one) which works just fine, so I know my Raspberry isn't broken :) . Has anyone experienced something similar and/or has a solution?
BTW: The turbo mode of my raspberry was set to normal and it was running with no problems for months.



Posts: 917
Joined: Sun Jul 29, 2012 9:06 pm

Re: sdcard sudenly won't boot

Wed Mar 13, 2013 11:28 am

Maybe 1 of the pi sd socket connector pins isn't making good contact anymore?
If it works again when you add a little pressure to the sd card it's your issue.

Posts: 12
Joined: Tue Nov 06, 2012 11:10 am

Re: sdcard sudenly won't boot

Wed Jul 24, 2013 3:55 pm

On a number of occasions, I solved the booting problem by running fsck in a Linux machine after connecting the SDcard in a card reader. Generally, I find that running RPi headless creates less problems in SDcard.

Return to “Troubleshooting”