User avatar
jbeale
Posts: 3630
Joined: Tue Nov 22, 2011 11:51 pm
Contact: Website

Re: WLAN too slow

Fri Jan 24, 2014 1:17 am

I have at least five RTL8188CUS based wifi devices. They are super small, cheap and work fine on any Windows PC. They work at the slow rates reported here on a R-Pi, I see 900 kbit/sec at first and even lower with sustained use. My solution is to use one with Atheros AR9271 chipset which is still pretty cheap, the specific one I got is $8 on ebay. I see about 10 Mbit/sec with the Atheros device.

rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Re: WLAN too slow

Sun Jan 26, 2014 7:13 pm

@jbuehl: Ty, I too went with another adapter.

@jbeale: Ty for the input. I did wind up buying a Edimax EW-7811Un and its working fine. With a bit of testing I was able to formulate a theory by testing that the other adapter when used on an old windows laptop was subject to severe slowdowns the lower the voltage to the device was. The more items I put between the laptop and the lower the voltage to the adapter should have gotten (I dont have any usb breakout boards currently) the lower the speeds got. More info on this here http://www.raspberrypi.org/phpBB3/viewt ... 26#p493626

So in a nutshell it seems voltage is what that adapter craves.

ppumkin
Posts: 82
Joined: Tue May 29, 2012 10:22 pm

Re: WLAN too slow

Sun Jan 26, 2014 7:18 pm

That explains why these dedicated power supplies do 5.25volts instead of 5volts. Yea I though something was wrong with the power on the USB.

Return to “Troubleshooting”