effemmeffe
Posts: 19
Joined: Thu Jan 10, 2013 1:25 pm

hang on df -h command

Sun Jan 20, 2013 7:10 pm

Hi, I'm using the latest XBian 1.0 Alpha 4.
XBMC is running smoothly, so I decided to add some work to my rapsberry and I installed Transmission and samba.
It worked fine for all day until tonight I decided to switch on the XBMC debug to try to solve a minor issue on library creation. Since then things went wrong. I normally connect via ssh to RPi to manage all but XBMC and if I type the command

Code: Select all

df -h
as normal user or even as sudoer the RPi hangs and I have to remove power to unlock it.
Some help, please?
TIA

M_P
Posts: 51
Joined: Sun Jan 06, 2013 5:40 pm

Re: hang on df -h command

Mon Jan 21, 2013 5:53 am

I had a similar problem this weekend. I picked up two SanDisk 8GB Class 4 cards and noticed that one of them made the Pi it was in very sluggish - ls would take 5-10 seconds just to display an empty directory. I swapped it between three different Pi to confirm it was the SD card, all three showed the same problem when using that card. Running df would hang, and reformatting and reinstalling on that card didn't seem to help. The other card worked just fine. Do you by chance have another card you can test with?

effemmeffe
Posts: 19
Joined: Thu Jan 10, 2013 1:25 pm

Re: hang on df -h command

Mon Jan 21, 2013 9:41 am

I have another card, I'll try to dump the entire card on it.
But this card worked like a charm for two weeks, can't believe it stopeed working all of the sudden...

matthiku
Posts: 2
Joined: Mon Jan 12, 2015 3:54 pm

Re: hang on df -h command

Mon Jan 12, 2015 4:27 pm

I had the same problem but it worked when using this syntax:

Code: Select all

df -hl
This checks only the 'local' devices. In my case, I had mounted a network device which was off-line and that's what caused the delay.

Return to “Troubleshooting”