TomoRTK
Posts: 1
Joined: Mon Jan 14, 2013 5:22 pm

SD Card Problem

Mon Jan 14, 2013 5:36 pm

Hi there,
I have a big problem with my Emtec 8 GB SD Card. Currently there is a latest version of Raspbian on the card, I copied it through Win32DiskImager. Whereas the system actually boots with no problem I messed something with it and I couldn't use apt-get. I want a clean install of the OS but I can't delete the partitions in any possible way. Every time I want to delete partitions, in any possible way - diskpart,gparted (from live cd),paragon partition manager, easeus pm, and so on, it gets to the moment when I select to delete 2 partitions that are left (56 MB FAT32 and 7,3 GB ext4) and then I try to create new, only one and big 8 GB Fat32 partition - it throws errors depending on software used. The content isn't deleted because I can still boot Raspbian. I tried on different computers with different card readers... Any ideas? Maybe the card got corrupted somehow? :(

Dominoes_Fall
Posts: 2
Joined: Sun Jan 13, 2013 11:38 pm

Re: SD Card Problem

Tue Jan 15, 2013 9:53 pm

Hi TomoRTK,

You could re-format the card using SDFormatter on a Windows PC. I have not yet found any SD card that cannot be restored to its new, "blank" condition by using this program.

This free program is from the SD Association, who set the standards world-wide for SD cards. You can download it from

https://www.sdcard.org/downloads/formatter_3

Good luck,
Andy

obcd
Posts: 917
Joined: Sun Jul 29, 2012 9:06 pm

Re: SD Card Problem

Tue Jan 15, 2013 10:08 pm

You can simply copy another Image on the card with Win32DiskImager.
You don't need to reformat the card before you start over.
Obvious you will find 2 partitions again afterwards, but it's contents should be a fresh install.

fransschreuder
Posts: 6
Joined: Mon Jun 04, 2012 7:18 am

Re: SD Card Problem

Wed Jan 16, 2013 12:06 pm

Have you checked that the card is not on lock? (little switch on the SD card)

Return to “Troubleshooting”