ZakharKapustin
Posts: 1
Joined: Mon Dec 14, 2020 1:51 pm

Usb device error

Mon Dec 14, 2020 1:55 pm

Tried Raspberry Pi 4 Model B 4GB + hub orico (with its own power supply) + modems (from 2 to 10) get error in log and as a consequence non-working modem. Changed the OS, changed to orange pi zero, all the same. I had read about the lack of power supply... But I installed Pine64 and everything worked. What can it be and how can I fix it on my Raspberry?

here is the error

Code: Select all

[    7.104760] usb 1-1.1.4.1: device descriptor read/64, error -71
[    7.334515] usb 1-1.1.3.2: new high-speed USB device number 12 using xhci_hcd
[    7.454770] usb 1-1.1.3.2: device descriptor read/64, error -71
[    7.684671] usb 1-1.1.3.2: device descriptor read/64, error -71
[    7.805023] usb 1-1.1.3-port2: attempt power cycle
[    7.914430] usb 1-1.1.4.1: new high-speed USB device number 13 using xhci_hcd
[    8.024691] usb 1-1.1.4.1: device descriptor read/64, error -71
[    8.254669] usb 1-1.1.4.1: device descriptor read/64, error -71
[    8.374954] usb 1-1.1.4-port1: attempt power cycle
[    8.714489] usb 1-1.1.3.2: new high-speed USB device number 14 using xhci_hcd
[    8.714848] usb 1-1.1.3.2: Device not responding to setup address.
[    8.934707] usb 1-1.1.3.2: Device not responding to setup address.
[    9.154493] usb 1-1.1.3.2: device not accepting address 14, error -71
[    9.494430] usb 1-1.1.4.1: new high-speed USB device number 15 using xhci_hcd
[    9.494746] usb 1-1.1.4.1: Device not responding to setup address.
[    9.714698] usb 1-1.1.4.1: Device not responding to setup address.
[    9.934424] usb 1-1.1.4.1: device not accepting address 15, error -71
[   10.044433] usb 1-1.1.3.2: new high-speed USB device number 16 using xhci_hcd
[   10.044736] usb 1-1.1.3.2: Device not responding to setup address.
[   10.264681] usb 1-1.1.3.2: Device not responding to setup address.
[   10.484459] usb 1-1.1.3.2: device not accepting address 16, error -71
[   10.485049] usb 1-1.1.3-port2: unable to enumerate USB device
[   10.594430] usb 1-1.1.4.1: new high-speed USB device number 17 using xhci_hcd
[   10.594725] usb 1-1.1.4.1: Device not responding to setup address.
[   10.814683] usb 1-1.1.4.1: Device not responding to setup address.
[   11.034427] usb 1-1.1.4.1: device not accepting address 17, error -71
[   11.035021] usb 1-1.1.4-port1: unable to enumerate USB device
[   14.104510] usb 1-1.1.3.3: device not accepting address 22, error -71                                                              [352/1930]
[   14.444511] usb 1-1.1.4.2: new high-speed USB device number 23 using xhci_hcd
[   14.444904] usb 1-1.1.4.2: Device not responding to setup address.
[   14.664724] usb 1-1.1.4.2: Device not responding to setup address.
[   14.884425] usb 1-1.1.4.2: device not accepting address 23, error -71
[   14.994468] usb 1-1.1.3.3: new high-speed USB device number 24 using xhci_hcd
[   14.994793] usb 1-1.1.3.3: Device not responding to setup address.
[   15.214740] usb 1-1.1.3.3: Device not responding to setup address.
[   15.434426] usb 1-1.1.3.3: device not accepting address 24, error -71
[   15.434983] usb 1-1.1.3-port3: unable to enumerate USB device
[   15.544438] usb 1-1.1.4.2: new high-speed USB device number 25 using xhci_hcd
[   15.544741] usb 1-1.1.4.2: Device not responding to setup address.
[   15.764717] usb 1-1.1.4.2: Device not responding to setup address.
[   15.984428] usb 1-1.1.4.2: device not accepting address 25, error -71
[   15.984960] usb 1-1.1.4-port2: unable to enumerate USB device
[   16.094444] usb 1-1.1.3.4: new high-speed USB device number 26 using xhci_hcd
[   16.204682] usb 1-1.1.3.4: device descriptor read/64, error -71
[   16.434690] usb 1-1.1.3.4: device descriptor read/64, error -71
[   16.664455] usb 1-1.1.3.4: new high-speed USB device number 27 using xhci_hcd
[   16.774715] usb 1-1.1.3.4: device descriptor read/64, error -71
[   17.014712] usb 1-1.1.3.4: device descriptor read/64, error -71
[   17.136133] usb 1-1.1.3-port4: attempt power cycle
[   17.824458] usb 1-1.1.3.4: new high-speed USB device number 28 using xhci_hcd
[   17.824772] usb 1-1.1.3.4: Device not responding to setup address.
[   18.044706] usb 1-1.1.3.4: Device not responding to setup address.
[   18.264450] usb 1-1.1.3.4: device not accepting address 28, error -71
[   18.374468] usb 1-1.1.3.4: new high-speed USB device number 29 using xhci_hcd
[   18.374767] usb 1-1.1.3.4: Device not responding to setup address.
[   18.594733] usb 1-1.1.3.4: Device not responding to setup address.
[   18.814446] usb 1-1.1.3.4: device not accepting address 29, error -71
[   18.815050] usb 1-1.1.3-port4: unable to enumerate USB device

kenadams_the
Posts: 24
Joined: Thu Nov 19, 2020 6:58 pm

Re: Usb device error

Tue Dec 15, 2020 7:49 pm

If it does not work with a 32 bit linux (e.b. Raspberry Pi OS 32) but works with 64 bit then stay with 64 bit.
https://downloads.raspberrypi.org/raspios_arm64/images/

My thread viewtopic.php?f=28&t=291752
I opened an issue on github but no progress so far... https://github.com/raspberrypi/linux/issues/3971

Return to “Troubleshooting”