piefairy
Posts: 12
Joined: Wed Dec 03, 2014 9:52 pm

Random text box

Tue Oct 13, 2020 5:31 pm

For some reason I keep getting a random text box popping up in the top right hand corner when using my raspberry pi 4. I run a program on the raspberry pi that is controlled with a remote control VIA an FLIRC receiver and it stopped working at random. On a closer look for some reason a little "search" box or something comes up in the top right corner of the screen and starts taking the inputs as keyboard keys and starts typing. It does the same thing with a keyboard when plugged in. Any idea what this is and how to turn it off? I cant narrow it down to one particular key causing it either. Any help would be appreciated.

Thanks

piefairy
Posts: 12
Joined: Wed Dec 03, 2014 9:52 pm

Re: Random text box

Tue Oct 13, 2020 5:39 pm

It is the same box that appears if you just start typing at the desktop with no program open. It is a terminal window since I can call programs from it.

pidd
Posts: 2351
Joined: Fri May 29, 2020 8:29 pm
Location: Wirral, UK
Contact: Website

Re: Random text box

Tue Oct 13, 2020 7:22 pm

I can't seem to run programs with mine, it takes the keyboard input when the desktop is the focus.

piefairy
Posts: 12
Joined: Wed Dec 03, 2014 9:52 pm

Re: Random text box

Tue Oct 13, 2020 7:34 pm

Is there a way to disable it? I've been able to consistantly recreate the issue, it seems one command makes a small overlay window that stays open for a few seconds and then goes away. If a button is pressed right after this window goes away and before focus is set back, about a 1 second window, it triggers commands to go to it. It may not sound like much but without a full keyboard to toggle back to the program its a pain in the butt when triggered. Commands keep going to this popup until you manually reselect the program with a mouse click or alt-tab to it. It seems its only desktop applications it will start when typing, not all commands.

pidd
Posts: 2351
Joined: Fri May 29, 2020 8:29 pm
Location: Wirral, UK
Contact: Website

Re: Random text box

Tue Oct 13, 2020 7:52 pm

Its searching for app shortcuts on the desktop. For some reason the app you are wanting to use is losing focus which is what you need to address, if the box wasn't there then your inputs would be lost as there would be nothing in focus.

piefairy
Posts: 12
Joined: Wed Dec 03, 2014 9:52 pm

Re: Random text box

Wed Oct 14, 2020 3:26 pm

I never had this issue on older version of Raspbian. If there is a way to turn off this text box I think it would be the fastest solution since I cant alter the software myself. As it sits right now if no buttons are pressed for a few seconds after the pop up window closes, then focus is never lost, its only in that brief moment.

piefairy
Posts: 12
Joined: Wed Dec 03, 2014 9:52 pm

Re: Random text box

Wed Oct 14, 2020 5:35 pm

Ok, I think I have found a workaround. Let me know if you think this would cause any issues. This Pi 4 is only running this one program so I think it should be alright.

I went to
/etc/xdg/lxsession/LDXE-pi/autostart

I commented out
#@pcmanfm --desktop --profile LDXE-pi

This disabled the desktop as well as the desktop search window that was popping up. The only change I can see in the environment is the lack of a desktop, so I feel like the search bar is in the default desktop profile.

I am not sure if this is a good long term fix or may affect something else, so if there is a way to edit the profile and comment out the search bar and still leave the desktop environment that would be preferred. Let me know if you know a way to do this.

VR_ICE
Posts: 1
Joined: Fri Dec 04, 2020 12:02 am

Re: Random text box

Fri Dec 04, 2020 12:15 am

I'm running into the same issue, when I type outside of an application the text appears in the top right of the screen.

I'm concerned that it may be key logger but I don't know enough about the system to be positive.

I tried reformatting the SD and starting over with a fresh install with no luck.

Just tried navigating to "/etc/xdg/lxsession/LXDE -pi" and running "sudo nano autostart" where I '/* pcman... */ ' to no avail.

Return to “Troubleshooting”