Page 1 of 1

I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 12:27 pm
by waspish_raccoon
Good day. I use Raspberry Pi 3 B+ and I have problems connecting to a hidden network. On the Internet people write that I need to add a line in file "/etc/wpa_supplicant/wpa_supplicant.conf" :
"scan-ssid"
But unfortunately it doesn't work for me.
Here is my code:
""
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=RU
network={
ssid="My Hidden SSID"
scan_ssid=1
psk="My SSID's Password"
key_mgmt=WPA-PSK }
"

What should I do in this case? Thank you in advance.

:) :) Sorry for my English. I'm not English.

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 3:06 pm
by beta-tester
don't you need also the bssid with the mac address of the adapter of the wifi you want to connect to (access point)?
bssid=<mac_of_access_point>

sudo iwlist wlan0 scan [essid <SSID>]
e.g.:

Code: Select all

sudo iwlist wlan0 scan essid "My Hidden SSID" | grep Address
Address: 01:23:45:67:89:AB
then bssid should be

Code: Select all

bssid=01:23:45:67:89:AB

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 3:16 pm
by kerry_s
just run ' sudo raspi-config ' and manually enter the info in the network section.

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 3:24 pm
by JovianPyx
I had the same problem while trying to configure a pi-zero-w as a porch pirate camera. I have never been able to get a connection with disabled SSID broadcast.

So I just now tried both of the suggested fixes above and neither worked for me. I am in the USA if that might matter.

In a discussion elsewhere, it was said that broadcast disable doesn't give much additional security over WPA/WPA2, so I just leave broadcast on.

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 3:34 pm
by trejan
JovianPyx wrote:
Thu Aug 06, 2020 3:24 pm
In a discussion elsewhere, it was said that broadcast disable doesn't give much additional security over WPA/WPA2, so I just leave broadcast on.
Disabling SSID broadcasting actually makes security worse. All of your devices need to do active probes to find the hidden SSID which means they're all broadcasting your SSID everywhere they go. Other management frames from your AP have the SSID in anyway.

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 7:04 pm
by DougieLawson
waspish_raccoon wrote:
Thu Aug 06, 2020 12:27 pm
Good day. I use Raspberry Pi 3 B+ and I have problems connecting to a hidden network. On the Internet people write that I need to add a line in file
Are you able to reconfigure the network AP to stop hiding the SSID? What reasons do you have for hiding it?

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 9:37 pm
by LTolledo
unhide --- connect --- hide

simple enough?

Re: I can't connect to a hidden network WiFi.

Posted: Thu Aug 06, 2020 11:21 pm
by HawaiianPi
waspish_raccoon wrote:
Thu Aug 06, 2020 12:27 pm
What should I do in this case?
What you should do is unhide your SSID, because it's pointless to hide it. It doesn't make your network more secure, and as someone already explained, it can even hurt security.

Also, the wpa_supplicant.conf you posted looks very odd.

Mine looks like this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
	ssid="WiFi SSID"
	psk="WPA/WPA2 passphrase"
}
Adding scan_ssid=1 to the network section should work for a hidden SSID (as far as I know).