hstvac
Posts: 10
Joined: Tue Aug 13, 2019 9:11 pm

Issues using full speed devices with USB 3.0 hubs

Sun Aug 02, 2020 5:08 pm

Hi. I found this article:

https://www.raspberrypi.org/documentati ... /README.md

which says
1. Interoperability between the Raspberry Pi and USB 3.0 hubs
There is an issue with USB 3.0 hubs in conjunction with the use of full- or low-speed devices (most mice, most keyboards) and the Raspberry Pi. A bug in most USB 3.0 hub hardware means that the Raspberry Pi cannot talk to full- or low-speed devices connected to a USB 3.0 hub.

USB 2.0 high-speed devices, including USB 2.0 hubs, operate correctly when connected via a USB 3.0 hub.

Avoid connecting low- or full-speed devices into a USB 3.0 hub. As a workaround, plug a USB 2.0 hub into the downstream port of the USB 3.0 hub and connect the low-speed device, or use a USB 2.0 hub between the Pi and the USB 3.0 hub, then plug low-speed devices into the USB 2.0 hub.
Forgive my ignorance, but I need some clarification: Does this mean external USB 3.0 hubs with USB 1.0 ("full speed") devices plugged into the Pi's 3.0 slots may have trouble? Or that the USB 3.0 ports on the Pi are considered "hubs" and that a USB 1.0 ("full speed") device plugged directly into the Pi's 3.0 slots may have trouble?

In other words, does "hub" refer to the ports on the Pi itself?

Extra credit: Does a USB sound device contain its own "hub"?

(Sorry just a little foggy on the terminology.)

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2432
Joined: Thu Jul 11, 2013 2:37 pm

Re: Issues using full speed devices with USB 3.0 hubs

Sun Aug 02, 2020 5:58 pm

The heading above the section you're reading states that the restriction only applies to products that aren't a Pi 4.

The USB3 "hub" is actually a USB2 hub and a USB3 hub connected to the same port. If you plug USB1.1 devices into a USB3 hub, they will appear as children of the USB2 hub. Similarly, if you plug USB1.1 devices into any port on a Pi 4, they will appear as child devices on the USB2 bus.
Rockets are loud.
https://astro-pi.org

hstvac
Posts: 10
Joined: Tue Aug 13, 2019 9:11 pm

Re: Issues using full speed devices with USB 3.0 hubs

Sun Aug 02, 2020 7:22 pm

"The heading above the section you're reading states that the restriction only applies to products that aren't a Pi 4."

Gah! Thank you for pointing this out and clarification on the ports on the Pi 4B.

Return to “Troubleshooting”