User avatar
moscardo
Posts: 5
Joined: Tue Dec 26, 2017 11:22 am
Location: Milan, Italy
Contact: Website Twitter

Rpi4 audio glitching problem

Sun Aug 02, 2020 8:13 am

Hy guys,

I'm experiencing some strange problem with audio coming from my RaspberryPi 4.
I'm not able to understand if it is something related to hardware (audio connection) or to the software.
In a few words audio is glitching/stuttering/digitally clicking don't know ho to better describing it.

Please find attached a recording I've made from a pair o headphones connected to the audio jack output of the pi

pi4_audio_problem.mp3.zip
audio file problem recording
(72.64 KiB) Downloaded 12 times

The problem is not always present: sometimes it start since booting the pi, other time it suddenly appears after some time the pi is running, some other time, from being present, the audio problem disappears without any reason.
The problem is there even if I lower the audio volume from the GUI (audio icon on the upper right corner).

The Pi is powered by its official power supply adapter. It is connected (via HDMI 0 port) to a HDMI monitor.
Audio is forced to the Jack output (via raspi-config).

Have you ever faced something similar?
How can I better debug it?
How can I solve?

Thank you so much for your support.

pidd
Posts: 1098
Joined: Fri May 29, 2020 8:29 pm
Location: Birkenhead, Wirral, UK
Contact: Website

Re: Rpi4 audio glitching problem

Sun Aug 02, 2020 8:48 am

Is the audio you are playing coming over wifi or is it a file on the same Pi?

If it is over wifi have you tried downloading a file and playing it locally?

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2436
Joined: Thu Jul 11, 2013 2:37 pm

Re: Rpi4 audio glitching problem

Sun Aug 02, 2020 11:46 am

Does the noise occur if you run speaker-test? Run speaker-test -c 2 -t sine
Rockets are loud.
https://astro-pi.org

User avatar
moscardo
Posts: 5
Joined: Tue Dec 26, 2017 11:22 am
Location: Milan, Italy
Contact: Website Twitter

Re: Rpi4 audio glitching problem

Sun Aug 02, 2020 12:55 pm

Thank you @pidd for your quick replay
pidd wrote:
Sun Aug 02, 2020 8:48 am
Is the audio you are playing coming over wifi or is it a file on the same Pi?

If it is over wifi have you tried downloading a file and playing it locally?
The audio i'm playing is the audio of an MP4 video file.
The same setup (same video file, so same audio) is working fine on other three RPi 4 (same OS, same installed packets, etc...).

worth mentioning: audio problem persist if I'm not playing anything: if pi is silent, listening to the headphones you hear the noise!

User avatar
moscardo
Posts: 5
Joined: Tue Dec 26, 2017 11:22 am
Location: Milan, Italy
Contact: Website Twitter

Re: Rpi4 audio glitching problem

Sun Aug 02, 2020 12:58 pm

jdb wrote:
Sun Aug 02, 2020 11:46 am
Does the noise occur if you run speaker-test? Run speaker-test -c 2 -t sine
Thank you @jdb for you quick reply.
I didn't know this command. I'll try it and I let you know!

Do you think the issue could be related to something wrong on the RPi system setting?

Initially I've had the suspect this could be related to some loose hardware connection on the audio jack port (or something similare) but, from the moment the issue seems to appears randomly, I am more inclined to believe it may be something software related...

Return to “Troubleshooting”