Posts: 1
Joined: Thu Jul 30, 2020 3:10 pm

PI 4 8gig no sound ever

Thu Jul 30, 2020 3:21 pm

My background is linux and Unix although i haven't got my hands dirty for a while since moving into management but i decided to get one if these RPi's

i went for the new model four 4 8 gig model so far i have managed to install software ok but as yet not a sound from the unit except when i borrowed a USB plug in Cambridge Audio Day.

I have tried everything to get the onboard 3.5mm jack to work tried headphone and powered speakers - nothing

i have now purchased an innomaker Rasp Pi HiFi DAC Hat PCM5122 Audio Sound Card Expansion Board following all the instructions i cant get that to produce sound either.

I have a cd drive attached and running KSCD but not sound even with the correct output selected

Any suggestions

Posts: 664
Joined: Thu Oct 23, 2014 12:14 am
Location: Texas
Contact: Website

Re: PI 4 8gig no sound ever

Thu Jul 30, 2020 7:25 pm

Are you running the 5.4 kernel and the vc4-kms-v3d overlay?

Posts: 2
Joined: Tue Aug 04, 2020 12:33 pm

Re: PI 4 8gig no sound ever

Tue Aug 04, 2020 12:41 pm

I have the same model of Pi 4 as you and also had the same problem. I found the solution in the following very helpful post, which I have tried and the sound is working fine now via the onboard 3.5mm socket.

viewtopic.php?f=38&t=263942&p=1706540&h ... k#p1706540

Hope it works for you too!

Return to “Troubleshooting”