KuupoLOL
Posts: 6
Joined: Sun Dec 30, 2012 2:00 pm

Raspi not reading the SD -card [obsolete]

Sun Dec 30, 2012 2:13 pm

Hi,
I know this has been discussed a lot before, but I couldn't find a solution.
So my pi refuses to boot, I used this card before with my pi and it worked fine, but after reflashing the card it does not read the card. The power light is the only light lighting.
I have tried reflashing again several time both from windows and linux, cleaned the contacts on both the card and pi, tried without anything but monitor attached (HDMI). I've also tried switching the PSU to a different one, my current on provides 1.2A, I tried with a dofferent 700mA one and no luck either.
I see the partitions on a linux computer and the FAT partition on windows so it is flashed properly via dd.

Thanks for any help provided!

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: Raspi not reading the SD -card

Sun Dec 30, 2012 11:01 pm

Not sure what os you are putting on the card, but did you check the checksum for the file you downloaded to make sure image itself is intact?

If you have an image that is not 100% correct for some reason, you could be successfully flashing it to the SD card, but it would still fail to boot the RPi.

Also, does the green ok led flicker at all when you power up the pi?

Some times the contacts for the SD card do not actually make contact so gently pressing the contact area of the sd card down as you power it on might get it to boot. You would then need to carefully bend up the spring contacts for the sd card. The wiki I believe describes how to do that.

Just a couple of possibilities.

KuupoLOL
Posts: 6
Joined: Sun Dec 30, 2012 2:00 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 2:26 pm

No, I did not check the checksum, mostly because of Intel Atom generates it pretty slowly.
The green light does not flicker.

I forgot the card, its kingston 8Gb class 10 which is on the supported list.

InvernessTMD
Posts: 26
Joined: Sun Dec 16, 2012 1:25 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 3:40 pm

I am having a similar issue, I can get the Pi to partially boot but then it stops with a message saying it cannot boot further.
I have run the Windows Checksum and I guess the string of letters/numbers on the download page should match up with the result on the Checksum? They don't, despite downloading several times.
Any Ideas?
Cheers

ITMD

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 3:49 pm

As to the check sum matching: are you calculating the checksum on the .zip file or the .img file you get out of the zip file?

The checksum on the download page from raspberrypi.org is for the .zip file, it will not match if you calculate your checksum on the .img file extracted.

InvernessTMD
Posts: 26
Joined: Sun Dec 16, 2012 1:25 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 5:06 pm

The instructions say use the img rather than the zip... Just tried it using the zip and it matches!
Will re-do the SD card and try again! (SanDisk SDHC, class 4, 32GB)

Kbho
Posts: 18
Joined: Sun Dec 30, 2012 4:23 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 5:29 pm

If that doesn't work, reformat to Fat32 and copy the files for BerryBoot over, and then that allows you to install from .img, or it can automatically download the file. It also has support for multiple operating systems.

stevhorn5
Posts: 116
Joined: Wed Jul 04, 2012 5:47 pm
Location: Ontario, Canada

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 5:52 pm

KuupoLOL wrote:I forgot the card, its kingston 8Gb class 10 which is on the supported list.
Which model Kingston 8Gb class 10 card do you have? I have a SD10V/8GB and it has been problematic for me. I also have a couple of Kingston Class 4 cards which won't boot at all.

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 6:00 pm

InvernessTMD wrote:The instructions say use the img rather than the zip... Just tried it using the zip and it matches!
Will re-do the SD card and try again! (SanDisk SDHC, class 4, 32GB)
Could you point me to those directions? I'll try and make sure they get corrected.

KuupoLOL
Posts: 6
Joined: Sun Dec 30, 2012 2:00 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 7:09 pm

Oops, the card was sandisk extreme 8Gb class 10.
Remembered another card :D

InvernessTMD
Posts: 26
Joined: Sun Dec 16, 2012 1:25 pm

Re: Raspi not reading the SD -card

Tue Jan 01, 2013 8:26 pm

http://downloads.raspberrypi.org/verify ... image.html under windows users...
I tried it using the zip and it works, now boots to the login, though for some reason although the ATI Remote Wonder 2 has the alphabet showing above the numbers like a phone, I cannot access them!!
(heads off to find a cheapo keyboard!)

User avatar
wallarug
Posts: 460
Joined: Mon May 14, 2012 8:21 am
Location: Sydney, Australia

Re: Raspi not reading the SD -card

Mon Jan 14, 2013 12:24 am

KuupoLOL wrote:Oops, the card was sandisk extreme 8Gb class 10.
Remembered another card :D
Same Card, Same Problem.

KuupoLOL
Posts: 6
Joined: Sun Dec 30, 2012 2:00 pm

Re: Raspi not reading the SD -card

Fri Jan 18, 2013 7:35 pm

Did not get it working, unfortunately, bought a cheap sandisk card and rootfs on 120Gb laptop drive 8-)

ChuckThibodeau
Posts: 8
Joined: Wed Jun 11, 2014 2:31 pm

Re: Raspi not reading the SD -card

Sat Jul 19, 2014 1:25 am

THANKS! I've been working on something like a Drone, and during the prototyping fase, the tires ran into the sd card and the card stopped making contact. I've been searching for hours(possibly over a day) for the solution! And simply by pressing my thumb on the card..... IT BOOTED! Bitter sweet to have such a simple solution to a problem that perplexed me for so long.

bgirardot wrote:Not sure what os you are putting on the card, but did you check the checksum for the file you downloaded to make sure image itself is intact?

If you have an image that is not 100% correct for some reason, you could be successfully flashing it to the SD card, but it would still fail to boot the RPi.

Also, does the green ok led flicker at all when you power up the pi?

Some times the contacts for the SD card do not actually make contact so gently pressing the contact area of the sd card down as you power it on might get it to boot. You would then need to carefully bend up the spring contacts for the sd card. The wiki I believe describes how to do that.

Just a couple of possibilities.

simonelawrence
Posts: 2
Joined: Mon Jan 04, 2016 4:58 pm

Re: Raspi not reading the SD -card

Mon Jan 04, 2016 5:11 pm

Hi,

I have two Raspberry Pi model B v1.1

Both were up and running fine since Sept 2015 when I purchased them.
I have HDMI monitors and USB mouse and keyboard connected to both (individually).

One of the Raspberry Pi's(Alpha) will not boot. The other Raspberry Pi (Beta) boots normally.

Alpha's Red Power LED is on and stays on and the Green ACT LED turns on but does not blink. The Ethernet Nic has no LEDs on
1. Tried swapping Pi's. Beta worked with all of the Alpha monitor/nic/monitor/keyboard. Alpha did not work with Beta's monitor/nic/keyboard/mouse.
2. Tried swapping SanDisk 8GB micro SD card. The SD card from Alpha worked fine in Beta. Beta's card did not work in Alpha

Not sure what else to check.
Any Help would be appreciated. Thanks

slothonmeth1
Posts: 8
Joined: Tue May 28, 2019 3:45 am

Re: Raspi not reading the SD -card

Wed Sep 25, 2019 5:34 pm

bgirardot wrote:
Sun Dec 30, 2012 11:01 pm
Not sure what os you are putting on the card, but did you check the checksum for the file you downloaded to make sure image itself is intact?

If you have an image that is not 100% correct for some reason, you could be successfully flashing it to the SD card, but it would still fail to boot the RPi.

Also, does the green ok led flicker at all when you power up the pi?

Some times the contacts for the SD card do not actually make contact so gently pressing the contact area of the sd card down as you power it on might get it to boot. You would then need to carefully bend up the spring contacts for the sd card. The wiki I believe describes how to do that.

Just a couple of possibilities.
Could you link a post that details how to bend the springs back up? I couldn't find anything useful other than people replacing the whole thing

User avatar
B.Goode
Posts: 8987
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Raspi not reading the SD -card

Wed Sep 25, 2019 7:21 pm

slothonmeth1 wrote:
Wed Sep 25, 2019 5:34 pm

Could you link a post that details how to bend the springs back up? I couldn't find anything useful other than people replacing the whole thing

7 years further on the specifications have changed: no currently available model of Raspberry Pi board, including your RPi 3, still has a card reader slot for an SD card.

Return to “Troubleshooting”