Page 1 of 1

St7735 showing gibberish

Posted: Wed Apr 29, 2020 3:30 pm
by bfg-e
Image
Hi , today I wanted to add an st7735s display to my pi to can play games on retropie. I checked the wiring and it's good .
What should I check ? I tryed adjusting the resolution and rotation but it doesn't help
20200429_182832.jpg
20200429_182832.jpg (53.88 KiB) Viewed 286 times

Re: St7735 showing gibberish

Posted: Wed Apr 29, 2020 8:46 pm
by DougieLawson
What Raspberry?
What OS?
Where did you get the display? Does the manufacturer/vendor have some instructions for connecting it to a RPi?

Re: St7735 showing gibberish

Posted: Thu Apr 30, 2020 6:37 am
by bfg-e
DougieLawson wrote:
Wed Apr 29, 2020 8:46 pm
What Raspberry?
What OS?
Where did you get the display? Does the manufacturer/vendor have some instructions for connecting it to a RPi?
I use a raspberry pi zero(non w)
Retropie
I got it from aliexpress ,the display is an ST7735S . It worked well with python3(with aditional libraryes i maked it show pictures on the screen)

Re: St7735 showing gibberish

Posted: Thu Apr 30, 2020 6:49 am
by fruitoftheloom
bfg-e wrote:
Thu Apr 30, 2020 6:37 am
DougieLawson wrote:
Wed Apr 29, 2020 8:46 pm
What Raspberry?
What OS?
Where did you get the display? Does the manufacturer/vendor have some instructions for connecting it to a RPi?
I use a raspberry pi zero(non w)
Retropie
I got it from aliexpress ,the display is an ST7735S . It worked well with python3(with aditional libraryes i maked it show pictures on the screen)

Please can you link to the product page of the ST7735S you purchased, there are hundreds for sale on AliExpress.

Re: St7735 showing gibberish

Posted: Thu Apr 30, 2020 7:24 am
by bfg-e
[/quote]


Please can you link to the product page of the ST7735S you purchased, there are hundreds for sale on AliExpress.
[/quote]

https://www.aliexpress.com/item/3290685 ... 4c4d3nTENH

It worked well also with test codes from arduino library (using an arduino uno, if this matters)

Re: St7735 showing gibberish

Posted: Thu Apr 30, 2020 4:11 pm
by bfg-e
hi , i got it to work , but only in 128x128 resolution. If i set 160x128 it make the image at a 45 degree angle (it just shows up the 128x128 picture and instead of breaking the line at the pixel 128 it continues up to 160)

Re: St7735 showing gibberish

Posted: Fri May 01, 2020 10:58 am
by tipam
Hi - I did a quick (non-technical) video on connecting this type of screen to the Pi just yesterday ... try it out and see if it works on yours ..

https://www.youtube.com/watch?v=ST2sDStY-oA

It might not address the RetroPi issue but it might help to check your screen ;)

Ps. Pi in vid was using latest Raspbian Buster