Page 1 of 1

Unable to watch YouTube videos

Posted: Thu Mar 26, 2020 11:48 am
by etjkai
I'm just fiddling around, and trying to surf YouTube using my Raspberry Pi.

However, the videos are stuttering, and doesn't have any sound at all.

I know that I can't expect any high-end performance from it, but I'm hearing that people are able to watch YouTube, and am wondering what I'm doing wrongly.

I'm using the Raspberry 3 Model B, with NOOBS installed. I have tried to remove bloatware from the Pi too, if it is supposed to help.

Re: Unable to watch YouTube videos

Posted: Thu Mar 26, 2020 12:48 pm
by fruitoftheloom
etjkai wrote:
Thu Mar 26, 2020 11:48 am
I'm just fiddling around, and trying to surf YouTube using my Raspberry Pi.

However, the videos are stuttering, and doesn't have any sound at all.

I know that I can't expect any high-end performance from it, but I'm hearing that people are able to watch YouTube, and am wondering what I'm doing wrongly.

I'm using the Raspberry 3 Model B, with NOOBS installed. I have tried to remove bloatware from the Pi too, if it is supposed to help.

NoobS is not an Operating System it is an installer /chooser !


Grab a spare SD Card and try LibreElec:

https://libreelec.tv/

Re: Unable to watch YouTube videos

Posted: Thu Mar 26, 2020 12:58 pm
by snowballEarth
Dunno the situation where you live, but internet speeds could be suffering due to vast numbers of people forced to stay indoors and going online.
Apart from that there could be a number of reasons. The Chromium browser doesn't do YouTube well at 60fps, especially on the Pi3. You can lock video at 30fps by the h264ify icon in the top right corner. Try lowering video quality down to 720p or lower.
Have you got good speeds within your home network? is it wired or wireless? Are other devices using bandwidth?
You may see better performance by increasing gpu memory to 192, through start>preferences>raspberry pi configuration