MishterKirby
Posts: 8
Joined: Fri Apr 12, 2019 2:09 pm
Location: Elmendorf, Texas

Chromium is slow on a Raspberry Pi 4

Thu Mar 12, 2020 7:22 pm

I recently got a Raspberry Pi 4, and browsing the web is slow, as in it takes about 10 seconds for the suggestions to start appearing, and scrolling stutters a lot. Anyone have any ideas on what it could be?
Roses are red,
Violets ain't blue,
Uno Reverse,
NO U!

User avatar
kerry_s
Posts: 1252
Joined: Thu Jan 30, 2020 7:14 pm

Re: Chromium is slow on a Raspberry Pi 4

Thu Mar 12, 2020 8:15 pm

is it a stock setup?

could it be slow internet, since you only say chromium?
what brand & resolution is your tv/monitor?
are you using a class 10 sdcard?

nope, no idea. :D

MishterKirby
Posts: 8
Joined: Fri Apr 12, 2019 2:09 pm
Location: Elmendorf, Texas

Re: Chromium is slow on a Raspberry Pi 4

Thu Mar 12, 2020 8:29 pm

kerry_s wrote:
Thu Mar 12, 2020 8:15 pm
is it a stock setup?

could it be slow internet, since you only say chromium?
what brand & resolution is your tv/monitor?
are you using a class 10 sdcard?

nope, no idea. :D
1. Mostly stock
2. I use an AOC 2476VWM at 1920*1080
3. I use a class 4, maybe that's the problem, I'll try running agnostics on it to see, but IIRC, my (dead) Pi 3 didn't have that problem, and it used a class 4

Also, side note, Midori works fine, Chromium causes the Pi to lag
Roses are red,
Violets ain't blue,
Uno Reverse,
NO U!

User avatar
kerry_s
Posts: 1252
Joined: Thu Jan 30, 2020 7:14 pm

Re: Chromium is slow on a Raspberry Pi 4

Thu Mar 12, 2020 8:48 pm

are you using an updated raspbian buster?

chromium is the only browser optimized for the pi.

MishterKirby
Posts: 8
Joined: Fri Apr 12, 2019 2:09 pm
Location: Elmendorf, Texas

Re: Chromium is slow on a Raspberry Pi 4

Thu Mar 12, 2020 9:19 pm

Latest version, though the Pi stutters here and there very once in a while, so I think it might be the SD card.
Roses are red,
Violets ain't blue,
Uno Reverse,
NO U!

tonybaynes
Posts: 2
Joined: Sun Oct 15, 2017 10:33 pm

Re: Chromium is slow on a Raspberry Pi 4

Fri Jul 03, 2020 11:46 am

A few days ago I noticed that Chromium was running very slowly on both my RPi4's, the 4gb and the 8gb versions. I'm running the 64bit RPi OS, and it's fully updated. To compare, I installed Firefox, and Firefox is working normally. I thought that it might be due to an overdose of cookies and cache, so I've cleared that in setting, but the problem still persists. My question is, is anyone else having the same problem, and does anyone know of a solution?

I would happily change to Firefox, but I have all my favourites saved in Chromium. Maybe there's a way to import them into Firefox, I'll check on that.

PiUser10
Posts: 42
Joined: Mon Dec 30, 2013 9:20 am

Re: Chromium is slow on a Raspberry Pi 4

Fri Jul 03, 2020 11:52 am

You may have updated to what appears to be a faulty Version 83 of the chromium browser.

See post myself and others have put in the following forum topic

viewtopic.php?f=63&t=275372&start=156

LTolledo
Posts: 3909
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Chromium is slow on a Raspberry Pi 4

Fri Jul 03, 2020 12:36 pm

its not slow on my setup.....
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

MishterKirby
Posts: 8
Joined: Fri Apr 12, 2019 2:09 pm
Location: Elmendorf, Texas

Re: Chromium is slow on a Raspberry Pi 4

Sun Jul 05, 2020 5:15 pm

Maybe try switching to a class 10 card? That's what solved my problem.
Roses are red,
Violets ain't blue,
Uno Reverse,
NO U!

deluxexbr
Posts: 5
Joined: Wed Jul 08, 2020 1:34 am

Re: Chromium is slow on a Raspberry Pi 4

Wed Jul 08, 2020 1:36 am

I am having this problem too. This week I did full upgrade and continue to get a slow chromium.

Anyone can help?

MishterKirby
Posts: 8
Joined: Fri Apr 12, 2019 2:09 pm
Location: Elmendorf, Texas

Re: Chromium is slow on a Raspberry Pi 4

Fri Jul 10, 2020 12:42 am

deluxexbr wrote:
Wed Jul 08, 2020 1:36 am
I am having this problem too. This week I did full upgrade and continue to get a slow chromium.

Anyone can help?
Can you describe your setup? Like what Raspbian version you're using, and what SD card you have?
Roses are red,
Violets ain't blue,
Uno Reverse,
NO U!

User avatar
Gavinmc42
Posts: 4636
Joined: Wed Aug 28, 2013 3:31 am

Re: Chromium is slow on a Raspberry Pi 4

Fri Jul 10, 2020 1:22 am

Did the same thing and Chromium got very slow.
Updated from ver 80 to 83.
Latest 83 build is a better than the first 83 build.

I am now running this one after another update/upgrade.
Version 83.0.4103.116 (Developer Build) built on Debian 10.4, running on Debian 10.4 (64-bit)
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

Return to “Troubleshooting”